3.7.9 alpha release

I have lost something.
Where to download 3.7.9?

Sending you the link in private as this alpha is not public yet... Your feedback will be welcome...

Hello!

For testing, installation as upgrade from 3.7.8 (with Reiser4) on the eeepc 1015pn (Atom N550, 2Gb)...
Comes right with nvidia privative's (340xx here)...
When installing: asking for EFI, (available but booted in legacy..), In BIOS, ATA/IDE Enhanced (can be Disable or Compatible too), SATA as AHCI, the SSD is in gpt with 2 linux systems (Elive + Elive-ed CAELinux) and a "home but not /home" (plus stuff as the 1Mb "bios" (By mistake, and when asking for the 8Mb one I say "No" and it's right nevertheless) & 256 "boot"")...

Going to test aside on the Dell M4400 (live)...

Ih!

1 Like

So: For the Dell M4400 (Q9300, 4Gb, nvidia Quadro FX770M), it runs good with the nvidia 340xx privative...
Fn keys for screen light & sound are all ok!

[general] Still double system monitor in the Elive Menu /Utility: one GNOME ~ & one ~ witch are the same one (or not?) and in /Audio, same with Volume control & PulseAudio ~ , MusicBrainz Picard (one with icon the other without) in /Video, Cheese x2 too; /Enlightenment/Desktop/Backgrounds gives no way (yes, possible via /Settings, but...) And Logout directly logs out without asking for just log out, reboot, halt or so (yes, possible thru CairoDock after ad hoc configuration, but...)...

Salutations!

... :warning::warning::warning: ...
Be aware -
Reiser4 will NOT being supported by Elive
anymore = :skull_and_crossbones:
:broken_heart:
...
Switch to Ext4 asap, pls... :+1:

... :hooray:

1 Like

Yep, I see..! :hot_face::see_no_evil:

:+1:
Thanx for report :hug:

Having to try too with the "nouveau" free nvidia driver, but "normally" may be ok...

Answer post specifically for @maxinou reports:

Mmmh... I reproduced the same steps and not was my case, after to select the root partition to use it asked me which FS to use on it and then asked me the confirmation to format it, normal (clean) installation proceeded later

Notes:

  • BEFORE to ask the partitioner and everything else it asks if you if you want to upgrade an elive found on the computer (but then should not ask for the partitioner to use, so should have been not your case)
  • make sure that your installer is always updated to the last version (just have the computer connected to internet before to install)
  • using gnome-disks to "add a mountpoint" doesn't makes any effect, probably only in your installed system but not on live mode (any configuration that gnome-disks could add to the Live fstab will be not included in the installed mode, this is a newly generated one by the installer)

an upgraded system doesn't include previous old repo entries, this is wanted for the reliability of the system, modfiying default repos is very dangerous (leads to breakages) and should be made with caution, is not wanted to re-use them unless the user really-wants it (manual adding them again)

so, i cannot do anything with this issue since i was unable to reproduce it using the same steps.. strange

I don't see any reason that this report would be not true (I mean, it was really damaged :slight_smile: ), but maybe the message needs to explain better... let me explain what happens:

It is very common than an USB become "damaged", this is due to many writes / usages, but the best is to see it yourself when you see something strange, just run "sudo dmesg" and check what says the messages, it should say things like "error /dev/sdb" (or whatever usb device is) or also "squashfs errors", its good to know which exact messages is saying

the good news is that 95% of the times you can "revive" the damaged USB's filling them with zeroes, but for that i suggest you to use usb-bootable-elive tool with the just newly introduced feature, for that run:

usb-bootable-elive --clean elive_3.7.9_alpha_hybrid_amd64.iso

you can add the option "-s" for simulation-mode and the "--auto" for not ask which USB device to write (autodetecting which is your USB)

maybe you "moved" the usb in the live mode, this can become an error too by having a small disconnection to its connectors

so basically, if you see this message again:

  • try to make a screenshot with your phone or simply note the exact message, in order to know from where it comes (which type of "error detected" has triggered it)
  • run "sudo dmesg" to know what happened exactly and what are these errors that says

as you said, next the system detected only 3.0.6 but not your previous 3.7.8, this is normal since that previous install "break" and your system was not marked as a "correctly installed system", so it is not included on the list, hum... maybe this can be improved on the installer by -still- including them on the list for the upgrade-mode cases

Next steps that you said sounds a bit confusing, but I assume this is what happened:

  • 3.0.6 was listed (only this one) for upgrade, and it worked fine
  • 3.7.8 partition still having your old files with all your data available, but it doesn't shows (list) as a system able to upgrade
  • sdaZZ is your working data, you said that has been formated? what could have caused this? the installer should not format anything that you don't select to do... maybe it was on reiser4 and its unreadable this filesystem now?

i have seen (and fixed) something recently that looked to have caused this, so tell me if you see it again on an install with 3.7.10+

.... and also Calamares as update manager in detail (but Thana already pointed it out = :frowning: )
.... pitty :disappointed:

???? :stuck_out_tongue::stuck_out_tongue::stuck_out_tongue:
.
.
.:rofl:

@maxinou, HP Mini, 32 bit, 2 GB RAM
was this not your machine with a harddisk issue (!?!??)

Im betatesting the installer but for now i was able to exit from it in any moment that I want, I would need to know the exact steps which will require a "cancel/abort" button

About the "cancel / panic" option, I'm changing a few options like this:

image

basically for the "do you want to add another partition?", which i think that is the case where is the most wanted / needed

mmmh, maybe the buttons should be added in the inverse order :thinking: but the default (other) question dialogs are always in the other " no + yes" :thinking:

reiser4 note:

3.7.10 will use kernel 5.2, without reiser4

3 Likes

Yes, especially there, actually anywhere where partitioning is concerned. That's the real danger zone.
Basically in the picture you have there, it would actually be best to start over again with the partitioner (or cancel totally and start over) because chances are that:

  • Either the root partition is already hogging the beginning of the disk (so will have to be moved/resized)
  • or there are other, older boot/efi partitions there that need manipulating.
  • After which we need a concise overview over what is going to be submitted and if the user is happy with that, or not......it's the point of no return after all.

In general it's with the partitioning where the shit hits the fan, one cannot be carefull enough there.

2 Likes

Hello!

For the eeepc 1015pn, I fit via synaptic eeepc-apci-tools, but seems useless (still no fn keys for sound & screen light)...
Same machine, still bad datas about battery (indicate always 100% (but helas not true :wink: ) & max capa 97%)...
It seems that there's a problem with hibernation: screen stops, but computer continue to have leds & fan on...

I think that the Cairo-Dock should be configured ab initio with the "disconnect" icon, to have easy access to stop, restart, hibernate, or so..?

EDIT

Dell M6700/nvidia M5000M: fn keys for sound & screen light ok! ...

Salutations!

2 Likes

I agree
Else new user will click Restart in the e16 menu and endup restarting the configuration of the Desktop

1 Like

Hi!

Testing on eeepc 1001px (live): very good!
As already said, this one is usualy, for now on 3.0 with its nice E17, and a big differance with Elive x64 is that on x32, the cpus (2) tends to be at 100%, where in x64, to push them both to this rate, I, e.g. launch synaptic downloading, installing stuff + the demo "rupture by asd" via vlc at 1.6 speed before having some lag..!
(well, I made the system freez launching Opera web with 6 tabs plus a privative window for a YT video & vpn... ;-p )

Beside that, I notice a thing: when lauching the very same iso on this 1001px eeepc than on the 1015pn one, it appears that on 1001 the eeepc-apci-tools are ab initio installed, but not for the 1015..?
On the 1001, fn key for light are ok but not the sound ones, when on the 1015, as previously writed, none are functional (even after installing eeepc-apci-tools)...
An other special thing: for the first time on the 1001px, I can set Opera's vpn (comes "blue" when stays "orange" (not ok) before, even on previous x64 Elive)...

Here you are, for now!
Salutations!

1 Like

In my case system asked me for root partition (OK) but not asked me for file system (i use always ext4 for all my partitions including data one) and start the upgrade, when my first choix was a new one...

As I had choice a new clean installation it was useful that system asked me for use a partitioner tool, as it did

Yes, it was the case, be sure.

i didn't know that, good to know for the future

Don't worry, and yes, it was very strange but maybe as @Rebel450 saw later, is due to my broken HDD????? maybe it's the guilty..... I didn't think to this option....

What I meant was that the same ISO file and the same USB Flash memory were used the day before to install 3.7.9-32 in my Acer laptop without issues...

Good to know, and here you have a picture of those message, I'm sorry, in French, not in English (BTW, the barcode is still in present in live mode LOL):

Yes, is exactly as this....

That is that worries me installer never asked me nothing about /sdaZZ partition that NEVER should be formatted because no file systems was inside, only my own work data (backed-up in an external HDD so no data lost)

Nice to has been helpful

Yep, you're right so maybe the issue cames from my broken HDD, you've a good memory :+1: I didn't even think to that possibility

Yes I think in the same way

I'm doing this now to perform a new 32 bit installation from USB Flash, I'll do the same with my other USB flash that contains 64 bit release

yep, i experienced this feeling too, like forced to continue while selecting extra partitions and thinking "oh wait! i would need to create a another partition bla bla"

so this is specifically solved now :slight_smile:

tell me if you see another place where an "abort" button is needed :applause:

added customized logout icon in cairo-dock
also the hotkeys pdf launcher custom app

(for next build, or use elive-skel at your own)

the eeepc-acpi-tools are dynamically installed/removed depending of the "detected" machine :slight_smile: , tell me if there's any wrong setting by default (installing/removing the package when its needed / not-needed on each machine, a reboot will be needed probably)

yeah but i was unable to reproduce the same issue :confused: , using the same steps... if next time happens again to you, we will need to know the "why" and checking how to reproduce them

check your collected data from:

cat /etc/elive/disks-health

the pendings are the bad ones, the reallocated are "not so good" but probably not an issue

well, it can happen if your usb moved during installating like wrong connection on it, but again, the best is to "sudo dmesg" to see which kind of errors shows when it says that (which the installer should in fact report what exactly happens, if the info is correctly wrote)

ok i see the picture, but "sudo dmesg" will be needed to know what it says (from where is the error), and I strongly suggest you to use usb-bootable-elive with the -c option :slight_smile: which will "revive" any possibly damaged usb (over the time, they sometimes produces errors)

Humm... this is a delicated thing, for security the installer won't show you as an upgradeable system a system which didn't installed correctly, I can improve the installer to ignore this "mark" for the "upgrading/migration" modes on which the system should be much more "better installed", but again, since the installation didn't finished correctly (and you had a first successful boot), it could be "half"-correctly-installed, like missing things and specially configurations of the system, like mountpoints, users, etc... This means that you could have the option available but without a guarantee that the upgrade would work fine (again, since its not a verified of correctly-installed system). This is a good or a bad thing to have? im not sure... its a security measure in fact :thinking: :thinking:

mmh, this is very strange issue, im not sure if i can find some information from your reports but i can try it

20190725-17:04:20__ae9ecdd43057ee75637231adfc0151d5e71c54fd__0__lxx@gmail.com__3.7.8____.gz
20190908-17:16:28__a10112623baf80ec4de2d78e908323e69718b21e__0__lxx@gmail.com__3.7.9____.gz
20190909-12:25:07__dace706b7695edb61c5dc2eb2f2affd55c77bd33__0__lxx@gmail.com__3.7.9____.gz
20190909-15:11:40__30ee8d8887802b80936bcc7a7b7b51f01ed751da__0__lxx@gmail.com__3.7.9____.gz
20190909-20:14:02__e6355b1ac6509f910d691f42ecfbb0da61bb6264__0__lxx@gmail.com__3.0.6____.gz
20190910-14:56:20__da18fe794a5aca6b3f97c145561db7c604fed907__0__lxx@gmail.com__3.7.9____.gz
20190914-23:54:10__c980ecde339d697bb252e77077ad6a883dc5c0c6__0__lxx@gmail.com__3.7.9____.gz

can you tell me which one of these reports could have been the one with that issue? :slight_smile: (timezone is same as yours, from Frankurt timezone), in the end of the filename you see the version of Elive too