3.8.8 boot: error: no such device /live/vmlinuz (UEFI boot only)

Trying to boot into 3.8.8 64-bit on a 2013 Google Pixelbook (i5 w/ 4GB). Former Chromebook flashed & un-screwed to run ElementaryOS natively.

When I boot from USB for Elive, I get "error: no such device: /live/vmlinuz". If I boot into Elementary and look at the USB /boot/grub/grub.cfg file it shows the options for Live boot at /live/vmlinuz1.

In the /live dir there's only vmlinuz1, vmlinuz2, vmlinuz-4.19.0-8, and vmlinuz-5.4.0. I "etched" the USB again but same result. Do I need to edit something to get it to boot into Live?

Thank you.

Welcome to the forums :slight_smile:

Check the md5 more info here How to verify the MD5 values

If they are different you'll need to redownload. If not... there's a bug. Or maybe it's because Google wants you to use ChromeOS and so it attempts to break installations.

Thanks for the report, this bug happened by introducing more than one kernel in the isos by default and only happens when you boot in UEFI mode

Bug fixed in 3.8.9 :slight_smile:

So you have two options now:

  • download the updated version 3.8.9
  • boot using legacy mode instead of UEFI (you may need UEFI if you have other OS's on the computer)
1 Like

crap, just last night I downloaded amd64 version 3.8.8 !!!!!
is there perchance a zsync_curl download option ?

yeah sure! you can use zsync_curl if you have the iso url :slight_smile: (the direct one pointing to the mirror) im not sure if there's any howto around by @triantares

1 Like

Thanks, but right after you said that I found triantares's old dm to me! :man_facepalming:

/m/v/from Mba ❯❯❯zsync_curl -i elive_3.8.8_beta_hybrid_amd64.iso -o elive_3.8.9_beta_hybrid_amd64_zsync-curl.iso -u URL.zsync
No .zsync file specified.
Usage: zsync http://example.com/some/filename.zsync

Why did that happen @Thanatermesis ? Do you know?

you don't need to specify any flags like -o by default.
It's simply if you're in the directory where the old .iso is:
"zsync_curl -i elive_3.8.7_beta_hybrid_amd64.iso https://URL_3.8.8_beta_hybrid_amd64.iso.zsync"

So in general:
"zsync_curl -i path/to/local.iso https://URL.zsync"

1 Like

That was my issue I typed URL.zsync instead of URL.iso.zsync

Thanks :slight_smile:

Confirmed, 3.8.9 works great. Thank you!

2 Likes

I ran into this also with that UEFI only Acer laptop. Got the 3.8.7 and 3.8.8 images to work by writing them to the usb stick with Rufus instead of dd. Then i promptly forgot that i ran into this :smiley:
Good thing it was a bug.