Broken Libre Office installation Elive 3.7.8

I could not install the French Dictionnary on my LibreOffice 6.3
I though something was wrong so through Synaptics I unstall ( Complete Removal) all Libre Office Packages.

Now it's messed up

api libreoffice

The following packages have unmet dependencies:
libreoffice : Depends: libreoffice-math but it is not going to be installed
Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed

if trying to install missing package
The following packages have unmet dependencies:
libreoffice-math : Depends: fonts-opensymbol (>= 2:102.11) but 2:102.10+LibO6.1.5-3 is to be installed
E: Unable to correct problems, you have held broken packages.

and on and on and on in a loop

I run the Broken Package in SYnaptics without results...

This is when I miss WIndow LOL

I just tried

sudo apt-get remove --purge libreoffice*
sudo apt-get clean
sudo apt-get autoremove

Can't wait, will upgrade Elive ( install Elive over ELive,,, Hope as my installation is encrypted, it won't stop ELive te recognize my installation)

The reinstall should work as a fast solution, and yes, encrypted is maintained

Tell me which are the packageS you need to include your language support (dictionaries, Lang, etc, since there’s multiple ones), so I can verify that the installer is using the correct ones

(Yes, the installer should install automatically detected some extra language packages support and dictionaries, but has not been beta tested for a while)

OK Back on my feet ( upgraded)

  • will reinstall a few missing app
  • will try to see if French dictionary can work now

Where I don't miss Windows if for those LONG INSTALLATION THAT NEVER ENDS LOL

TRying to see if this one would work

but it's a 5.7 dict version

@Thanatermesis
I would need help to find a French Dict that works with LibreOffice 6.3
:frowning:

I didn't APUG yet the new install (upgrade)
so for now Libre Office is 6.1.5.2
WIll wait for your instructions

I need a french dictionary but can't find the right way to install it for now. IN older version of LibreOffice I was not having problem installing a directory.

But this was just a joke, ya. :face_vomiting::broken_heart:

1 Like

Why don't you just follow the install instructions from the Libre Office site :hooray:

But first you have to repair your apt cache.

On my freshly apug'ed 3.7.8 with libreoffice 6.3
.
apse libreoffice |grep -i french
libreoffice-help-fr - office productivity suite -- French help
libreoffice-l10n-fr - office productivity suite -- French language package
hyphen-fr - French hyphenation patterns
mythes-fr - French Thesaurus for LibreOffice

I'd say take your pick. :+1:

tks @triantares
it worked

Trying to download the dictionnary from the web, following instructions ( @Rebel450 ) was not working for me

?? Can't you try to be "less clear" than that ?

This dictionary is working LOL

Not sure how what your comment mean...

The 'l10n- {your language} files are always obligatory for applications to work in {your language} , usually every app needs it, e.g.
Firefox, Chromium among others.
You can add them with Synaptic or via terminal or, if available, a so called meta- package. Note that these will also install unwanted languages though.

Happy that you didn't break your system
and that it's working now. :innocent:

@yoda

Just came back to my mind -
for French it's a bit tricky (my WiFi is native French, that's why I know about this) :woozy_face: :

In Libre Office WRITER you need to go in
options /settings/languages/ etc
and you have to choose between old or modern dictionary,
after this !! it's working

Krgds

2 Likes

there's different dictionary packages that you can install but i don't know much what are the difference with them / for what they are for

there's "hunspell", "myspell", "ispell", "aspell", libreoffice-related ones, and a few more...

the best will be to try them in Live mode and restart libreoffice to see how they affects, before to install them in the installed / real system

As mentionned above I already installed libreoffice-l10n-fr - office productivity suite -- French language package and it's working

tks though

I tried them and the one you need is the "hunspell" one, @yoda

Note: I booted 3.7.8 Live mode without problems running "apug" upgrading libreoffice, not sure if the issue is with trying to upgrade previous versions of elive :thinking:

1 Like

I will keep the one I have for now, as I can't find the one you're talking about in french

~ ❯❯❯ apse libreoffice |grep -i hunspell
hunspell-be - Belarusian dictionary for hunspell and academic orthography
hunspell-br - Breton language dictionary for hunspell
hunspell-ca - Catalan dictionaries for hunspell
hunspell-ko - Korean dictionary for hunspell
hunspell-lv - Latvian dictionary for hunspell
hunspell-af - Afrikaans dictionary for hunspell
hunspell-bg - Bulgarian dictionary for hunspell
hunspell-bn - Bengali dictionary for hunspell
hunspell-bs - Bosnian dictionary for hunspell
hunspell-cs - Czech dictionary for hunspell
hunspell-da - Danish dictionary for hunspell
hunspell-de-at-frami - German (Austria) dictionary for hunspell ("frami" version)
hunspell-de-ch-frami - German (Switzerland) dictionary for hunspell ("frami" version)
hunspell-de-de-frami - German dictionary for hunspell ("frami" version)
hunspell-el - Modern Greek dictionary for hunspell
hunspell-en-gb - English (GB) dictionary for hunspell
hunspell-en-za - English (South Africa) dictionary for hunspell
hunspell-es - Spanish dictionary for hunspell
hunspell-gd - Scottish Gaelic dictionary for hunspell
hunspell-gl - Galician dictionary for hunspell
hunspell-gu - Gujarati dictionary for hunspell
hunspell-gug - Guarani dictionary for hunspell
hunspell-he - Hebrew dictionary for hunspell
hunspell-hi - Hindi dictionary for hunspell
hunspell-hr - Croatian dictionary for hunspell
hunspell-hu - Hungarian dictionary for hunspell
hunspell-id - Indonesian dictionary for hunspell
hunspell-is - Icelandic dictionary for hunspell
hunspell-it - Italian dictionary for hunspell
hunspell-kmr - Kurmanji dictionary for hunspell
hunspell-lo - Laotian dictionary for hunspell
hunspell-lt - Lithuanian dictionary for hunspell
hunspell-ne - Nepalese dictionary for hunspell
hunspell-no - Norwegian dictionary for hunspell
hunspell-oc - Occitan dictionary for hunspell
hunspell-pl - Polish dictionary for hunspell
hunspell-pt-br - Brazilian Portuguese dictionary for hunspell
hunspell-pt-pt - Portuguese dictionary for hunspell
hunspell-ro - Romanian dictionary for hunspell
hunspell-ru - Russian dictionary for hunspell
hunspell-si - Sinhala dictionary for hunspell
hunspell-sk - Slovak dictionary for hunspell
hunspell-sl - Slovene dictionary for hunspell
hunspell-sr - Serbian dictionary for hunspell
hunspell-sv - Swedish dictionary for hunspell
hunspell-sw - Swahili dictionary for hunspell
hunspell-te - Telugu dictionary for hunspell
hunspell-th - Thai dictionary for hunspell
hunspell-tr - Turkish dictionary for hunspell
hunspell-uk - Ukrainian dictionary for hunspell
hunspell-vi - Vietnamese dictionary for hunspell
hunspell-en-au - English (Australia) dictionary for hunspell
hunspell-en-ca - English (Canada) dictionary for hunspell
hunspell-en-us - English_american dictionary for hunspell