Cpu Running at half speed

I installed Elive on my new old laptop Extensa 5235 and i got a weird issue. The cpu is running at 1192 MHz instead of 2.20GHz. IDK why. It's not a bios setting (it's the first thing i checked), and this speed is shown both in conky and lscpu. Do you know what this may be caused by?

Hello!

Seems very simple: win$ames consumes quite all power of your machine, letting eventually bits (read crumb) for working or any other software...
A fat Linux system gives you generally a good balance...
Optimized Linux, say, Elive's good example uses only the useful minimum of hardware power, furbishing a maximum of opportunities to run whatever you want to work, play, use...
So, if you, e.g. run a big Blender project, a big CAD suite, a mining session or somewhat huge work thing, you finally get your CPU at full speed, but with the less as possible due to Elive, the max for your use.... :wink: :innocent:

Salutations!

2 Likes

Exactly, Linux only uses what it needs where others use as much as they can. :w00t:

thank you guys for the reply, tho i know how does intel enhanced speedstep technology work like... The problem is that when the os eats 100% of the cpu due to relatively intesive tasks the cpu is still runningat 1190MHz despite no overheating!

Hi!

In this case, it should be due to a tuning somewhere, of somewhat "economy" mode, or an effective bug that makes thinking of "economy" mode..?
Or did you set the 32bit .iso by mistake (well, I'm not sure this can give that..? :thinking:)???

Ih!

1 Like

We had a thread on powersave and cpu_freq a while ago with this result.

I was thinking the same thing!

I'm sure it is the 64!

Thank you!

You can test the max speed e.g. by compressing a bigger file with 7zip or gzip - then watch your processor speed...
:wink:


This is the situation under stress

Are you sure that

  • speedstep is enabled in the bios
  • you followed @triantares' advise above
    :confusing:

if it wasn't, it'd run at full speed costantly!

Yes i did, no result

I remember in E17 and i think in E23 too it was possible to select the cpu speed from the gui itself, tho E23 does not run correctly on my laptop for some reason.

Just wondering:
What does i.e "inxi -C" have to say about your CPU speed?

Never mind, will be identical to "s-tui".

BTW,
I'm getting strange results from "s-tui" i.e "stress". Did you give "7z -b" a run as well?

1 Like

Ok so update.
Looks like my predecessor made some tweaks to this laptop. It was supposed to be using a celeron t3100; which was swapped with the pentium t4400. While the T4400 supports enhanced speedstep tech, the t3100 does not. I guess this is the problem. Moreover the intel_pstate does not support this cpu model as showm by dsmeg. Ahcpi-freq cannot load properly ofc without support for the speedstep tech in the bios.

Tho, what i don't get, is: the Bios looks like recognising the cpu correctly and detects the right cpu speed (2.2Ghz). I saw cpu bad detections, with the multiplier/FSB set at the wrong speed, but the bios was always able to tell me at what speed the cpu was running (after all it's just FSB*multiplier, and since the mobo can run the FSB only at 200Mhz it's even an easier operation). So i guess the multiplier is set correctly at 11. Which brings me to the question again: why tf am i running at 1197 like it were a 6x multiplier (bare minimum) :cry: I mean at least it should run with a 9.5 multiplier like the old celeron :sob:

The only thing I can now think of is maybe a power issue i.e battery opposed to connected/charging settings. :thinking:

or .... maybe a BIOS/firmware upgrade ?