Download Bug with Chrome-based browsers

Hi, just recently signed up for the free download of Elive

After the hour wait i received the link and clicked and was taken to the page with the download links, which is embedded in an image, therefore no left click 'save file as' option was accessible..

after clicking that link, a new browser window opens displaying the path and filename, but no 'save as' dialog appears

i tried the link in both Google Chrome, and Vivaldi, which is a chrome-based browser, same result

however, the link worked fine in Firefox...

Not sure if this is in the right category for this post, since it's not a bug of the actual OS , per se, so feel free to move the comment or let me know if i should repost under another category

cheers!

james theobald

Well as long as you got the Elive .img or .iso everything's OK. :w00t:

I cannot make what you tell happen, using chromium or Opera so looks like an issue with both of them (vivaldi & chrome).

Anyway you can always do "wget https://link_to_download" on the commandline if all else fails. :happybounce:

Welcome to the forum any which way. :smiley14: