E16keyedit wrong E16 version

The latest version of Elive E16 has an issue with e16keyedit.
Somehow, somewhere there's a nono on the version that's there.

It's not in the command itself (it's binary) so probably in an altered script (@Thanatermesis ) somewhere.
Or the latest version ofe16-data has an error/bug. :thinking: Which is probable.
On version 1.0.24 (buster) it worked on 1.0.26 it doesn't.

Bur reported as: #4 - e16keyedit version mismatch - e16 - Enlightenment GIT

Looks like a build error for Elive, I checked the e16 version with 'eesh ver' and received only 'e16' as answer.
Here's the response I got from Kim Woelders:

"eesh ver" should say "e16 v1.0.26-2-g6a0c30e7" (or "e16 1.0.26" in a "release" build).
The version string (E16_VERSION) is generated by the e16 top-level Makefile(.am) and written to version.h.
Somehow this has gone wrong in the Elive build.
We'll have to ask Thanatermesis.

I don't know how many other E16 apps require a correct version check so it might be worthwhile to correct that. :slight_smile:

Solved. Was indeed a .git error in the e16-data build.