E23 encountered issues .... Please expand

E23 Issues

  • On "suspend" screen sometimes goes/stays black showing only the pointer. It does not become visible again with any key combo or action.

Even using TTY1 and then TT7 keeps the screen in the same condition. Where, apparently everything is active, only invisible.

taking a screenshot gives a same blackscreen, so it is not "just" the backlight that is off.

Going to telinit 1 and then Ctrl+D works through lightdm login screen, effectively restarting the whole desktop again.

  • On resume from hibernate, the system becomes unstable with kernel error messages

  • Built-in file manager freezes the whole system when generating icons/pictograms when connecting large (USB) disks or opening directories for a first time. The built-in manager is below par compared to Thunar.

  • When configurating the desktop from settings panel the whole desktop will freeze on different occasions, requiring a logout/login.

  • Pager resizing makes the pager uncontrollable requiring a logout/login to be able to access it.

  • Lightdm login screen gets ever darker due to screen dimming by compositor. It has to be disabled otherwise eventually the login screen will become unworkable.

  • On my machine, when the mouse hits the screen edge it moves to the next (virtual) screen.
    This is overly sensitive and makes the desktop extremely "jumpy" when I don't know where my pointer is.
    So I disabled it by simply removing all the edge bindings here:

Hah, peace and quiet. :happy:

  • Selecting "input methods settings" always kills the whole settings panel and requires a restart.
    ** Resolved**
1 Like

I am not experiencing most of those...
If you want me to go into more details let me know

Well for one, you state you don't have some of the issues I've summed up.

Would be good to hear which ones don't happen to you and which you can confirm. :smile_cat:

Suspend , hibernate work flawlessly for me on E23/Elive 3.7.16 and 3.8,1 (Dell Inspiron N5040). Closing the lid does leaves the laptop running no hibernate suspend or power down; most likely need to configure in power settings. may not be a bug. That being said E23 is very unpredictable , many things fail randomly and it can be difficult to track their origin.

Unplugging power supply to laptop temporarily freezes Cairo-dock so nothing can be launched from it for about 10 secs

The Touchpad is the source of some of them , looks like some default settings ( difficult to find which one) are the culprit. For example if you open 2 programs/windows the second window is immediately pushed to the background.
Default E23 file manager does not mount other partitions on the computor but Thunar mounts them immediately then Default E23 file manager can access them.

More issues will be posted

If the AC adaptor is connected .... same experience albeit that the screen blanks after a certain period.
My suspend and hibernate problems are there on battery power .... or when issued as a system command from the menu.

"cairo-dock" is an extra application in E16. You can run it on E23 too, if you want to but trhe standard bar/dock on your screen is part of E23....so be careful how you name what. Not to be pedantic but to avoid misunderstandings. :smile_cat:

I cannot say I've encountered that (yet). What I do have (but also on E16) is that the touchpad will not work on resume, where the touch screen does.

  • I can resolve the issue by reloading the "psmouse" module
    "sudo modprobe -r psmouse && sudo modprobe psmouse"

but you might try out if you experience the same "freezing" if using an external mouse...in that way making certain if it's the Desktop or Touchpad that's freezing. :thinking:

Thank you for taking the trouble. :happy_dance:

Hi,

Maybe it's laready been reported in an older topics (I didn't read all of them) : when logging in on e23, the welcome screen is displayed for a very long time (about 4 minutes) before I get actually logged in.

The screen is not frozen though. I can move the mouse pointer and the screen darkens every 30 seconds of inactivity.

This didn't happen on the very first login after e23 installation.

Any idea why it takes so long ? Is there anything I can check to help improve this issue ?

@triantares
After playing a little more with E23 on my Desktop (not laptop), yes, some DE crash here and there from time to time. I then press F1 "as suggested on the screen" and it comes back to normal.

Not too much painfull though...
JF

I think this darkening is connected to the compositor settings I mentioned in the first post (I add stuff there, as it goes along). So turn off the backlight dimming there to see if it helps. :thinking:

The first time E23 starts up, it will take a fairly long time but after that it shouldn't take more than a few seconds ...... so there might be something else wrong there if you continue to see this behavior.

Hitting Ctrl,Alt and F12 should show system messages and the same combo but with F7 will bring you back.

No indeed, a reasonable invention but best would be to never have to show that error window. That is the goal, after all. :smiley_cat:

1 Like

OOPs now, I am duplicating your problems LOL
I Clicked on a Desktop Icon of my Large USB Drive and it frozed..
had to change TTY and pkill enlightenment

:slight_smile:

But if'm in the file browser alreader, and opening the same USB external drive, it's not doing that
I will register to the distribution list to report those... Problably someone did already

It's an EFM (E23 internal file manager) thingy ..... it's horrendously bad compared to thunar.

You can disable that by unloading EFM in the "settings panel":

1 Like

LOL ho to you launch thunar LOL

I created a shortcut / keyboard shortcut and when /usr/bin/thunar some weird picture open instead of thunar....

Sheesh !!! Use the menu like the rest of us suckers. :rofl2: :shocked: :dance:

Or did somebody steal your mouse ? :madness:

LOL I tried, same result, I should have said...

I will reboot in case it's something " one time / Weird "

It open some picture of my desktop by default

That is extremely weird :shocked:

Wow!!! Show us a screenshot !! Pretty Please. :smiley_cat:

reboot fixed it LOL

DO you often have this :

1 Like

Yep, all the time ... I added it to the top post.

problem is not there anymore so I have nothing to show for now

:wink:

1 Like