Elive custom Screen Capture tool and E23

I prefer Elive Screen Capture tool to others.
But with E23, there is some weird behavior with the selection tool...

@triantares does it work well for you ? If you "try to select " a large area of the screen, does it behave normaly ?

When using E23 don't use the E16 screenshot tool from the menu or commandline (the command is "scrot" = "elive-screenshot" ), use the one for E23 from the menu or using the Prtscr key.

and this is what it looks like, it's quite cool. :smiley14:

2 Likes

No it doesn't, not if opengl is enabled.

Mine is broken as I get somekind of error message after selecting the arear.
It relase to the default file manager i changed from Default E23 File Manager to something else

I will try to find what I changed weeks ago to default the file manager to something else.
JF
image

1 Like

This could indeed be your trouble.
The E23 screenshot tool uses EFM to save ..... and it saves in: "~/.e/e/shots/"
That might be the place to check if any shots are saved there and it's maybe only an issue of not being able to show where they are.

Tks. yes they are exactly there
Did you started using again EFM ?

No not really but I didn't disable it anymore either. .... mainly for bug hunting sake. :smiley14:

1 Like

Tks i brough it back to life
I loaded " both module"

what i liked about some screen capture tools is that the screen capture is going into he Clipboard and is ready to be pasted ( less one step...)

With the E23 one, we need to save in a file and then upload or use that file in a 2nd step.

As when it's in the clipboard, we can PASTE IT in Whatsapp, MEssenger or here etc

Yeah, well you can still use "elive-screenshot" for total shots.... i.e the -r flag isn't much good unless you change to software rendering in "compositor settings".

I agree it's a very fast, simple and effective tool. :smile_cat:

1 Like

I just did it and it work well now.

Can you remind me the cons of having doing that ?

image

Frankly, I have no idea. :smile_cat:
From what I understand it's a matter of either using the GPU (OpenGL) or software (CPU).
Most laptops have the GPU built into the (Intel) CPU so I think it's moot.

1 Like

It's not moot. The gpu inside of the processor is still an entity set somehow apart from the cpu, so if you use software rendering you're not going to take advantage of it. You should always use the Opengl rendering in my opinion except for a few cases so rare that i do not think we'd need to mention them right now.
You may use software rendering in case you have some bugs related to graphics drivers also, or when the drivers are missing completely.
Enabling opengl makes everything feel faster because it makes the gpu do what is good at, drawing, while set the cpu free from that bourden. For example i make sure to use a decent enough gpu in all my old computers so i can run elive with hardware acceleration (is one of the few distros that lets you choose this natively, and that's the main reason why i love it so much), making even pre-dual-core era computers usable (and, literally, an athlon dual core @2.00GHZ from 2005 a nice and smooth experience!).

1 Like

@triantares I'll see if it continue but it seems that since I turned off OpenGL, that I don't have the E23 bugs anymore, the one where we loose the Desktop for a 2 seconds after being forced to LEFT CLICK MOUSE or ESC to bring back Desktop properly

Nope problem still there...

I'm sorry but I don't recognize that behaviour.
It might be a setting thingy. :thinking:
Can elaborate what exactly happens??

Never happened to me either.

usually hardware acceleration rather causes artifacts due to the driver problems, more or less like when you have bad driver and videogames go down on fps or show weird colours on the screen, or just the game does not run at all :joy: the problem you described does not sound like an opengl problem (i may be wrong), especially because such errors usually are resetted moving to a different tty without gui and then back to the original tty with gui session (like ctrl-alt-f1 -> ctrl-alt-f7). Left clicking or pressing esc would not solve such errors!

Not being an opengl related problem, i think you should turn on opengl and report the bug (or maybe reinstalling elive with the "upgrade mode", or just e23 since it's a e23 related error, so that it fixes any issue related to a possible broken installation?).
It really does sound like a software bug

1 Like

How do you reinstall Enlightnement (already installed package) if already installed ? Will google...

sudo apt-get install --reinstall packagename ?

I had this in my commands buffer
api enlightenment
api enlightenment-data <---- is this one important too ?

Will I loose my customization ?