Elive Linux 3.8.9 beta 32bit won't save keyboard settings and wallpaper

Please help. I installed Elive 3.8.9 beta and it worked fine. I changed the keyboard settings so I have US English and Greek Simple keyboard layout then installed the same wallpaper for all virtual desktops. Though now that I started my computer it has the default wallpapers and I can only type in US keyboard layout. What's wrong?

1 Like

Welcome to the forum @achilleaselivelinux!

I have been testing what you reported but it worked for me:

  • configured keyboard to a different language
    • it worked after to run the tool
    • it still worked after reboot
  • set a different wallpaper
    • still shows after reboot

Note that these settings are only saved for the installed system, not for the Live mode, unless you set up the Persistence mode of Live mode

I have the same problem with 3.8.11 beta x64.

  1. Since I configured EN and RU languages as default - after reboot these settings are lost
  2. Language indicator in Cairo Dock not working correctly
    Is there any solutions?

@Felix_Feodor can you be more specific how you changed your settings?

I just tried with "preferences" - "language and keyboard configuration" from cairo-dock and they work OK for me. :thinking:
That is for a 3.8.11 amd64 installed system.

1 Like

Hi,
I did the same too.
But after reboot all preferences are lost and I must to do all changes again.
Keyboard indicator have a problem too so sometimes it removed by system from cairo-dock.
How can I save the changes for another boot?

Are we talking a reboot into live mode with USB or is it an installed to HD system?

Thank for response,
Elive amd64 installed on HDD and reboot from it. There is three partition for Elive on HDD: system - 40Gb, /home - 180Gb and Swap - 40Gb
Maybe I made mistake while install?

Were you asked your password to change the settings after choosing your language and keyboard setting?

Anyway you can change language settings with the command:
"sudo dpkg-reconfigure locales" and choose your language from there.
To change keyboard settings:
"sudo dpkg-reconfigure keyboard-configuration"
or to change your setting on the fly (this is my us keyboard change to the one you want):
"setxkbmap -rules evdev -model evdev -layout us -variant altgr-intl"

To find the keyboard variants available (there's quite a few Russian ones):
"cat /usr/share/X11/xkb/rules/base.lst | grep ru"

I type my password
I tried all these steps - no result
Then I try to reinstall Elive and there was wrong way. Several times I formatted disk and only one message, like on screen.
Now I'm not have Elive ((.

UHOH !!!, looks like your HD is going to the dogs.
The HD is probably faulty.... if you've got important files on there see if you can copy them to a USB disk or such, while you still can as I suspect sda2 is your /home partition.
You can use Elive in live-mode to do that.

If there's nothing valuable on the HD i'd advise to let the installer create the partition scheme for you, i.e let it use the whole disk and automatically create what is needed.
For instance, in your current setup you have 40G of swap which is alot. The general rule of thumb is to have a swap partition with the size 2x the amount of available RAM

Thanks for answer about swap partition size!
HD... It looks but isn't :slight_smile:
I have no files in that disk. Only Elive OS freshly installed
That HD work correctly by Win10 (see Диск Е:)
I have two HDD first 1Tb - for Win10 and other 250Gb for Elive
There was Elive system disk until I tried to reinstall
In BIOS Win HDD are Master and Elive are slave. Boot by press F12 and choose Elive HDD
The question is: while the installation, when I choose the automatic creation of partitions - can I say to installer to choose exactly and only 250Gb HD?
I afraid for loose my Win10. My work is there

  1. Previously I can't save the language settings. Elive works like in Live-mode but almost installed on HD. Should it happens because Elive was installed in other HD and boot by F12 key and chooseElive HD?
    Thanks for your help

Actually there are some mix ups here and you seem to be handling your disks in a strange way.

The way you choose to boot your systems through F12 is a bit hard and actually unnecessary. Elive (and any other Linux) is quite capable of booting both Windows and itself using grub and coexist quite happily, even on the same physical disk.
So even if you give your second disk to be wholly used by Elive it will want to use your first disk for the bootloader (those small FAT partitions)....which would simply give the option to boot either Windows or Elive.

If you do want to continue using F12 to chose a disk manually, it would be best to disconnect the 1TB drive from your machine and let Elive install onto the 250 Gb disk as the only disk on the system. That way it will create the necessary bootloader for itself there.

Alas my Russian is no good and on top Windows is always very unclear about partitions, physical HDs and the difference between them.
What I do see there is a lot of NTFS files sytems and no Ext4 (or other type of Linux file system) i.e Elive most certainly is NOT installed.....it wont run on NTFS.
Or was this the situation before you installed Elive?

A thing you should certainly do is enter your email address when asked to send in an automatic report by the installer..
That way somebody can check to what's going through the logs and if need be, report back to you.

A word of advice:
Never, ever play around with partitions without making a backup of important files first...especially if you aren't 100% sure of what you're doing.

can you tell me more details in order to reproduce the issue and see what is happening?

more exactly:

  1. your computer booted in LIVE mode and which language autodetected?
  2. then you reconfigured the language on which one ? (automatic message that appears in the desktop asking you for the language)
  3. I assume you proceed with the installation, anything specifically to know here?
  4. Then you rebooted in your new installed system, what happened here? and what is what you expected?

mmmh, maybe you are not using the language configurator from the menus as @triantares is suggesting, and used a cairo-dock gadget instead? note that they are not very tested for us, did you tried the language configurator from the menus? theres also a recent howto in #howtos about how to change the language in E16 desktop

ow, sorry for that recent bug, it is fixed now, you can try to reinstall elive (with connection to internet, so the installer will be updated) and the problem is solved, thanks for report it :slight_smile:

nothing to worry, the issue was from the installer, with had a new improved command for formatting but the command was wrong, now its fixed :slight_smile: @Felix_Feodor HD is healthy :slight_smile:

1 Like

Thanks a lot, I did reinstall!
But problems is the same :frowning:
There is only one language En or Ru (depends of locales) but no switching to other
There is step by step screenshots:

  1. after boot go to Language and keyboard configurations

  2. set locale ru_RU

  3. then change a keyboard to "other"

  4. set Russian keyboard

  5. set keyboard layout Russian

  6. set switch between Russian and Latin - Alt+Shift

  7. password and save a changes
    All changes done. All works correct. In Russian mode indicated
    Restart the system and all changes are lost. No switch between languages. Only one language

Try to do hotkeys like Thanatermesis say in "howtos"

"To switch fast between one keyboard language and another the easiest way is to simply create a hotkey that runs the command to switch the keyboard, for that, edit your hotkeys file:

scite ~/.e16/bindings.cfg

KeyDown CA 1 exec setxkbmap ru
KeyDown CA 2 exec setxkbmap en"

but no result. Only KeyDown CA 1 exec setxkbmap ru works. KeyDown CA 2 exec setxkbmap en - not works

There was some pictures and some links but I can't put it in reply

it works only one time. Next tape on key are not switched a language

looks like the cause is the " character in the end of the second line, try to remove it :wink:

Thanks, sure symbol " is wrong, this is mistake when typing
But I'm tried to install 3.8.12i386 on other computer - Lenovo S110 notebook and the problem the same: the system are not save keyboard switching settings.
It works with only one language and this is the most problem to use this system.

Mmmh, maybe is because russian language needs a special combination values for setxkbmap

I don't know which ones they are, but try these commands in a terminal to see if makes it working:

First, this one is to switch to english keyboard (try it first):

setxkbmap us

Then, see if switching to russian works, try these one to one:

setxkbmap "us,ru" "grp:alt_shift_toggle"

setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll,compose:menu -layout 'us,ru' -variant ',,phonetic_winkeys'

setxkbmap ru -variant typewriter

setxkbmap -model pc105 -layout us,ru -variant ,phonetic -option grp:ctrls_toggle

Tip: Howto copy-paste in terminal

Yeah, surely its not easy to know which ones are the parameters you need, but let's try them for now....

Note, the ones saying "alt_shift_toggle" are meant to be switched between english and russian using the Alt + Shift keys. The last command is the same but using both Ctrl's keys at the same time

You can also use a gadget in the desktop, see the updated howto: Switching keyboard input language in E16

Related: Switching keyboard input language in E16

Note : I just noticed we talked about "setxkbmap en, this is wrong, its "us", not "en", maybe this was your issue

1 Like