Fake raid not recognized (but gparted does...)

Hi all,
looking for a new distro to revive my laptop I found elive and I fell immediately in love :heart_eyes:
So I want it installed but... when trying to install to disc from live, the installer can't recognize correctly my disk layout so I cannot choose the root partition.

My laptop is an Asus UX301 with 2 ssd disks: they are bound together in a raid 0 through something called fake raid. They are also already partitioned with my preferred configuration so during the installation I don't need to make any change, just select the root partition for the elive OS.
So I choose DONE in the installer's partitioning window but the next step showed me only one entire ssd disk to choose, as if it didn't recognize that there is a raid and many partitions above it.

Clearly the installer cannot recognize my fakeraid, but the strange is that if I choose the gparted option instead, it shows the exact configuration, with the raid and all my partitions well existent and safe. Why the installer does not?

Tried with elive 3.0.6 but the same happens with elive 3.8.16.

Anyone has encountered the same problem?
Any suggestion appreciated!

Hello @AlexQm welcome to the forum. :smiley14:

fake raid is a BIOS implemented contrrol of a disk array and has a few variations, so it's hard to to offer explicit advice but if "gparted" recognizes the partitioning scheme: there shouldn't be any worry.

During install you are given the option to use gparted to set your system as wanted by the installer.
After that the installer will continue with the choices you have made and continue installing and everything should work out.

If there are other worries, don't hesitate to ask and be careful when playing around with partitions ..... think twice and double check before clicking any OK.

Hi @triantares and thank you for your answer!

...unfortunately no :sob: :sob:

More details to be clear:
when the installer offers to choose gparted, I see this partitioning:

that is correct and the last partition is where I want elive to be installed.

But after closed gparted, the installer's next step shows me a choice like this:
/dev/sdb1 119GB (isw_raid_member)
/dev/sdc1 29GB (ventoy -exfat)
that is completely incorrect, since there are no partitions (and also it shows me only one SSD disk of 119GB, and not two. Don't mind the last disk, it is the usb key).
So I have to stop the installation and exit.

My concern is: why the same installer sees two disk layouts and so different?
and how to get around it?

Well in that case you choose that partition and designate a mountpoint for it .... in most cases simply: /
If you close gparted without any changes then the installer wont know what to do either.

may be I'm missing something...
gparted doesn't allow me to mount that partition, the option is grayed. I can only format or label. So I choose to format it to ext4 just to be sure and then I quit gparted to continue with the installer.

The next screen was again the "select a hard disk partitioning option" screen with the list automatic/windows/gparted/gnome-disks/help/done, the same from where gparted has been launched before.
So this time I choose "done" since the partitioning is ok.
Well, the next screen, instead of my usual 8 partitions, shows only one item and the wrong one:
/dev/sdb1 119GB (isw_raid_member)

So there is no way for me to choose the right partition as root for elive.

...and sorry for not explaining well what happens, I'm not familiar with this installer so probably I'm missing something obvious :disappointed:

Back in the summer i had a similiar issue. HP pizzabox and i just put couple of 500gb hdds there and then raid'ed them in the bios. Fought with the installer for a few hours and then forgot about it until now. heh.
Remembered now that later i read this article and thought i'd try it, but forgot to do that too. This might help : DebianInstaller/SataRaid - Debian Wiki

ie. add dmraid=true to kernel command line before booting.


Thank you @Wizor, I really saw a little light in the tunnel and immediately tried your suggestion but no, it not helped in my case :disappointed: Also with that option in the kernel the installer cannot see the right partition.

I'll try changing some options in the bios, not sure it can make any difference but just in case, and then probably I'll give up and direct to different distro.

I suspect that the installer sees the correct disk as /dev/sdb but doesn't show the mapped partitions yet.
The naming scheme can be messy sometimes and lead to wrong assumptions and choices.
For one, /dev/mapper entries wouldn't be the real device name but those created by the volume mapper and are probably inside /dev/sdb...... that can be confusing as after all, they're not physical partitions .

I myself have never worked with fake-raid (only encrypted LVM partitions), so I'm not sure and thus don't want to advise into simply carrying on (although I suspect you can) ..... unless you've made backups of everything you want to keep and know how to put them back.

  • Having recent backups is always good. :smiley14:

This is more of a thing @Thanatermesis should answer ..... I'm fairly sure he has something in place inside the installer that recognizes fake-raid.

I made a short howto on how to access encrypted LVM partitions which can shed some light as to how this kind of mapping works:

well, I imagined that this fakeraid could be a strange creature to deal with, especially during the installation steps... but not so bad! :scream:

Tried with different Bios settings (CSM enabled/disabled, just to see if something changes) but same result and no partition recognized.

Anyway I attempted to go on, so I choose /dev/sdb1 for root, crossed my fingers and clicked on OK to proceed with the installation... and the installer got stuck on "arranging some atoms in the universe" for at least 30 minutes, after which I stopped all with the cancel button.
After a reboot, I saw that nothing has been written on my disks since all my partitions are safe and sound (yes, I have a full backup :sunglasses:)

So I'm still in a dead end... but thanks to all that answered! :+1:

Are you sure you clicked "Apply" before quitting? I made the same mistake and am sure many others have.

Sure! :nerd_face:
I saw the message that the all the operations were applied correctly

1 Like

Did you give the installer a go a second time from a fresh startup?
Don't ask me why but sometimes htat gives different results. :shocked:

yes, loosed the count of how many boots I have made in this days... :exploding_head:
Also tried with a complete update of the packages, running apt update before running the installer, but not helped.

Hi @AlexQ , thanks for reporting the issue

raid's should be supported in updated versions of elive, but I see that you are using a beta version, so there should be a problem somewhere

Can you tell me more details on how you configured this raid system? did you created it on linux or it is configured from the bios? :thinking: i need to know that in order to try reproducing the same scenario in a virtual box

A helpfull command that you can run to see if is detected somewhat is:

sudo partitions-list --show-all --show-raw --show-disks

it should show the raid structure just like other elements, like maybe the disks individually

Hi @Thanatermesis and thank you for your work on Elive.
After some unsuccessful attempts few months ago, I gave up with Elive and turned on a different Linux distro. So at the moment I cannot try with the new release (still I won't exclude it for the future...) nor can I run the command you need.

If of any help:

  • I confirm that the raid is configured in the BIOS, not from linux
  • in my old notes I found that the output of

partitions-list –show-all –show-disks –show-raw

showed 2 single disks (correct), one with the right size and the other without any size reported (not correct).

Sorry for not having better info...

1 Like

That's the command he asked for, so that'll help a ton. :nod: