Firefox and chromium scrolling on touch screen

The strangest "bug" I encountered:

When scrolling Firefox or chromium with my finger (or 2 fingers) on the touch screen or touchpad I see a strange artifact. A diagonal almost invisible line along which the rendering sort of slows down.

It shows especially well on the edge of a dark picture where a minimal white indentation can be seen moving along the line or that certain parts of the text (centered on the window) seems to jump or get wobbly when scrolling up or down.
With Chromium it happens down on the lower part of the window compared to Firefox.

This does not happen on E16 only in E23 and only with Firefox and Chromium. :thinking:

  • Can anyone using E23 and Firefox see anything like it?

I've tried to capture it with vokoscreen and even my phone but both do not show anything ...... it's the human eye that does this. I suspect the framerate of the videos is too low to show it.

  • Is this just my vision (not wearing glasses or lenses BTW) ?

I've been wiping my screen for days now thinking there was some grease, spittle or dirt there. :face_with_head_bandage:

Managed to capture it after all. :w00t:

With Chromium i managed to get it slightly viewable. Check out the edge of the dark blue part, as well as the light green in it. The second time I scroll is clearer BTW.

Set the video to full screen to get a better view.

1 Like

try to switch between software and opengl rendering compositor, also check the vsync (tearing-free) rendering option!

Toggled both on E23 but doesn't make difference.
As there have not been any confirmations by others, I suspect it's a very machine specific thing.

but then is strange that it only happens in e23, it should be related to the compositor, unfortunately I think that there's no possible to unload (entirely) it, by other side you have many other "compositor" options that you can try to toggle (recommended to backup your .e dir first in order to recover it later)

Well that was a quicky, first try solved it. :w00t:
Opting for "tear-free updates (vsynced)" made it go away.

The downside:
It gives strange effects with selecting e region for a screenshot. :slightly_frowning_face:

Elive_Screenshot_2020-01-03_18:02:19__290x362

and without:

Elive_Screenshot_2020-01-03_18:03:57__280x357

Ultimately, opting for "software" rendering in place of "openGL" solved it.
This happens only on my Carbon X1 Thinkpad, the other machines do not have this issue.

It has an Intel Haswell-ULT integrated GPU that uses the i915 driver.
OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.6
Using 5.3.0 kernel.

ah! vsync is a must to have always enabled! :slight_smile: it also features a well smooth video playing

unfortunately, since e23 is not included by default by elive (i mean, no default conf provided), we are missing all those must-to-have options :happy:

so this means, not a bug

ah interesting! you found the reason of why these things happen in e23 :slight_smile: I seen that before... so its related to vsync, actually I don't know if the issue is related to e23 itself that doesn't manages that correctly or the screenshot tool itself (scrot, IIRC)

no artifacts with vsync + software? :thinking: then I assume that vsync is not enabled on this mode (it was not possible in the past, but seems like the option is "able" to toggle in software mode, and so it should be NOT, thats another thing to report, very easy to solve by setting the checkbox to disabled mode)

@triantares can you report these issues to the E guys and add me as a susbscriber? (artifacts created from "scrot -s" when no vsync is enabled, and vsync checkbox should be disabled when in software mode if is not working on software mode)

Not sure what you mean by that. :thinking:

Do you mean that in software rendering vsync is not possible so it shouldn't be possible to check that box?

OK, will do.