First boot: unable to reboot / shutdown

By some unknown reasons, seems like in my tests, im unable to reboot / shutdown the computer from the first desktop user's session. It simply goes back to lightdm :thinking: (where you can, but is not friendly and some users may not found the poweroff small button)

Sounds like an issue with systemd and user's permissions, and if im not wrong this works correctly after the second reboot

The question is, what it needs to be reconfigured / set in order to work since the first boot? :thinking:

I have no such issues on E23 so maybe it's just E16 handling the signal wrong?

EDIT

I just tried on both DEs and cannot replicate this issue. :thinking: Not even on a freshly installed 3.7.8 or setting to "autologin" either using "lightdm" or "entrance", encrypted and unencrypted filesystem.

Installed or live version ...... no problems whatsoever when using the shutdown or reboot emenating from the desktop menu.
The icon on cairo-dock had some issues to shutdown but those work again too now.

maybe

but it only happens on the first boot on the installed system, probably using a new e16 conf on that first boot

cairo-dock shutdown never worked for me (in my unique test made months ago), but you say it works again so... maybe is related? hum...

Looks like it is related. On the first E16 run, Cairo-dock "shutdown" does not work .... on subsequent runs it does.:thinking:

then the only possibilities that comes to my mind is:

  • installer post-install & removing that happens on the first boot (i don't see any reason of why this can be the cause)
  • first desktop creation adds some needed privileges (desktop is run in paralel than those steps, so maybe are not included in the desktop itself)
  • first boot of the OS (systemd) adds some privileges itself

ways to find the cause (probably from a vbox with snapshots to do tests, if we can reproduce it on it)

  • first boot without a new desktop creation (let's try to copy back the .e16 dir)
  • logout and re-login to see if the privilegs are added (desktop startup again, instead of reboot first)
  • same, but restarting lightdm too
  • trying to reload daemons, in the end, there should be -something- that must be reloaded that makes these privileges appear (just like a reboot is the same as restarting all the daemons)

Couldn't it be related to lightdm privileges?

I found that if I installed "entrance" (it was in packages-to-retain) before the first GUI boot, it would hang i.e never got out of TTY1 (the one with the Elive graphics with moving horizontal lines superimposed)
Required me booting into "safe/rescue mode" to remedy that.

Are you sure? please give it like 2-5 minutes, there's an added delay in the first boot which is about removing the installer and final setups (im trying to improve to show a message about that, but it only appears if we have plymouth installed, so in 32bit versions we don't have it)

back to the topic, im unable to reproduce the privileges issue in a new install of 3.8.9 32-bit with the "reboot" option in a VBOX

Yes, on F12 there were messages about 1` of 2 jobs running with a too long (5 min is too long) time-out for my taste.
Sadly it never tells which jobs. :slightly_frowning_face:

wait, im a bit lost, are we talking about first boot or shutdown?

6 posts were split to a new topic: Entrance: development issues (boot process, login privileges, etc)

UPDATE: moved all the last posts which are specific to entrance issues, let's focus this thread on its topic (only lightdm, which is the default login-manager provided on elive ATM)

Which the topic is about a (possible) issue not having enough privileges on the first boot

ATM Im unable to reproduce for me on VBOX installed + reboot option, I may should try the next time with enligthenment "maintain-installed" and no-autologin on lightdm so i can login the first login on E23 to see if they are grayed out or not :thinking:

2 posts were merged into an existing topic: Entrance: development issues (boot process, login privileges, etc)

I just did another test, maybe for 3.8.10 the issue is solved (some delayed boot added in first-boot may have solved it), but in any of the cases, my last test is:

  • lightdm: autologin disabled
  • e23: first boot + login happened to e23 (manual login in lightdm)
  • all "system" options in the menu are available, not grayed out

I think we can consider this bug fixed since I'm not able to reproduce it at the same time improvements in a delayed first boot has been added which may solved it too :slight_smile:

Update:

This is finally fixed in the next build 2.8.10 (able to reproduce the issue and verified the fix)