Gdebi cannot install from thunar

I am unable to install .deb since upgrading with the Elive3.8.1 (used the liveusb upgrade system) . Gdebi reports that all the dependencies are satisfied and when i click install the whole program disappears without any warning or feedback . I am also unable to install using terminal. going to try apug.

Can confirm Gdebi is broken and for some reason reinstall doesnot seem to restore it.
However you can still install .deb package in terminal with: sudo dpkg -i packagename.deb

The GUI of the package installer indeed is broken.
Probably because it has to run with admin privileges but does not ask for those.

In a terminal you can install using "sudo gdebi path_to_package.deb" which gives more information on missing dependencies than "dpkg" does.

:thinking:

in my old tests gdebi correctly worked

basically: open the file-manager, select the .deb file to open with gdebi

this doesn't works ?

No the gdebi gui does not work, exits without doing anything, invoking this installation with terminal goes off well without problems

The gdebi gui ("gdebi-gtk") does not demand admin rights and thus cannot install the paclkage. It dies silently without giving any errors.
That's about the whole thing ..... running "sudo gdebi" works fine on the CML.

Edit

Actually started wondering why "gdebi" and "gdebi-gtk" are in "/user/bin" where IMO they should be in "/user/sbin". :thinking:

hum, this issue is very strange, i remember that gdebi worked in the recent versions, but not anymore... I just played with it in Live mode and the issue is basically from thunar

so if you run gdebi-gtk file.deb from the commandline, it works without problem (yes, as user), but if you run it from thunar it doesn't, so its not a permissions issue

note for @triantares by default (unless specified in the installer or the user-manager tool when creating a new one), the users has "admin right" to manage packages, same for live mode, so it should be not caused because the need of root, so...

  • it is not caused by the need of root / admin
  • it is not caused by lacking sbin entries in the PATH variable

:thinking:

the only way to make it working is by using a wrapper instead :thinking:

maybe related: #932088 - gdebi doenst ask for a root password. just silently closes - Debian Bug report logs

note: moved to a new thread in #system:bugs

1 Like

question, in order to not forget this issue / bug, we should open a bug in the BTS website? just leaving it here is OK (less work)?...

the thing is that by having it listed on the BTS we can have always a list of opened / closed bugs, which is good to not forget about these issues, but here we have many threads and there's not specifically a notification system about it, etc.. not easy to track the issues from here, IMHO

mentions: @Rebel450, @triantares, @stoppy98

Yes i think you should.
I just realized i met this bug a few times recently but i did not give it much value and just used dpkg immediately. The reason why i did not care is because i lost trust in such GUI installation method when i used ubuntu (it never worked!), but thinking about the 3.0.0 release it actually did work perfectly!
Let's add it to BTS, so it will be solved and also people not familiar with terminal will be able to install a .deb :1up:
I'm writing the report

EDIT:
done @Thanatermesis

Hello!

I had the same thing, and when running Thunar as su, it was ok...

Salutations.

It might be related, update doesn't work on mine either! using 64bit

FIXED

apug & reboot :slight_smile:

4 Likes