Got this authenticate loop trying to dump a screenshot

.. anyway it's a loop and i fell for it twice now i think the hacker tried to log into the tower which has a different password because i got an error message loop on it now. i really should clonezilla more.. get back to square one faster instead of doing a re-install. hope your day is going good. please

wow ok i'm amazed that that worked.. sorta heart attack city today.. was pretty sure i'd lose facebook again.. but luck of the irish maybe. :slight_smile:

I got the same issue. I think the installer is broken or something.

It is very unlikely this is an attack, It should be basically the system needing to do some administrative tasks, unfortunately these windows doesn't tells "what is trying to run" but you can still see that yourself running commands like "sudo ps aux" or "sudo pstree".

This can especially happen if you selected to not give (automated) sudo permissions to your user, so it is asking the password to run something

@linux23dragon mentions that has seen this recently too... I wonder if it has been caused by the recent (big) changes that were introduced in elive-upgrader (so, since the new "boot impermutable" feature added) :thinking:

Isn't this what the setuid bit (chmod +s) is for? (For those who don't know, the setuid bit basically means "run this program as whatever user owns it".) That way, you can chmod +s automated processes that need root, make sure they're owned by root, and then they'll just... run as root.

They sometimes do when you click on 'details' but 'ps aux' will suffice too. :wink:

It could be.
On another machine I upgraded I noted that "gksu" popped up but simply took for granted, it needed "sudo" for "update-grub" .... but it shows up again when rebooting in impermutable mode : It's 'elive-upgrader-tool' that wants sudo, now

I enter password and gksu pops-up again but now it's for "elive-upgrader-root --hooks-root-pre"
and again this time it's "elive-upgrader-root --hooks"
Which is the last time, meaning for @r0to00 :
It's not a loop, 3rd time lucky !! :wink:

1 Like

yep. Impermutable boot upgrade is trying to install after every boot.

Thanks for the details, this is strange, because the OS is configured to not require password to use this system's tool :thinking:

Verify what you have on this file:

~ ❯❯❯ cat /etc/sudoers.d/sudo_nopasswd_generic_$USER

elive-upgrader-root should be configured to use sudo without asking for password, why is asking for it then? :thinking::thinking::thinking:

fast test to do @triantares: open a -new- terminal and type "sudo elive-upgrader-root" alone, it should not return anything but it should NOT ask for password too, this is directly dependent of the previous configuration mentioned too

not exactly, at every desktop start, elive-upgrader is run to see if the system needs updates, but for some reason elive-upgrader is asking for password now :thinking:

Standalone works just fine .... looks to be just an issue inside the script. :thinking:

:baffled: that's confusing... so you still have it in your boots, right? can you show me your sudoers configurations to compare with my last install which doesn't shows the issue? (I set to not ask for sudo password, never at all, from the installation)

Which ones exactly? There's quite a few in "/etyc/sudoers.d"

❯ ls /etc/sudoers.d/                                                                                                                                    
README  sudo_nopasswd_generic_triantares  sudo_nopasswd_packagers_triantares  sudo_nopasswd_power_triantares  timeout_inmediate  users-elive-migrated
~ ❯❯❯ 

In 'sudo_nopasswd_generic_triantares' 'elive-upgrader-root' is there on both my marchines (one machine with and one without encryption)

Fixed the asking of password on every boot:

Just run "apug" and you will have it fixed, or wait for your next system update :slight_smile:

mentions: @triantares , @r0to00, @linux23dragon @TheTechRobo