Laptop keyboard / touchpad problem

I will have to boot with another distro when I have a minute but, I am presently using my Laptop (usually I am working on my Desktop) and when I type, at some point, the mouse goes somewhere else on the screen or the computer seems to get something different from what I am typing.

I will try to pay attention if it's not me who's touching the touchpad instead of the spacebar ( may be...)

Did anyone experienced weird behavior on a laptop with a Touchpad ?

JF
Will try to pay attention to my hands positions and what I touch whe I type fast...

I have the same issue on E23 but still not sure whether it's me touching the pad or not. Sometimes I have the impression it's somewhere else on the laptop base.

Very unclear and often frustrating when typing.
I do think it's me (almost) touching with the palm or base of my thumb...these things work on body heat.

1 Like

IN the next Few days I'll boot with another OS on a stick and type

For me it's very frustrating LOL Especially when typing fast.... May be it's our hands position LOL not sure ....

well the touchpad should be disabled while typing ...... it's in preferences ->touchpad configurator.
You can check if it works by setting the re-enable time a bit longer and try to move your mouse during or directly after typing.

Sometimes I get the impression that it's maybe because I accidently hit the CTRL in place of SHIFT and a letter combo.

1 Like

In settings I have a TouchPad but when opening the App, it says I don't have a TouchPad

As for " preferences" LOL Where is that LOL

I'm in E23 lately but IIRC in E16 that would be just above or below administration in your left click menu.

Edit

That would be settings -> touchpad configurator in the left click menu.
and preferences in the cairo dock menu

.... even not working on Mint,
it's always active ... :confounded:

Works on my machine :thinking:

1 Like

MacBook, may be a wrong driver installed...
didn't follow up, not a desaster at all

I booted on with a USB Stick and :

I just typed for a while and very fast with last version Manjaro XFCE and I am not experiencing the weird behavior I am with Buster/Elive...

Will try to fix / make the TouchPad configurator work on my 3.7.x 64 bit installation to see if it fix the problem

hummmmm doing a test again on elive and it's very difficult to validate it's the OS that makes the difference... grrr As my typing position may change... Example, presently I was doing a test on Elive again to see and the keyboard was not going crazy but, it's may be because I was being more carefull....

Will create a new Desktop config to see if the TOuchPad config shows up...

image

1 Like

Maybe it's in part too, some of the key-combo's that do different things.
Me to my surprise dicovered that holding the L on facebook executes a "like" ...... so what's stopping other websites doing similar. :thinking:

Let me get this right .......:

You don't have a touchpad device recognized yet yet you are using one .... is that correct?

In addition:

On E23, I loose the touchpad disabling (i.e it's enabled during typing) unless I set the touchpad configuration. Then it works as it should until the next reboot.

  • This might indeed be a bug. :thinking:

BTW

That message text is about as @Thanatermesis in a nutshell as you can get.
His typicall language errors and frame of thinking. :rofl2:

1 Like

Yes exaclty.
JF

And what does xinput list come up with?

Ah, there's the issue :slight_smile:

So we need 2 things here for fix it in elive:

  • know why it is not detected as touchpad
  • see if the configurator works anyways

So, for the second option, that's easy, just run it with force mode, as:

touchpad-configurator --force

Then see if works

For the first thing, we need to know how to detect your touchpad, on this case, show me the result of:

cat /proc/bus/input/devices

maybe better as:

cat /proc/bus/input/devices | elivepaste

(so if you have a pastebin like link, is better than pasting it in the forum with lots of lines)

that makes sense, seems like E23 controls "too much" all the computer / desktop behaviours, taking out your own configurations

1 Like

@Thanatermesis

http://paste.openstack.org/show/785847

JF

b[quote="Thanatermesis, post:17, topic:1598"]
touchpad-configurator --force
[/quote]

it worked but problem still there... Keyboard behaving weird

image

Can you notice that the touchpad indeed has the 0.9 sec wait before it is activated after using the keyboard?
If not sure set it to 3 sec or such, that way you'll know if it's responding to the configurator or not.

1 Like