Opera wont install on beta

~ ❯❯❯ sudo apt-get install opera
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
opera : Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.16) but it is not installable
Depends: libgstreamer0.10-0 (>= 0.10.15) but it is not installable
Depends: gstreamer0.10-plugins-good but it is not installable
E: Unable to correct problems, you have held broken packages.

Please always add which version and archtecture you are on!!

Silly guess here:
Thinking you have 32bit Beta version ....... there is no 32bit Opera version any more only 64.

no mate 64bit uefi

Well it might be that recent updates broke some stuff in regards to opera.

On my system Opera is already installed for a while but if I do "api opera" I get the same libgstreamer error messages.... which is strange because an "apug" doesn't any give errors, meaning it doesn't set Opera to be an upgrade candidate or it is already the latest version.

  • In the latter case "api" shouldn't have errors either :thinking:

So just wait around till it gets fixed (it's a buster/opera thingy I suspect) or do a general web search regarding latest Buster and Opera.....and do tells us the solution if you find anything. :smile_cat:

this is more like a bug in the opera official repositories

"opera" points to a very old version, the correct package name that you should use for install is opera-stable:

api opera-stable

1 Like