Suddenly cannot access my partitions

From your terminal photo, I assume you've tried 3 timed the wrong password (shown as PAM Error) and more often the right one (not shown in the log)?
If you've only tried once the false one, the password is always wrong ... As in sudo, I think the system asks for your user password, not for the root (aka administrator) password. But since I'm not familiar with Thunar, I could be wrong ... I would go the following steps to analyze:

Please try to mount manual.

  1. $ sudo fdisk -l |grep sda1
    See what type of partition you've got. NTFS? Here is mine (ext4):
    /dev/sda1 * 2048 195311615 195309568 93,1G 83 Linux
    -> The types are explained in Partition types: List of partition identifiers for PCs
  2. sudo mount -t auto /dev/sda1 /mnt
    See if any error will be shown. Sometimes it is something like 'partition not unmounted properly, please do some magic with --force or so'
    If no Error is shown, try to access via /mnt ... Is everything there?

Depending on the results, we can go on.

On a side note to make a screenshot a tad easier:
The output on F12 can also be acquired by opening a terminal and typing:
"tail -f /var/logsyslog".

Or use "less" piped through "grep" ..... say:
"less /var/log/syslog |grep /dev/sd"

That way it can be [screen]shot or even have the output copied to your message.

As to the error:
You did check your CapsLock key didn't you. :shocked:

I think problem is with E23 login system , like what happened with Gdebi earlier when we couldnt install .deb files . because with E16 i have no problem opening and accessing the partitions with thunar

No if i try the correct password in E23, the password box just goes away immediately. If i try the wrong password the password box stays a few seconds longer and then dissapears on its own. Both times i dont get access to the partitons. In E16 everything is fine.

I do have an NTFS partition but i used to access it before

Returns :
cannot open '/var/logsyslog' for reading: No such file or directory no files remaining

I am always very careful with passwords. Caps is off. The problem seems that authentication just logs out whether the password i put is correct or wrong

Oops! there's a typo there (correct in the next line) it's "tail -f /var/log/syslog"

Did you try a reboot BTW?

Tried reboot doesnot work, but if i log in via E16 DE , works like a charm.
Back to E23 now the whole DE crashes and shows i guess we'll call it the red screen of death which ends with an ecrushdump.txt. Dont know if this can help identify the problem and where it originates. How do i upload a txt file?

I get this feed back

Partition 1 does not start on physical sector boundary.
/dev/sda1 3495999 208734207 205238209 97.9G 7 HPFS/NTFS/exFAT

This results in the partition dissappearing in Thunar file manager

copy it to i.e "gofile" and post the link here. :smile:

Would be interesting to see what E23 has to say why it crashes.

Crashdump for E23

Had a look at it but alas, I'm not acquainted enough with Enlightenment innards to see what is causing what there ..... albeit I have the impression that the crash has not caused by the disk being non-recognized.
It might be EFM (the own filemanager) that's causing some malfunction in the mounting i.e is stricter than Thunar.... I've seen other anomalies there between the two. :thinking:
You could try and disable EFM from the settings panel and see if thunar behaves like in E16 then.

And the question is 'do you find your desired content in ls /mnt?' ...

Lets go with the assumption we have a PAM issue in e23. Please open any terminal, type:
sudo tail -f ls /var/log/auth.log
Now I'm starting with 3-5 times [Enter] to get a gap and see the new lines.

Now try to mount your device in Thunar and we'll see what PAM is trying to do.

I really don't know at this moment howto go on. may we need to take a look at /etc/pam.d/ or /etc/nsswitch.conf ... But why should e23 use any different configuration, than the common one?
To be honest, I'm not using e23.

The only special configuration to use NTFS on-the-fly in Linux is to make sure your user is in the group plugdev. Check your groups with the command id at the terminal.

Even after disabling EFM, behaviour still the same with Thunar

Hi LupusE thanks for joining the rescue effort
Here is my tail output

Okay. The Issue seems to be udisk2. Maybe e16 don't using the udisk2... I've looked into /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy but can't say anything helpful, right now.

Please check is consolekit is installed ($ apt search consolekit |grep consolekit).

E16 works fine. The problem only shows up if i login with E23 as the DE.

The feedback i get is below so I did a sudo aptget install consolekit

Ntfs can be cagey at times, especially if it got disconnected during a file transfer or otherwise abruptly disconnected. So in a way it not mounting is not surprising, especially if it's in use by an existing Windows installation ..... what is surprising is that there's a difference between E16 and E23 there, apparently. :thinking:

The "tail -f /var/log/syslog" output might shed some light as to what the system has to say about the drive when connecting, after which (i.e correcting errors, if need be there) we could look into the differences how either DE handles those situations and whether those are bugs or features.

So let's handle this step by step, from beginning to end.

Tail under E23 after opening partition. Noted that it does not seem to even register here compared to E16 below

Tail under E16 after opening into Partition

im not following very much this thread but... does your partitions are accessible from Live mode? if yes, just reinstall elive to be able to access them again

in fact elive has features for that too (elive has features for everything lol), if you mount them from thunar, check the files inside: /usr/lib/elive-tools/hooks/mount/ , they have not tested in years so not sure if we still having the commands correctly set :wink:

oh wait, it had but not anymore :thinking: , before there was a "fix ntfs if broken" pre.mount hook

I can access the partitions in E16 and Live mode installs E16 which mounts the partitions anyway, just E23 which fails to mount them. I do not want to reinstall the whole OS. I had rather continue using only E16 and give up E23. I really was interested in E23 for bug finding, i will wait for it to fully mature.

I have a suspicion that this is an authetication problem like the one we had earlier with gdebi (the gui program for installing .deb files.) The authentication program/routine in E23 does not link to the mount command to mount the partition when the login password is entered correctly it exits just like gdebi was doing.