Terminology / APUG Problem

after a recent update I am experiencing the following

~ ❯❯❯ apug
Hit:1 https://deb.opera.com/opera-stable stable InRelease
Hit:2 https://repo.nordvpn.com/deb/nordvpn/debian stable InRelease
Hit:3 http://apt.insynchq.com/debian buster InRelease
Hit:4 http://linux.teamviewer.com/deb stable InRelease
Hit:5 http://deb.debian.org/debian buster InRelease
Ign:6 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:7 https://updates.signal.org/desktop/apt xenial InRelease
Hit:8 http://www.deb-multimedia.org buster InRelease
Hit:9 http://repo.buster.elive.elivecd.org buster InRelease
Hit:10 http://deb.debian.org/debian buster-backports InRelease
Hit:11 http://dl.google.com/linux/chrome/deb stable Release
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:
terminology : Depends: libefl1 (>= 1.22.0+git1bd9a8f232-6buster63) but 1.22.0+68+git53a0eb8fb6-6buster68 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

~ ❯❯❯ sudo apt --fix-broken install 130
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
terminology
The following packages will be upgraded:
terminology
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/188 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]

(Reading database ... 239542 files and directories currently installed.)
Preparing to unpack .../terminology_3.7.8+v1.5.0+git413b8791f-6buster12_amd64.deb ...
Unpacking terminology:amd64 (3.7.8+v1.5.0+git413b8791f-6buster12) over (3.7.8+v1.5.0+git413b8791f-6buster12) ...

dpkg: dependency problems prevent configuration of terminology:amd64:
terminology:amd64 depends on libefl1 (>= 1.22.0+git1bd9a8f232-6buster63); however:
Version of libefl1:amd64 on system is 1.22.0+68+git53a0eb8fb6-6buster68.

dpkg: error processing package terminology:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of terminology-data:
terminology-data depends on terminology (= 3.7.8+v1.5.0+git413b8791f-6buster12); however:
Package terminology:amd64 is not configured yet.

dpkg: error processing package terminology-data (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
terminology:amd64
terminology-data
E: Sub-process /usr/bin/dpkg returned an error code (1)

see if is solved now

apif
apug

~ ❯❯❯ apif                                                                                                                  130
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  terminology
The following packages will be upgraded:
  terminology
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/188 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]


(Reading database ... 239542 files and directories currently installed.)
Preparing to unpack .../terminology_3.7.8+v1.5.0+git413b8791f-6buster12_amd64.deb ...
Unpacking terminology:amd64 (3.7.8+v1.5.0+git413b8791f-6buster12) over (3.7.8+v1.5.0+git413b8791f-6buster12) ...
dpkg: dependency problems prevent configuration of terminology:amd64:
 terminology:amd64 depends on libefl1 (>= 1.22.0+git1bd9a8f232-6buster63); however:
  Version of libefl1:amd64 on system is 1.22.0+68+git53a0eb8fb6-6buster68.

dpkg: error processing package terminology:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of terminology-data:
 terminology-data depends on terminology (= 3.7.8+v1.5.0+git413b8791f-6buster12); however:
  Package terminology:amd64 is not configured yet.

dpkg: error processing package terminology-data (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 terminology:amd64
 terminology-data
E: Sub-process /usr/bin/dpkg returned an error code (1)

and apug
~ ❯❯❯ apug 130
Hit:1 https://deb.opera.com/opera-stable stable InRelease
Hit:2 http://apt.insynchq.com/debian buster InRelease
Hit:3 http://linux.teamviewer.com/deb stable InRelease
Ign:4 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:5 http://deb.debian.org/debian buster InRelease
Hit:6 https://updates.signal.org/desktop/apt xenial InRelease
Hit:7 http://www.deb-multimedia.org buster InRelease
Hit:8 http://repo.buster.elive.elivecd.org buster InRelease
Hit:9 http://dl.google.com/linux/chrome/deb stable Release
Hit:10 https://repo.nordvpn.com/deb/nordvpn/debian stable InRelease
Hit:11 http://deb.debian.org/debian buster-backports InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
terminology : Depends: libefl1 (>= 1.22.0+git1bd9a8f232-6buster63) but 1.22.0+68+git53a0eb8fb6-6buster68 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Let me guess:
You installed E17 and/or E22. :boogie:

If so ...... you were warned this was going to happen.:nod:
No big deal.

Not from what I remember... It's a new installation / upgrade over my e16

but as you say, not a big thing / of importance

I suppose it won't update anymore but other components will continue ?

Looks that way. But this shouldn't be happening.
I haven't done "apug" this week so I've got:
libefl1 (>= 1.22.0+git3eb7b3793b-6buster53)

For the time being, "xfce4-terminal" is nice. :grin:

Me I've always got "guake" running from startup ..... so F12 and I've got my terminal.

1 Like

I can't install software anymore because of this problem

  • Synaptic broken package doesn't work
  • sudo apt --fix-broken install doesn't work
  • apt --fix-broken install

any ideas ?

I don't feel like reinstalling...

~ ❯❯❯ sudo apt --fix-broken install                                                             100

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
terminology
The following packages will be upgraded:
dpkg: error processing package terminology-data (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
terminology:amd64
terminology-data
E: Sub-process /usr/bin/dpkg returned an error code (1)

~ ❯❯❯ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
terminology
The following packages will be upgraded:
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
terminology
The following packages will be upgraded:
terminology
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/188 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 239555 files and directories currently installed.)
Preparing to unpack .../terminology_3.7.8+v1.5.0+git413b8791f-6buster12_amd64.deb ...
Unpacking terminology:amd64 (3.7.8+v1.5.0+git413b8791f-6buster12) over (3.7.8+v1.5.0+git413b8791f-6buster12) ...
dpkg: dependency problems prevent configuration of terminology:amd64:
terminology:amd64 depends on libefl1 (>= 1.22.0+git1bd9a8f232-6buster63); however:
Version of libefl1:amd64 on system is 1.22.0+68+git53a0eb8fb6-6buster68.

dpkg: error processing package terminology:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of terminology-data:
terminology-data depends on terminology (= 3.7.8+v1.5.0+git413b8791f-6buster12); however:
Package terminology:amd64 is not configured yet.

dpkg: error processing package terminology-data (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
terminology:amd64
terminology-data
E: Sub-process /usr/bin/dpkg returned an error code (1)

What about just uninstalling (purging) terminology completely and waiting out till it's fixed?
Me I'll just give it a go on one of my virtual-boxes.
I admit the cowardly version. :innocent:

will try
I may have missed something in your replies, " UNTIL IT'S FIXED" ? Meaning, it's a known issue / BUG ?

Why I don't have it on my other computer ?

Never mind running apug now on my machine /// note the **downgrades:

Calculating upgrade... Done
The following packages were automatically installed and are no longer required:

  • fonts-noto-core fonts-noto-mono libmwaw-0.3-3 numlockx*
    Use 'sudo apt autoremove' to remove them.
    The following packages will be REMOVED:
  • libreoffice libreoffice-math libreoffice-pdfimport python3-uno*
    The following packages will be upgraded:
  • ephoto ephoto-data eruler eruler-data expedite expedite-data libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core*
  • libreoffice-draw libreoffice-gnome libreoffice-gtk3 libreoffice-impress libreoffice-report-builder-bin libreoffice-style-colibre libreoffice-style-tango libreoffice-writer libvpx6 libx264-157 libx265-176 nordvpn*
  • rage-player rage-player-data terminology terminology-data uno-libs3 ure youtube-dl*
    The following packages will be DOWNGRADED:
  • libefl-data libefl1*
    32 upgraded, 0 newly installed, 2 downgraded, 4 to remove and 0 not upgraded.
    Need to get 144 MB of archives.
    After this operation, 5,702 kB of additional disk space will be used.
    Do you want to continue? [Y/n]

So for the moment I'm stopping right there and finding out what the consequences are (and why) of removing "libreoffice-pdfimport" as a few of my personal scripts rely on that.

I've seen "mypaint" being slaughtered by those idiots at debian so I'm not surprised at anything, anymore.

1 Like

I tend to associate "efl" stuff with @Thanatermesis so I assumed he'd repair that stuff after a while. :innocent:
Admittedly I could go sleuthing as to what causes it .... but I'm severely pressed for time at the moment, sorry. :sniff:

@yoda does your problem persist?
I've just run "apug" and all's well on my machine.

What version of terminology do you have on that specific machine?
I've got version 3.7.8+v1.5.0+git413b8791f-6buster12 after upgrade.

on my Laptop too all is well

For now, no Terminology installed on Desktop...

I can retry to reinstall this one... But last few times it didn't go well.

❯❯❯ apse -f terminology | more
Package: terminology
Version: 3.7.8+v1.5.0+git413b8791f-6buster12
Architecture: amd64
Maintainer: Thanatermesis - thanatermesis@elivecd.org
Installed-Size: 644
Depends: libc6 (>= 2.28), libefl1 (>= 1.22.0+67+git4410f8b080-6buster67), termin
ology-data, dbus-x11

OK Here is the result :

~ ❯❯❯ api terminology
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
mailspring : Depends: libsecret-1-dev but it is not going to be installed
Depends: gir1.2-gnomekeyring-1.0 but it is not installable
terminology : Depends: terminology-data but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So you have some packages installed from 3rd party repositories that brought in incompatible dependencies/versions.
Probably repos using older versions than buster
Especially beware of ubuntu repos. If you do, use 19.04 or later repos.

well, this should be better dealt now, you should be able to install "e17" OR "enlightnement" as you wish with the correct removing/installing of packages when doing it (warning which packages are removed that are also needed, like 17-menus)

but the problem was more exactly that I was working with the EFL packages and more specifically with a segfault issue in evas for 32bits: ⚓ T8119 Evas segfaults on recent builds of x86 and I did many rebuilds, with some uncompatibilites between versions

the repo should be working correctly now and with optimizations for efl, I have updated mine without problems

2 Likes