USB Boot on Macbook not booting

Hi all,
I was wondering what the issue is - I can't boot the Elive Live system on my macbook. Etcher always creates 2 files on my USB and when booting nothing happens. All other Live systems on other USB sticks simply work - but only have one partition on the USB stick. MD5sum is ok.
I have no idea why that happens. It's a 128 GB Verbatim.

Any help or ideas available?

Okay I found the solution:
my macbook is 64 bit - and I only have the 32 bi image. I donated yesterday but unfortunately I can't get the 64 bit beta download now.
I hope they'll see and send me a download link so I can try it out without donating again.


If you are booting 3.0.6 Stable there ..... Be aware that it doesn't support EFI. 32bit in itself will boot on x64, that isn't the problem. The beta 3.7.x versions do support EFI, BTW.
Please do check first if an issue isn't mentioned in the FAQ page (hint: It is):

On wanting to boot Stable you need to turn on "legacy boot" i.e set it as first (or only) option in the BIOS.
As to the "donation" you should've received the link almost immediately ....... maybe check your spam folder?

I checked your links but couldnt find anything that would help me since my Macbook runs ISX and there seems no way to change the bios serrings to deactivate UEFI.

They sent me a link to download Elive but I downloaded the 32 bit version instead of the 64 bit one since I didnt know that issue existed.

You can simply re-use the same link and download the 64bit. Couldn't be easier. :smiley_cat:

There has to be! ..... "user deactivation" is one of the standard requirements for Intel chips to be able to use the firmware.

A quick search "access macbook bios" on the web comes up with this as the first result:

There are more of course.

I have to say im not really a tech person, so going into depths where there seems to be a prompt only is something I try to stay away from, since I have no idea what I would need to do.

I tried acessing the link again, but I can only select 32 bit, 64 bit wants extra donation.

There is no prompt.


Then you are not using the link you have received via email but the one on the site itself.
The received link, after payment stays valid i.e is not a one time thing.

Find the email titled "Elive Download" and use the link in there.


also from the Elivecd site:
Apple / Mac users: You will simply need to power-on the computer with the USB stick inserted while the Option/alt (⌥) key is pressed.

You can either enter in the bios to configure the boot order or to hit the key that selects the device to boot “only this time”, the second option is suggested.

Also be aware that there is no 64bit Stable (3.0.6) version. Only the Beta 3.7.16 versions have a 64bit variant and allow for UEFI booting, and that includes the 32bit version which should just boot on a macbook and is cost free.
Here's someones very recent experience:

The Beta versions are very different beasts compared to Stable with a very different temporary desktop experience.

Yes, thats what I did, but the USB stick doesnt show up as UEFI boot option compared to my Lubuntu USB stick.

And I havent tried the other hack from the video yet.

The Link only brungs me ti the downliad page of the 32 bit versions.

When I click 64 bit version it wants a donation.

ask triantares for the 64bit 3.7.16 link (not really be accesed by public), the download page doesn't have 64bit for 3.0.6, only 32 bit by email link.

Which 32 bit version?
First try the 32 bit one, if it will boot...if it doesn't then there's something wrong with the USB and it wont boot 64 bit either..

  • Did you checksum if the download isn't corrupted?
  • Try another machine if it gets recognized?
  • What did you use to write to USB? ... not all GUI programs work well...The commandline using dd is infallible though. :w00t:
  • Try another USB drive or DVD.

You keep on stating you need 64bit to boot ...... but that cannot be the problem.

I believe it to be so, because the 64 bit version has UEFI support and other distro packages worked well with this USB stick.

But as I said, I am a lay person.

I always use balena etcher to write images, which is also what you recommend.

See pm, please.

First of all :
Welcome to Elive.

For that we can help you, we will need some more information, like

  • do you already use a boot-manager, e.g. refind - or not ? ? ?
  • do you want to run this machine with dual / triple boot or single boot a Linux ?

Meanwhile we'd learn that we are talking 'bout a

MacBook 7,1 = Apple MacBook "Core 2 Duo" 2.4 GHz 13" (Mid-2010)
with an Intel P8600 processor and a NVIDIA GeForce 320M, 256 MB
soldered & shared memory graphics card.

This model is actually a 64bit machine, but can also run 32bit instructions.

I will adjust your situation and advise a bit later today. :coding: :omfg: :typing: :work:

1 Like

Ahm ...... NO.

Sorry for the encountered inconvencies.... :ohmygod:

Your problem is a different one:
Your machine needs to boot EFI, the Elive image that you used does not have this option.

You need another Elive image with (U)EFI boot.
Actually only our beta does offer this needed option,
therefor you will need the
or the

Use Balena Etcher for writing the iso to an usb stick
switch OFF your Mac
put in the usb stick
hold down the "alt" key and do not release
switch on your Mac (still pressing alt, yes)
until you can see the screen like this:

choose the the first USB drive icon like shown and hit enter:

Boot. :news:

A little HowTo Install Elive On Mac Hardware will follow later.

Reply if you need further assistance, pls


In fact the last beta versions (64bit only) should have correctly the UEFI and SecureBoot features included

Secureboot has not been tried yet by us (no computers available with this limitation)