3.7.4 betatesting experiences

We could give it a default wallpaper with a (joking?) warning when it is opened for the first time, maybe even a "Told you so ..." dialog if something not-yet-configured is chosen. :rofl:
I'll think about it and maybe create one this weekend. :muscle:

1 Like

June 15 .... 11.15 hours

Upgrade existing 3.7.3 Elive (which is previously upgraded from existing Ubuntu 18.04) to 3.7.4 using live-USB.
1- Boot USB in "secure mode" is not allowed: unverfied image.
2- Boot in unsecure mode (UEFI only) allowed ..... fine, let's go! Only I don't see a way to get EFI partition this way. :thinking:

3- Live boots with no problems or glitches :smiley:

So let's install! :nod:

    1. Install? ... Yes.
    1. Upgrade? ... Yes.
    1. Only user (recommended)? ... Yes.
    1. The standard options questions ... the, in my case usual ones.
      some installer work.
    1. Congrats you can reboot!


    1. Personalized desktop wallpaper/baclground, startups and previously downloaded themes are gone.
    • Solution: They can be found in "~/.e16.old" and copied over to the new "~/.e16" folder.
  • Cairo dock is as previously configured ... good!
  • 2 Previously installed apps (like guake and mc) are not there, which is no surprise as I chose "user only" upgrade.

  • 3 Printers: None configured, do new setup ...... Good!
    Added new network printer (hp 6122) running on Elive 3.7.3 ..... no problem, all good!

All in all a hitchless, smooth experience ..... let's call it BETA indeed and get to work on the desktop(s) experience. Kudos for Thana! :applause:


Let the installer also copy, at least the "backgrounds" and the "themes" sub-folders to ~/.e16. That way a user can quickly get his Desktop to how it was.

Copying "startupapplications.list" and/or other .cfg files is a mixed bag and depends on how much is changed. Could carry some unneeded risks in IMO.

1 Like

I probably missed that step / question

So, it is asking something about user when upgrading ?

I will test the upgrade again on one of my 3.7.3 laptop

Yes, after chosing "upgrade" it asks whether to upgrade the whole sustem or just the user settings. The latter option is recomended.
Will try a whole system upgrade on another (ex-ubuntu) machine.

1 Like

Ok I just saw / noticed it
Continuing laptop upgrade

Had difficulty wire wireless activation but finally worked


"All in all a hitchless, smooth experience ..... let's call it BETA indeed and get to work on the desktop(s) experience. Kudos for Thana! :applause:"

I agree, 3.7.4....lets call it BETA...Stable so far and I did not have any bugs to report. Very Nice Thanatermesis! :100:

1 Like

@Thanatermesis :

374_Alpha test #1 of ... ? :
Review by Rebel450 (this time - from the perspective of an average user):

First of All:
Great work @Thanatermesis !!!
Thank you for all your efforts, especially after the Btrfs desaster...

(Connected to the internet via Ethernet_DHCP)
All works fine - no misconfiguration occurred
I selected
Auto - EXT4 - Auto - no encryption -> on a blank SSD
Then when it comes to chose between e16 / e17/ e22
the installer has switched to German (!?!) [the translation is terrible, by the way!!]
How comes ?? I did not push any button for local settings at this point!?
The misconfiguration with deselected apps/games but installed though - does not appear again.
All in all everything works oob, except the stupid build-in wlan usb adapter = :face_vomiting:

After install has completed, I needed to switch the BIOS settings boot order to:
"Elive" - instead of the SSD "name" ; I used UEFI :wink:
After changing the boot order all starts as expected. (see image above)

Now to obviously bugs:

Elive Menu / Enlightenment Submenu/ Themes:
Only "DarkOne" is working flawless, allothers produce errors or misbehaviour. Sad.

Elive Menu / Settings / Appearance:
You can not apply "Adwaita-dark" the result is that you have in different windows (e.g. Thunar)
always a different appearance as on another window -
then "colours" in the Appearance settings window complains for missing 'lxsession' so you cant change colors at all

The NetworkManager Applet on Desktop disappears after clicking for actions on it

For Cairo Dock - it's nice - but I think you installed too much extentions.

The window borders are all looking different (Gnome apps in comparison to others)

The sensors seems not to measure correctly(?) SSD = 90C, Processors 4C - huh ?

That's it for now, will to be continued if some more is coming up :expressionless:

1 Like

Everything went well for my 3.7.3 to 3.7.4 upgrade on my little slow hp laptop
Only 2 small things

When I was asked to connect to the internet for the upgrade/install, the WireLess connection was a bit complicated, had to click 2 or 3 times on the WiFiNEtwork tool (top left corner) it as trying to connect with no success, at the stop I had 2 times the NEtwork/wireless tool at the top left but if finaly conected

Also, my opera was not functionnal / some error saying it could be related to extension or something like that, I uninstall and reinstall Opera with synaptics and everything went fine.

Didn't have that issue on my Desktop that is also using Opera... So I think it's not something people will go through

So pretty smooth upgrade

May be some suggestions for Beta fine tunning :

  • Could we make some WIFI tool show up earlier on the laptops when booting in live mode ? So people do not have to look for a way to connect to the internet ?
  • If I have waited, would a "Do you want to install ELive " or icon to install be visible ? Or people have to Click on the Desktop, Go into the ELive menu and find the elive install icon ?
  • When we boot, some windows overlap at the same time depending of the speed of the PC, The one saying we need to reboot for keyboard setting to be effective, the installation window, but I will try to go slowly over the process to better communicate what I mean, but long story short, the user can end up with several window on the same area of the screen....

:dance: :rainbowyay:

@Thanatermesis = :work: :coding: :surprise: :typing: :w00t: :omfg: :typing: :coding: :nod: :mwahaha: :music:

Scheduled ALPHA tests performed by the incredible and the incomparable Rebel450:

1. Speed comparison read/write between ext4 and reiser4.

2. 374_a additional install on a disk with previously existing installation of :face_vomiting: Win 10

3. 374_a install on a Aspire 5750G with Nvidia (Optimus) Nvidia 610m (uaaaah...)

Rebel450 = :coding: :omfg: :face_vomiting: :typing: :typing: :coding: :mwahaha: :nod: :love:

1 Like

Looking forward the results
MY Main Desktop and 2 desktop are in Reiser4. 2 Laptop are encrypted. But I didn't do speed comparison...

Chat / IRC icon is cool in the Cairo Dock When left opened


Nothing actually, I try the applet from Cairo-dock but it doesn't allow to add new keyboard-languages as the small flag I love in right bottom corner in 3.0.6 release. I'm not so familiar still with E16 so I use in this machine its Spanish keyboard (no problem to write in English with it) and try to write also in French, but more difficultly because French language have some special characters that they are more difficulty to employ with an Spanish QWERTY keyboard (they use an AZERTY keyboard with many symbols in different way from the good QWERTY ones)

You should just sit down and try out the numerous settings of Cairo....
( I hope, that you will have time, a glass of wine and .... ) = :omfg: :eyepopping: :applause: :love: :smiley14:

[I liked the e17 animations from @Thanatermesis better, btw) :love:

1 Like

OK I get it
When I receive some message / the notification of Chat, Signal etc in the Dock is that the icon is rotating... Really cool

that is because of the customized kernel, which mostly includes the reiser4 support (and a few tweaks), to have secureboot we would need to sacrifice that kernel and use the default by debian, even if i dislike secure boot entirely because is evil

the EFI partition is included in the USB (live mode), otherwise you couldn't boot on uefi mode for the live mode... then an EFI partition is required in your HD if you want to install it (but installer takes care of everything, asking you for it etc..)

mmh, this is a delicated step, if you boot in EFI the installed system (disabling legacy support), you should not be able to do it without the efi partition (upgrade mode doesn't ask for that partition, or maybe it does? to add one..), unless you have already one set in your HD (that is automatically used by the installer)

fixed for next builds (e16 dir will be not upgraded since 3.7.4-previously-installed-system)

you need to add the packages you want to keep installed in a special list, this list is asked in normal installs -and- if im not wrong it is correctly taken in account when you use upgrade mode too... add these packages list in the file:

sudo scite /etc/elive/packages_to_maintain_installed

if you have it previously configured, it -should- keep it installed / available on upgrade mode
this is due by re-using confs like /etc/cups, which if im not wrong the installer takes care of re-copying it, can you check which are the needed files for that?
for example, after doing the install, copy the /etc dir to /etc.bak, then install the printer, and compare the dirs with "diff -Naur" or "meld" to see which files are changed / needed for the printer thing

well, as said before, the .e16 dir will be not upgraded anymore since your previous install is 3.7.4, so I assume that it is already pretty well configured which doesn't require to have a new one since now

mmh, this question is in fact not much relevant / needed, i probably should remove it, the first one does an upgrade mode, and the second one takes care of reciclating extra things like printers, servers, etc... i assume that the latter is always the wanted one. The question was originally meant to be a way to select between "featured" and "more clean", but i still thing that the second option is the always wanted one no-matter-what

nice !

I worked a lot on the 3.7.4 after the 3.7.3 to fine tune every final thing and fixing previously reported issues :slight_smile: seems like is now a good one to start publishing it

2 messages waiting. ONe in Signal the other in CHAT LOL


Would it make sense from here / Beta, to have a Wish list and we VOTE to see which make sense to be implemented ?

I mean one will want this, the other, that,. the other Logout feature, the other that feature

WOuld it make sense, at this phase / beta, to throw a list of : Should have things, and we vote, to prioritize the important ones ?


Here are the results for ext4 without encryption;
test environment = AMD A8 | 4GB RAM | SSD _ GUID GPT Ext4 |

ext4 test results:

writing 2GB with swap ENabled:
2147479552 bytes (2,1 GB, 2,0 GiB) copied, 7,73116 s, 278 MB/s

writing 2GB with swap DISabled:
2147479552 bytes (2,1 GB, 2,0 GiB) copied, 7,1861 s, 299 MB/s

writing 200000x 4MB with swap ENabled:
819200000 bytes (819 MB, 781 MiB) copied, 10,6544 s, 76,9 MB/s

writing 200000x 4MB with swap DISabled:
819200000 bytes (819 MB, 781 MiB) copied, 10,5564 s, 77,6 MB/s

Reiser4 results from the same environment are coming soon...
:happy: :typing: :coding: :work: :shocked: :typing: :typing: :nanana:

1 Like

I had something comparable on a 3.7.3 install.
It happens when you connect to the internet but have the installer running too.
The installer and the system come up simultaneously and show 2 windows as it are 2 different processes all in all.
It doesn't do any harm, though. :smiley:

1 Like


Yes, will try an install on the M4400 to tell you @Thanatermesis if the nvidia stays in...
About E22, I use it for testing, and it seems to me (but perhaps I'm wrong on it) that the things I tell are not about configurations but more relative to bugs; when an icone of a software is ghosted but the one of an other is visible, when a key short is ok on a machine but not for an other....
The "nice" way of my experience is here not the subject: I for sure know that the last public release with E17 is wonderful and that the E16 can be very efficient & nice looking... And some here are very efficient in showing E16, so... :wink:
It's testing, so testing..... :slight_smile:

In Dell M6700 side, for now no evolution: I haven't yet made the full "tour" but there's still a problem with nvidia & optimus...


1 Like