3.7.9 alpha release

.... and also Calamares as update manager in detail (but Thana already pointed it out = :frowning: )
.... pitty :disappointed:

???? :stuck_out_tongue::stuck_out_tongue::stuck_out_tongue:

@maxinou, HP Mini, 32 bit, 2 GB RAM
was this not your machine with a harddisk issue (!?!??)

Im betatesting the installer but for now i was able to exit from it in any moment that I want, I would need to know the exact steps which will require a "cancel/abort" button

About the "cancel / panic" option, I'm changing a few options like this:


basically for the "do you want to add another partition?", which i think that is the case where is the most wanted / needed

mmmh, maybe the buttons should be added in the inverse order :thinking: but the default (other) question dialogs are always in the other " no + yes" :thinking:

reiser4 note:

3.7.10 will use kernel 5.2, without reiser4


Yes, especially there, actually anywhere where partitioning is concerned. That's the real danger zone.
Basically in the picture you have there, it would actually be best to start over again with the partitioner (or cancel totally and start over) because chances are that:

  • Either the root partition is already hogging the beginning of the disk (so will have to be moved/resized)
  • or there are other, older boot/efi partitions there that need manipulating.
  • After which we need a concise overview over what is going to be submitted and if the user is happy with that, or not......it's the point of no return after all.

In general it's with the partitioning where the shit hits the fan, one cannot be carefull enough there.



For the eeepc 1015pn, I fit via synaptic eeepc-apci-tools, but seems useless (still no fn keys for sound & screen light)...
Same machine, still bad datas about battery (indicate always 100% (but helas not true :wink: ) & max capa 97%)...
It seems that there's a problem with hibernation: screen stops, but computer continue to have leds & fan on...

I think that the Cairo-Dock should be configured ab initio with the "disconnect" icon, to have easy access to stop, restart, hibernate, or so..?


Dell M6700/nvidia M5000M: fn keys for sound & screen light ok! ...



I agree
Else new user will click Restart in the e16 menu and endup restarting the configuration of the Desktop

1 Like


Testing on eeepc 1001px (live): very good!
As already said, this one is usualy, for now on 3.0 with its nice E17, and a big differance with Elive x64 is that on x32, the cpus (2) tends to be at 100%, where in x64, to push them both to this rate, I, e.g. launch synaptic downloading, installing stuff + the demo "rupture by asd" via vlc at 1.6 speed before having some lag..!
(well, I made the system freez launching Opera web with 6 tabs plus a privative window for a YT video & vpn... ;-p )

Beside that, I notice a thing: when lauching the very same iso on this 1001px eeepc than on the 1015pn one, it appears that on 1001 the eeepc-apci-tools are ab initio installed, but not for the 1015..?
On the 1001, fn key for light are ok but not the sound ones, when on the 1015, as previously writed, none are functional (even after installing eeepc-apci-tools)...
An other special thing: for the first time on the 1001px, I can set Opera's vpn (comes "blue" when stays "orange" (not ok) before, even on previous x64 Elive)...

Here you are, for now!

1 Like

In my case system asked me for root partition (OK) but not asked me for file system (i use always ext4 for all my partitions including data one) and start the upgrade, when my first choix was a new one...

As I had choice a new clean installation it was useful that system asked me for use a partitioner tool, as it did

Yes, it was the case, be sure.

i didn't know that, good to know for the future

Don't worry, and yes, it was very strange but maybe as @Rebel450 saw later, is due to my broken HDD????? maybe it's the guilty..... I didn't think to this option....

What I meant was that the same ISO file and the same USB Flash memory were used the day before to install 3.7.9-32 in my Acer laptop without issues...

Good to know, and here you have a picture of those message, I'm sorry, in French, not in English (BTW, the barcode is still in present in live mode LOL):

Yes, is exactly as this....

That is that worries me installer never asked me nothing about /sdaZZ partition that NEVER should be formatted because no file systems was inside, only my own work data (backed-up in an external HDD so no data lost)

Nice to has been helpful

Yep, you're right so maybe the issue cames from my broken HDD, you've a good memory :+1: I didn't even think to that possibility

Yes I think in the same way

I'm doing this now to perform a new 32 bit installation from USB Flash, I'll do the same with my other USB flash that contains 64 bit release

yep, i experienced this feeling too, like forced to continue while selecting extra partitions and thinking "oh wait! i would need to create a another partition bla bla"

so this is specifically solved now :slight_smile:

tell me if you see another place where an "abort" button is needed :applause:

added customized logout icon in cairo-dock
also the hotkeys pdf launcher custom app

(for next build, or use elive-skel at your own)

the eeepc-acpi-tools are dynamically installed/removed depending of the "detected" machine :slight_smile: , tell me if there's any wrong setting by default (installing/removing the package when its needed / not-needed on each machine, a reboot will be needed probably)

yeah but i was unable to reproduce the same issue :confused: , using the same steps... if next time happens again to you, we will need to know the "why" and checking how to reproduce them

check your collected data from:

cat /etc/elive/disks-health

the pendings are the bad ones, the reallocated are "not so good" but probably not an issue

well, it can happen if your usb moved during installating like wrong connection on it, but again, the best is to "sudo dmesg" to see which kind of errors shows when it says that (which the installer should in fact report what exactly happens, if the info is correctly wrote)

ok i see the picture, but "sudo dmesg" will be needed to know what it says (from where is the error), and I strongly suggest you to use usb-bootable-elive with the -c option :slight_smile: which will "revive" any possibly damaged usb (over the time, they sometimes produces errors)

Humm... this is a delicated thing, for security the installer won't show you as an upgradeable system a system which didn't installed correctly, I can improve the installer to ignore this "mark" for the "upgrading/migration" modes on which the system should be much more "better installed", but again, since the installation didn't finished correctly (and you had a first successful boot), it could be "half"-correctly-installed, like missing things and specially configurations of the system, like mountpoints, users, etc... This means that you could have the option available but without a guarantee that the upgrade would work fine (again, since its not a verified of correctly-installed system). This is a good or a bad thing to have? im not sure... its a security measure in fact :thinking: :thinking:

mmh, this is very strange issue, im not sure if i can find some information from your reports but i can try it


can you tell me which one of these reports could have been the one with that issue? :slight_smile: (timezone is same as yours, from Frankurt timezone), in the end of the filename you see the version of Elive too


I just reboot the 1015pn to re-verify but nothing more (but perhaps too, I will look around its bios version...)

When installing a new program, (say Opera web), it appears in the Cairo-Dock menu, but not in the E16 one...

Just for testing, on the 1001px (2Gb), I arrive to launch 3 times VLC with three different videos with quite no lag (a very little), and the cpus are not 100% full time, where on the 3.0 x32, cpus tends to 100% with only one... (well this performance is still very low in compare with a good old Amiga 4000 PPC under WarpOS (AmigaOS 68k+PPC), where It arrives to play around 20 videos (in little windows) with 4 sound channels ok before lag/freeze..!!! 'was specially good hardware!!!)

Thanat's work in finding the last little resource of both hard&soft~ware is very impressive, somewhat as a demo maker mind for "business", "serious" stuff on a large family of machines..! :+1::ok_hand:


An other difference between the 1001px & 1015pn eeepc's: on the 1001px, at start (live), Conky fits perfectly just in the screen, where for the 1015pn the connection lines are down under the screen limit and need to have fonts sets from 8 to 6 (7 if # for the space lines) to have all in view... AND the screens of both are 1024x600!!! Just noted too that in Screen Layout Editor, Primary is by default for the 1001px but not for the 1015pn..?


in e16 you need always to use the "regenerate menus" option

maybe we need an automated regenerator for every reboot :thinking:

can you include a screenshot? :slight_smile:

about eeepc-acpi-scripts, i would need to know if you need to install (or remove) this package in your each machines, in order to make it behave / work correctly, to know if the default settings are not correct (if should be installed where is not, or removed where it is)

Maybe the good idea is to prevent user that it has a "corrupted" installation and offer him the option between made a new one at that partition (lost his configurations) or try to upgrade the corrupted installation (with a dialog box that explain that he has no guarantee)

I give you all explains of logs upper here, I have a big issue in HP Mini 2 GB RAM that is not present in Acer Aspire 1 GB RAM (always in 3.7.9-32) that apug in HP mini upgrades almost 150 paquets and I lost my network connection (both wifi and LAN) and also Conky is lost, here you have a screen capture from my clean new installation done this morning and that I won't apuged until you discover where is the problem, the strangest thing is that 3.7.9-32 in Acer (older and less RAM) is very fine and not problem with apug, also @yoda seems to had same issue in one of his machines that was solved itself after several reboots.....

If I agree I lost network connections + conky and system takes almos 10 minutes to power off, with those messages:

Hoping that the logs + apug package list + those pictures will be helpful to you...


. . . .

That would kill off every personal customization or theme. There be dragons there.
Better to ask than to use automagic. :mage:

this is a strange issue, but seems like "conky" simply crashes... is there any message on "sudo dmesg" about conky?

unless your upgrade removed some unwanted packages, i don't know why this could happen (broken HD? check your RAM too from the Live first boot menu -> extra tools)

finally, just upgrade to 3.7.10 :slight_smile: , but note about your /documents issue! which:

@maxinou /documents partition issue:
I think that I understand what happened here, it didn't formated that partition but deleted its contents, the reason is that a directory called "documents" in the root partition is simply wrongly put (your files should be in your /home/USER directory, and there it wont' have been deleted), the installer takes care to clean your system and he didn't know that /documents was a thing to not delete... in any case I will improve the installer so that this won't happen again, but my suggestion is to your mountpoints in the correct places and then "sudo ln -s /home/USER/mymountpoint /documents" to have it easily accesible for you (which is the reason you put it on your root structure :slight_smile: )

this improvement on the installer is not yet implemented, i need to work on that and do some betatestings first! :slight_smile:

@maxinou your screenshots looks to show a damaged install, maybe because of a broken HD, please check the /etc/elive/disks-health file and check your ram too

not really, every desktop has dynamic menus, if you add an application, it should appear and if you delete it it should unshow it, so the correct thing to do is to improve the dynamic generator to any need. By other side it is possible to add also a "user's own menu" that could a yours personal one and this wont be regenerated

1 Like

I doesn't know because I have now a clean installation where I doesn't still apug (need the laptop for my Tuesday travel)

I'll check my RAM, but I think remember that I did those RAM test some time ago with success....

but my partition was called "documentos" in Spanish because it exist from times I lived in Spain, not "documents" if you mean that system maybe was confused about name, anyway, I never use /home to keep my personal data and even I have not a /home partition, IMHO if the partition could be called "anythingelse" none there was different of a "documentos" named partition.... even if their name has been /documents in English, system never should delete those files, I think, anyway, as my data was backed-up it doesn't matter and if that lets you improve system I'll be glad

Here you have:


If I doesn't run apug everythink is OK now, the issue cames at first (and only) apug in this machine at least for 2 consecutive clean installation.... maybe a HW or HDD problem, but it seems that @yoda had the same issue once and it was solved itself after a few reboots, that is not my case


'Got some problems with multi install: For testing, I have on the M6700, a ssd where I want three systems: One "pure" Elive, one "morphed to Elive" Mint and one "Morphed to Elive" CAELinux, plus a somewhat home, the /"bios" & the /boot...
Installer asks each time for the /boot: Can't figure out if it's an additive process or not... I suppose /bios didn't vary?
I can have grub "vanish" generally ok after an update-grub in rescue mode, but I have too password problems, even trying in qwerty scheme... Having to look forward it (after dl the new .iso)...


This is something that isn't always clear to me either......good point. :thinking: