3.7.9 alpha release

For now we will have 64bit ISO, 64bit USB, and 32bit ISO versions

IMPORTANT: you should stop using reiser4, we will probably not use anymore custom kernels by elive and using the official ones signed by debian, this means that your reiser4 partitions will become unreadable, so i recommend you to switch any possible disk to a different filesystem (in fact we only have ext4 as option, duh)


  • nvidia drivers: many internal improvements, fixes and tests (thanks @Rebel450 for the hardwares :slight_smile: :happy_dance:)
  • much improved allocation of RAM memory for the live system, which means:
    • low-ram machines can install nvidia in a more reliable way
    • more things you can install on the live system (filesystem allows more space now)
    • bad (somewhat): if your ram is full you got before "not enough space on disk", now you can have the Live system to freeze (memory saturated / stuck), this is of course not so bad if we are on Live, nothing important breaks, by other side this case should not happen since the allocated space is meant to have an enough safe shift to not be at full
  • wording improvements by triantares (for other things, they can be directly done from eltrans automatically by translating to english)
  • USB version available with persistence support included (wohooo!) - non-uefi images
  • possible fix for low-end computers in 32bit wanting to install in encrypted mode that sometimes failed when low memory (bugfix by debian)
  • many stability and bugfixes improvements by debian updated release
  • all elive applications updated with translations (after apug), their updating will be more automated since now too
  • EFL stuff:
    • efl own build, very updated, and with with wayland
    • enlightenment last (or pretty much) build, with wayland support

wayland notes: if you run the live from a virtualbox (some real hardware may work too, but not all of them are supported) and in "console mode" (tty) you run "terminology", you will see that it directly opens on your tty, you are not in X11 graphical system, you are in wayland graphical system :omfg: , in the same way you can run "api enlightenment" to install the last enlightenment and then "enlightenment_start" from the console tty, and enlightnement will open on wayland mode, extra compatibility has been included to support (be able to run) x11-applications (they must be writed for wayland in order to have a correct wayland graphical system support instead of x11), so basically yeah, you can run enlightnement over wayland :slight_smile: by other side its important to note that the compatibility with wayland is much lower and some things could not work, it is not suggested to use wayland, but its directly available, and so you can directly play with it and use it :slight_smile:


Just apug'ed the 2 machines and can confirm @Thanatermesis.

All is well now. :boogie:

1 Like

@triantares , pls

what about hinting - I got very poor screen solution on fonts.

Ideas ??

it' done

But I stumble over little things during operating ...
I guess Reiser4 let me not all do what I want,
blocked access to several actions, even Cairo-Dock dosen't write the changes I made persistant...

OK let's go further tomorrow then

Hi guys,

For myself, first installation of 3.7.9-32 in Acer yesterday night, with some minor issues and also 32 bit in HP now with also some issues:

  • In Acer: installer asked me for upgrade or new installation, chose "new", use of Gnome partition disk (but not format sda7 myself) to verify which sda was the good one for my /, then installer asked me to use Gparted, I clicked NOT, thinking than when I'll be asked for where to put / system will format sda7 itself as my choice was new installation, not upgrade old...... and installer doesn't format sda7 and make a mix of new and upgrade, because I lost my own added repos (nordvpn) but I had my old user.... as those sda7 was where apug fails saturday, maybe the nordvpn repos was missed saturday, not sure...

Anyway I started again the installer and have a clean new installation using Gnome partition disk + Gparted and formatting myself sda7 without issues. I think the installer should be more explicit for new users and also verify and let came back before the final option is taken

  • In the other way, in HP, I'll try to upgrade 3.7.8-32 this morning. In the middle of installation process installer says me that my USB flas drive is damaged, or the ISO is damaged (the ISO+USB with I did Acer installation yesterday) and installer seems to work for some hours with no results.... I abort installation, reboot, and try again, in upgrade mode... installer only detects my 3.0.6 partition and I think is actually upgrading 3.0.6 to 3.7.9......
    So I think I lost 3.0.6 (doesn't matter, we are for perform those tests) and curious to know what happens with old 3.7.8 partition.... installer is running, I'll see lather what has happened....

Looks a lot like what happened to me when trying to upgrade 3.7.6.

I very much agree that just before the final commit before accessing the partition ..... the user should be shown what and where something is going to be changed (or not) and give a chance to totally cancel the whole install....exit 0 for all (sub)processes.
For now there are cancel buttons there that simply have no effect at all on stopping the install process i.e the installer just goes on and on.:omfg:

Yes, and effectively I confirm that my Elive 3.0.6 has been upgraded to 3.7.9, and in a bad way.....

  • sda5 where was 3.0.6 now has 3.7.9
  • sda6 where was 3.7.8 and was updating first time to 3.7.9 has more or less the same directory structure (for memory: installation in upgrade mode breaks with a message that my ISO file or my USB flash memory were damaged) so I doesn't know if is the old 3.7.8 or the new corrupted 3.7.9 installation

But the worst is that installer had formatted by itself without ask or prevents me my /dev/sda7 where all my data was and mounted it in their usual mount point /mnt/documentos but completely formatted for me it's doesn't matter because I had always an Unison sync copy in a external HDD and also installer asks us to make a backup of our all data, but usually this /sda7 partition never should be deleted in an upgrade I'll flash again 3.0.6 and came back tomorrow into my classic 3.0.6 + 3.7.x + documents schema....

@Thanatermesis normally installer should reports you something broke into elive-root-*** paquet at 15:20-15:25 PM French (and Spanish) timezone today 9 september 2019 from my Gmail account....

If not, 3.7.9-32 in Acer seems very smooth and quite fast with 1 GB RAM :+1:

I'm also starting to use Eltrans, my goal is to have 100 % French translation done in 1,5 months maximum

Means, I will redo the Saturday's install :coding:

@maxinou you mean that 3.7.9 doesn't installs correctly in your 32bit machine? the ram usage should be an improvement :thinking: , how much ram you have? I will made a simulated test in a virtual machine

upgrade mode could require a bit more of ram btw

not sure to understand exactly the issue, but the messages should explain every step correctly, is there any info missing or an option missing ? (which step? what should have instead?)

some of them, but basically because they means "no" instead of cancel, the name "cancel" BTW can be changed to something else (like "no"), so if you* know which ones are, tell me or make me a list so I can rename them

mmmh.. this confuses me so it should never happen (everytime a formating is going to happen, it should ask for it), do you remember the exact step/message?

Well obviously these steps are hard to reconstruct ..... but on Saturday. the chronologically first install I did (and submitted data with my protonmail address) had (very dire) issues with the cancel.

Before submitting changes to the partitioner there should be a warning and the option to cancel (exit 0 for all processes) or to go back if something is not understood or clear.
I am not refering to an install a user (and me) is in full control of but ..... the moment it hits you that you're not sure if you chose the right partition or option and you really, really want to quit and start over ....... ergo: We need a panic button ! :applause:

Which on a different note makes me wonder:

What are your reasons against using "calamares" as an installer?
Why are we using all these pop-ups with all kind of sub-routines that are hard to control when there's an easy and proven option available?
Some very specific sub-routines, like the data delivery can be added to calamares, if need be, No?

elive installer is much more featured, and would be not possible to use these kinds of frontends, we can only -improve- our actual elive installer, it has been pretty much improved over the years and can still be improved better, for example see the "user creation", it was in multiple steps before, now we have it on a single step with all the user's data

as said before, they can be improved (in what's possible) like the users creation step was, but we need to focus on specific pieces (parts) to improve one to one seeing what's possible to do with them :slight_smile:

in fact i don't see anything useful on calamares that we can use (also, this would mean a full rewrite), but basically we have 2 important points about this topic:

  • calamares can look better (not necesarily better working or more intuitive)
  • elive installer has too much steps, most of them are needed but we can improve / cut them a bit
  • some steps cannot be made in the same window and needs another one (needs to know a specific data to know what to show next, like asking of want to migrate when another OS was found on it)

The other way round:
Actually I was thinking to adapting "calamares" to our needs....it has, after all proven to be very stable, user friendly and almost the default installer overall.
Why re-invent the wheel when it's already there?

Admittedly, I have not looked into the installer code to see what's going on and what is very specific to Elive ..... maybe I should but I'm somehow getting the feeling that I'm taking on too much work for my capabilities (and my time) and need to focus on what is important in the short term.

Winter is coming ! :rofl:

well, talking about "short term" priorities this is not one (in the sense that could be a lot of work)

by other side, I know the code of the eliveinstaller entirely and i know what it does, this is why i say that is not possible to use a different front-end (see previous explanation, specially the last line)

i would say the inverse lol, calamares is much more limited and it is the one that should be adapted to elive features, about stable, well, i tried it only once and I found a few 3-4 issues on the interface, about userfriendly, yeah, why not... but i can tell you that my mother or many people will be not able to use it, instead, the elive installer can have multiple steps but everything is very well detailed and explained, I have already betatested it in many (very-novice) people just to see if they are able to install / understand it (while improving the parts not understandable)

as a final point, maybe the installer is not the best liked application of elive but it is meant to be used only once :slight_smile: , and it provides all the features that we need + special elive ones, what we can best do is to simply improving the "boring / disliked" parts, so basically:

  • locate a specific part to improve
  • brainstorm the procedure in what can be better
  • implement the improvement :slight_smile:

Well we certainly need a kill/panic/back button, on every step of the procedure up to the very last moment, just before the partitioning takes place. After that it's obviously irreversible and should be clearly stated as such.
Cancel should be cancel and No should be marked as no.....there's a big difference IMO.


I have not a RAM issue, really, I'll try to explain me better:

  • Acer, 32 bit, 1 GB RAM

My idea was to made a new one installation, instead an upgrade because some people here like @yoda or @triantares usually does upgrades, I usually does new installation, so you can have our feedback for both type of installations. I usually doesn't play with themes nor other personalised config and my data are always in a backup so for me perform a new one doesn't me lost any personal desktop configuration...

With this idea, I ran installer, then gnome-disk (to add mount point to my documents partition) and then go out.... installer asked me then to run Gparted and I click NO thinking that I'll be asked later to format /dev/sdaXX for /; installer asked me where to put / and I choice /dev/sdaXX but installation process starts in upgrade mode without asks me to format /dev/sdaXX for a clean installation, that was the option I had clicked in the firs step

So finally I got a 3.7.8-32 upgraded to 3.7.9-32, no issue at all while upgrading but that I wanted was a new installation, not an upgrade. I ran apug and I discover that my nordvpn repos had despaired, but those maybe has been done before, in the apug fail of saturday.

So, for conclusion, upgrades works fine with only 1 GB RAM the issue maybe wasn't if I manually formatted /sdaXX as I usually does, but IMHO the installer should inform+confirm user that /sdaXX YY ZZ will be / won't be formatted, their mount points and if the installation will be an upgrade (and in this case and upgrade from OS located at /sdaXX YY or ZZ) or a new one and then ask user for final validation.

  • HP Mini, 32 bit, 2 GB RAM

Here was the really issue, here I decided to upgrade 3.7.8 to see what happened in Acer, so I choice upgrade; installer shows me that I have 3.0.6 + 3.7.8-32 and asked me which one I want to upgrade; fine, I choice 3.7.8-32 and upgrades begins....

But, in the middle of installations process installer stopped himself and says to me that one of my 3.7.9-32 ISO image file or my USB flash drive is damaged thats wrong because the same ISO+USB flash had performed the Acer upgrade 1 day ago.

I reboot again in live mode and started again upgrade to 3.7.9-32, at this moment, installer detected only 3.0.6 system, not 3.7.8-32 where it was failed some minutes ago. I suspect that 3.0.6 will be upgraded but I decide to continue to see what happens.... upgrade rans fine at finally I discovered that, effectively, sdaXX where was 3.0.6 has been updated to 3.7.9-32, sdaYY where was 3.7.8-32 is full of folders and files in a classic Linux hierarchy (maybe old 3.7.8 files or newer 3.7.9-32 failed files, or maybe both together, I doesn't know) but, and the worst was that sdaZZ where only were my working data had been formatted and partition was completely empty!!! Why?, I doesn't know, it shouldn't never had arrived, yes I agree, but it did. is no problem for me because my data was backed-up out of laptop but is a very big issue to discover why is arrived and to solve it.

Now I'm installing again 3.0.6 + 3.7.9 + data in this HP because is my travel laptop and I need it Thursday night in Belgium for my Friday's meeting, but from next week I can install again what you need and perform all test that @Thanatermesis asks me.

But here, the probleme was due to first upgrade stopped by system thinking that ISO or USB flash was corrupted, that it wasn't true, because I did Acer installation and now I'm doing HP installation with the same ISO+USB without change them I doesn't know if my installer sends you a log (I hope) to investigate it.... then, when starting the new system, it asked me to send you a log from something wrong in the package elive-root-xxx and I obviously agree, so at least you should have one log, but I hope you had 2 log from my system (the HP ones) that let you to discover why installer stopped thinking that ISO or USB flash were damaged....

If I doesn't explain me correctly (not easy in English) please says to me and I'll send you a PM or mail in Spanish. :+1:

The big problem is that there wasn't any message, the step I hope I explained it correctly in the upper message.

I agree, in debian installer you can came back in multiple steps if you're not sure that what choice you had take, or to change something, here installer only lets go forward without possibility to came back for verify or change our choices. Is the big feature that need to be add to our Elive-installer

1 Like

That's normal. You can reinstall the repos with the .deb you downloaded from NordVPN, then apt update and `api nordvpn``

That was my issue too but was due to a low powered USB. I had stuck it into an extra socket on my keyboard but apparently there's not enough voltage there.
Putting it in another socket closer to the machine did work.

I also had the same thing happening(problem with elive root message ) with my elive 32 machine. Since then the laptop is working fine

Maybe they were lost in Saturday's apug failure

In my case I always use the same USB Flash (one for 32 and another one for 64 bit release) since 3.7 started and always in the same USB sockets in both laptops

So now there are at least 2 logs for this issue, mine and yours