About Tor Browser

useful

#1

Elive has a number of browsers pre-installed or gives the power to user to choose & install them at the time of installation. It would be great if Elive provide Tor Browser pre-installed :excited:. Tor Browser is very essential to surf online & it keeps our privacy and provides the power to become anonymous while browsing. I tested Tor Browser on Elive works fine but i found a little issue while creating a personal application launcher it shows Elive_Screenshot_2018-08-21_16%3A03%3A14__355x123
but it works everytime i execute it from the directory.


#2

May be it need sudo right ?
If you call the application menu Alt+Esc
Try after selecting your app, clicking Launch on the top right
Run with Sudo

Curious to see if it help

yoda


#3

I’ve tried sudo but it does nothing at all even not showing that error. but with gksu it ask for administrator password and shows the same error…


#4

OK will try.
Which version of Tor you are using ?


#5

I’m using the latest version of Tor.


#6

I tried
Same error
@Thanatermesis what is the right way to do it ?

I used the " Personnal Application" tool, gave name TOR, browse to the Tor startup file


#7

The application failed to launch, that’s a problem from the application

First you need to know why it doesn’t launch, applications are normally run from their .desktop file, the first screenshot says which is the .desktop file that try to launch, so now, you can read that file to know what is trying to run, for that you can try: grep Exec somefile.desktop

Which will show the executable that try to run, maybe with some parameters but normally you can now try to run it from a terminal, for example this will run what :

~ ❯❯❯ grep Exec /usr/share/applications/Thunar.desktop 1
Exec=Thunar %F
~ ❯❯❯ which Thunar
/usr/bin/Thunar
~ ❯❯❯ file /usr/bin/Thunar
/usr/bin/Thunar: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, BuildID[sha1]=0x53c6f4b0d6cd5ae99760d56699643b2c3b9d6bc8, stripped
~ ❯❯❯ Thunar

This shows in detail what try’s to run and what is the type of file that try to run (a binary executable), if was the case of a script, then you can sudo edit it to add debug lines (set -x) and see where it exactly fails


#8

@ Thanatermesis I’m not a computer scientist like you. The way you explained seems Hebrew alphabet to me. My point was i wanted it pre-installed on the system cause many distro provides it. and Unlike other software packages it’s a bit different to add in launcher. We will be glad if you do that for us.:smile:


#9

LOL LOL :-):mwahaha:


#10

Will look to include it in the next versions

But as I said, try to run it from a terminal, the .desktop files are launchers (as your first screenshot shows), run “grep -i exec” to that file similar to my example to know the command to exec, then run the command to see if shows any error message, it may be a library version issue or a missing dependency