Access Host Shared Folder while running Elive as guest

I installed the elive 64bit in virtualbox, but the host shared folder is not available. How do I access external files?

I personally never use a shared folder.
I find it easier to mount a folder (or the whole host machine, or vice-versa)over ssh or sftp.

Shared folder is an essential part of the work flow. The interesting part is that it works prior to installing elive on the drive, but not after it is installed on the drive.

@triantares how did you mount the host drive from within the guest?

I'm currently on windows 10 pro host and elive 64 as guest in virtualbox.

Long story short:
You can't AFAIK. It requires openssh-server. :slightly_frowning_face:
Considering my knowledge of Windows ended with Win98, you could try this if you're adventurous.
What can be done is copy files to and from Elive by the host.
Use "filezilla" or "winscp" for that. :smiley14:

Ya. Good idea, but not a suitable solution for a work flow.

Not sure how I'm supposed to see the workflow. :thinking:
I made some additions to the previous answer.

If it worked prior to on drive installation, it shouldn't be too much of a leap to get it working after installation. @Thanatermesis

That's the part that doesn't make sense to me -- is there a driver in Live mode that isn't in installed mode because @Thanatermesis doesn't expect VM users to install?? Have you @bitmaster1 installed virtualbox guest additions, or is it not available on debian?


And by the way, welcome to the forum! :happy: :smiley14:

Yes, there always is because .... the live mode user has more privileges (i.e = practically root) than the default user in installed mode.

ah...but I meant e.g. a virtual machine driver.......???????? or a driver for whatever technology the shared folder uses??????

Ya. It'd be great if the host shared folder worked out of the box Until then, I can't really do much with Elive until that works as the shared folder is central to all the other vm's (about 40+) that I'm working with. Thanks for the warm welcome.. :grin:

I installed 3.8.14 in Vbox after running it in live mode first and indeed once installed Elive (or actually Buster) does require some actions.

First and foremost you need to install "guest-additions" on the host. Considering your other vm's, I suspect it already is installed in your case.

  • After which you go check if the guest-additions.iso is mounted in the Elive session.
    In there go to the CD drive and click "" and execute that script with root privileges, when asked.

  • After that the shared folder will be accessible after a reboot.

  • If you want to use the folder as the user you are, do:
    "sudo adduser `whoami` vboxsf" to add the user to the needed group.

Good luck. :smiley14:

On a side note:
I'm surprised that someone that has 40+ vm's running .... hasn't encountered this issue before. :thinking:

@triantares Thanks. You got me going in the right direction. The host is windows. Elive is the guest. In my case, guest addition was installed from the insert cd of virtualboxand yes click on the vboxlinuxaddition, but it wasn't done in root. It was done in a super user account and thought that was sufficient. I guess it wasn't.

The whoami part didn't work for me, so what I did was just chmod the /media folder and then it worked like a charm. Now I can proceed to the next phase of testing. :slight_smile:

Probably due to the formatting of the text here ..... I had to uses backslashes for the back-ticks there.
They only work in a shell if one uses them and not the apostrophe sign. It's (with a us_en keyboard) under the ~ sign on the top-left key.
I used `whoami` because I didn't know the user name .... Maybe I should've used $USER instead. :thinking:

Anyway, glad it's going where you want it to go. :smiley_cat: