Access to time settings; time zone, locale


#1

Trying to rectify my time settings which are off by 7 hrs. As far as I am aware, HW clock is fine after I went into BIOS and reset it. I can find no further settings for it on this dist.


#2

@Thanatermesis ?


#3

If you type the command date what is the output ?

CTRL + ALT + Del or SUPER KEY + T (WIndows) to get the terminal window

~ ❯❯❯ date
Fri Jan 4 12:40:40 EST 2019

I am eastern time


#4

Fri Jan 4 17:53:54 UTC 2019


#5

And is your timezone UTC ? When we install Elive it is asking us wich country we are, you did choose the right one ?
But, I think that @Thanatermesis is using may be another method to set our timezone


#6

Yes, set keyboard also to USA. Fixed it with the tzdate procedure, changing from UTC to PST. Thanks for your help.
google the subject for hyperlink: changing-timezone-on-debian-keeps-local-time-in-utc


#7

This is a delicated topic, Elive has an own feature to automatically set the time depending of your timezone if is detected, this works good the 99% and you should not worry about anything, when you move to a new location / country / city it updates your time automatically when you connect to internet

A possible issue is when it can be related to the UTC / LOCALTIME configuration, the tool is meant to detect if there’s a windows OS to know which mode to use, but seems like windows doesn’t sets it the same way everytime and this can cause problems showing an offset time, I was thinking to solve this simply asking to the user during the installation process about “which time is the correct one?” (showing both UTC and LOCALTIME versions of the time), but it was not implemented

Also, this tool doesn’t include a way where the user can configure it himself, but should be not hard to implement it (something like editing the /etc/elive-tools/geolocation/timezones.conf file that controls the times and how they are configured)

If you know bash scripting you can check the tool located at /etc/NetworkManager/dispatcher.d/timezone-update , the code flow can be a bit confusing and I think that all the cache’s related code should be removed for reliability purposes, you can also try to play triggering it yourself with something like:

~ ❯❯❯ sudo EL_DEBUG=3 /etc/NetworkManager/dispatcher.d/timezone-update wlan0 up

(if your network interface is wlan0 for wifi, or probably eth0 if LAN)

you can also append the -f option to the end to force the update

And, try to edit the /etc/elive-tools/geolocation/timezones.conf file to change the “bios mode” or the “last” values to the correct ones for example


#8

Methinks that "sudo dpkg-reconfigure tzdata"is the easiest way to change times settings any way you want it…at least on a debian system.
It worked for me. :slight_smile:
Maybe we could invoke this command through a right click on the desktop date?


#9

Hum, and the configuration is maintained among reboots ? more exactly: everytime your network is set up, what about when you connect to a new network configuration? if so, yeah it could be easy to implement this temporal solution to make it working to who wants to reconfigure it


#10

Yes, it remains permanent. After multiple reboots and different networks with my laptop.
On a side note: I do not have any Windows installed to mess with my BIOS.

I also noticed that “tzconfig” now points to dpkg-reconfigure as well. I thought you had done that. :slight_smile:

[triantares ~]$ sudo tzconfig
[sudo] password for triantares:
WARNING: the tzconfig command is deprecated, please use:
dpkg-reconfigure tzdata<

Maybe an alias would set that, for the time being but I still think that command should be prompted bij a “right-click” on the desktop clock.
It would appear logic for the time settings to be there and it is a gui solution after all.


#11

it is now included a tool to reconfigure times (as you can have recently seen by the automatic updater tool), using the dpkg-reconfigure tzdata as a temporal but working solution :slight_smile:

right clicking to the gadget could be nice but harder to implement, I have added this in my TODO list