Beta 3.7.16 64-bit booting issues

Hi there, I have a brand new Kogan Atlas D400 notebook with 32gb storage and 4gb memory. Ir came with Windows 10 but I’ve decided to install Elive 64 beta..
It looks good but the only problem I have so far is that it takes yonks before it actually boots. Once it starts booting, it’s fast...
No idea on what is causing this, even to n a micro system like this...
I also have two other issues:
How to activate the touch screen?
How to rotate the screen as it boots in portrait mode.
Any help will be much appreciated!!

Hi @CRIB welcome to the forum.
Actually you've got 3 questions rolled into one header so let's take those in the right order.
Your slow booting could (probably is) a consequence of your BIOS settings.

  • I am presuming that you are referring to booting the live USB system and not a HD installed system here.

Go into your BIOS settings and turn off "secure boot" and maybe even set "legacy boot" as your first option and then see if the boot procedure is still that slow.

For more precise help, you'd have to be clearer where/when the slowness shows, i.e:

  • Finding/starting the boot media
  • starting up prior to the desktop (kernel issues)
  • The desktop itself being slow to render

As to the touchscreen:

  • That should be functional out of the box. So we'll be needing more specifics there.

Portrait mode can be set in the "screen settings" menu or, if you wish scripted with "xrandr" at boot if that doesn't work. Again more specifics needed. :smile_cat:

Hi @triantares,

Elive was actually installed on my notebook’s 32gb eMMC drive. This was done on top of a Windows 10 install which came with the notebook.

I’m attaching some screenshots of my bios.

Elive boots ok but there is a very long delay on power up before it starts around 90 seconds, then the normal Elive boot is fast.

It seems at this point that there isn't any boot issue with Elive but rather something is delaying Elive from starting it's boot process. My guess is that the system is somehow trying to boot the Windows 10 which was previously there but I thought the disk would be formatted during the Elive install.

I’m a newbie with Linux so I appreciate your patience with me!

I’ve issued the xrandr command via terminal and it worked for that session. I’ve no idea of what to do to implement that script as I’m not familiar with Linux..

As far as the touchscreen is concerned, it just does not work out of the box for me (it worked ok before in Windows).


Looking at your BIOS you might get going a tad faster if you put your HD(elive) as first in the boot order. That way your machine wont waste time looking for devices that aren't there.
AFAIK you'll always have a boot option by using F12 at boot, allowing to boot from USB if needed.

Other than that you might try turning off UEFI secure boot (in security settings) but that would probably require an upgrade/reinstall so that the bootloader wil get installed where it then is expected to be (mbr).

For the screen rotation I'd first give the "screen settings" a go and set portrait mode as your default.

I've got a script lying around that I used to change the orientation (on the fly) on my Helix2 pad so we can probably change that to your needs if wanted.

The same goes for the touchscreen i.e both touchscreen and mouse need to change orientation together with the screen we'll take those after solving the boot up problem, i propose

1 Like

I recall having something similar, which turned out to be a dying external USB disk.

Hi there!
“ Looking at your BIOS you might get going a tad faster if you put your HD(elive) as first in the boot order. That way your machine wont waste time looking for devices that aren't there.”
It can’t be done on my BIOS as it ignores the changes
I can boot from usb but I prefer to have Elive installed on my hd.

The UEFI setup shouldn't do that as the standard specifies it should be user changeable. But doesn't really matter.
We'll get to the cause of this anyway.
I've go some questions there:

  • Does the machine boot up faster from USB? I.e not have the same delay?

  • Can you give the output of " efibootmgr -v" and that of "inxi -Frnz" as well as that of "sudo fdisk /dev/sda" (using p to show the partitions)

  • I notice you've got an "Android" entry there, is that a booting install or some residue from past tries?

It looks like you've got a machine that's fairly new to the Linux ecosphere :shocked: so we'll have to put in some effort.