Boot Elive on a second disk, first disk is Archlinux with systemd-boot

Is it possible to boot elive on a second disk if I'm on systemd-boot on first linux and my esp is on the first disk ???

I'm quite puzzled since documentation is rather confusing on that aspect of systemd-boot.
I have installed elive on a second disk (on an mmc disk device). All installation went well but I cannot boot on it since on boot it seems the other disk is not there even if it is.

Can I add manually an entry in systemd to "chain load" the Elive on the other disk ???

I haven't figure a way to do so yet. Help appreciated!


[bt@batarch ~]$ sudo inxi -Faz
[sudo] Mot de passe de bt : 
  Kernel: 5.18.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: initrd=\amd-ucode.img initrd=\initramfs-linux-zen.img
    root=/dev/mapper/luksdev zswap.enabled=0 rw intel_pstate=no_hwp
    rootfstype=ext4 resume=UUID=834f9f58-2a2e-442c-a40e-a645c5d82353
  Console: pty pts/2 wm: kwin_wayland DM: SDDM Distro: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X513UA_M513UA
    v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X513UA v: 1.0 serial: <filter>
    UEFI: American Megatrends LLC. v: X513UA.305 date: 03/12/2021
  ID-1: BAT0 charge: 37.7 Wh (100.0%) condition: 37.7/42.1 Wh (89.7%)
    volts: 11.8 min: 11.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging cycles: 24
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x68 (104) stepping: 1
    microcode: 0x8608103
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1475 high: 1800 min/max: 1400/4370 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 1400
    3: 1400 4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400 10: 1800 11: 1400
    12: 1400 13: 1400 14: 1800 15: 1800 16: 1400 bogomips: 57488
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Lucienne vendor: ASUSTeK driver: amdgpu v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:164c
    class-ID: 0300
  Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-3:4 chip-ID: 0408:30d4 class-ID: 0e02 serial: <filter>
  Display: server: X.Org v: 22.1.2 with: Xwayland v: 22.1.2
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: eDP-1 mapped: XWAYLAND0 model: Najing CEC Panda 0x0046
    built: 2018 res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2
    size: 340x190mm (13.39x7.48") diag: 395mm (15.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 13.0.1 DRM 3.46 5.18.1-zen1-1-zen)
    v: 4.6 Mesa 22.1.0 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x,
    snd_pci_acp6x, snd_acp_pci, snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.1-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: N/A type: USB driver: btusb v: 0.8 bus-ID: 3-2:3
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 1013.56 GiB used: 316.78 GiB (31.3%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPNPZ-1T00-1002 size: 953.87 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21106000 temp: 38.9 C scheme: GPT
  SMART: yes health: PASSED on: 114d 6h cycles: 1,277
    read-units: 80,180,310 [41.0 TB] written-units: 28,822,400 [14.7 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB model: Multiple Card Reader
    size: 59.69 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 116.48 GiB size: 114.47 GiB (98.27%)
    used: 33.73 GiB (29.5%) fs: ext4 block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luksdev
  ID-2: /boot raw-size: 511 MiB size: 510 MiB (99.80%) used: 61 MiB (12.0%)
    fs: vfat block-size: 512 B dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 836.85 GiB size: 822.64 GiB (98.30%)
    used: 273.02 GiB (33.2%) fs: ext4 block-size: 4096 B dev: /dev/dm-1
    maj-min: 254:1 mapped: ainstnvme0n1p3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 17 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  ID-2: swap-2 type: zram size: 4 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 364 Uptime: 34m wakeups: 3 Memory: 15.1 GiB
  used: 2.86 GiB (18.9%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: pacman: 1058 lib: 255 flatpak: 0 Shell: Bash (sudo)
  v: 5.1.16 running-in: konsole inxi: 3.3.16
[bt@batarch ~]$ 

Seems like the best ways to boot multiple distros in UEFI mode is by running their own grub themselves, instead of using a single grub for all which can cause many issues booting the other systems (basically they don't knows how to boot them correctly / which boot parameters to use), so the best way to do that is by booting their own grub independently, for example by using a boot manager like refind, which is like a previous-boot system which allows you to pick which os-grub to boot next

the next updates on the elive installer will include installing this software (customized to look better and being more friendly) by default

I don't run grub. I use systemd-boot only on my main linux. Grub is very, very, slowwww to boot.
I will take a look at refind if it can solve the problem.


Would that be one of those SD card devices like in a phone or Raspberry Pi?

If so: Those devices do not have an MBR or anything similar to standard HD or SSDs to boot from.
It requires a completely different start-up method.

Yes its a 64G small SD card that was in an old phone as extra memory.
The installation went well with no error message. The SD card is formatted with 3 partitions.
First one the EFI, second one boot, third one a vg with the root and the swap.

Also I have added the following module to the initramfs to be able to read the SD card:

  • pinctrl_cherryview
  • vfat
  • mmc_block

But the problem is that the ESD is not on the same disk. UEFI wants everything on the same disk.
And the second disk is UEFI but with GRUB instead of systemd-boot.

Could I copy stuff from the second disk to the first so the other OS (elive) will be seen ?
What would be the correct way to setup the thing to be able to start ELIVE or my other linux ???

I'm not 100% sure how it should be done (my Eeepc died a long time ago) but if at all you'll need a kernel up and running to recognize the SD card, the BIOS/firmware doesn't do that.
I do know that you cannot boot an SD card with normal installation methods so, if at all it'll have to be from EFI on the HD.

The PinebookPro and also Raspberry Pi have their own special way of booting ..... I advise to do a search on that.

Looking at your 'inxi' output from Arch, I do notice that it defines your sd-card as '/dev/sda' where I dpubt that the installed Elive follows the same scheme.

Maybe you can 'chroot' into Elive from Arch and see if it'll run at all and also check out what naming scheme Elive uses. Chances are that it sees both disks very differently.

This looks quite interesting from Arch wiki: Unified Extensible Firmware Interface - ArchWiki

Oh! Thanks!

I'm trying this ASAP!

Will be back with results.


Well, no cigar!
This doesn't change anything. Either rfind nor systemd-boot won't see the second mmc disk on the sd card. Still reading about uefi & rEFInd to find a solution.


I'm not surprised ..... I think your laptop treats the (second mmc) as a USB device which either requires a running system (kernel) or ... that the BIOS or Firmware recognizes the hardware and is prepared to boot from it.

I'd go with the first option .... get Arch to start booting, recognize the SD card and hand over the boot process from there to that SD card, if possible. Else try using 'chroot".... where both cases will require an adapted kernel in Arch.

I'm sorry that my 'solutions' are only theoretical as I don't have the same hardware nor do I use systemd-boot often enough to practically roubleshoot your issue/question. :shocked:

I would instead try to install simply on the second disk very "normally" (maybe disconnecting the first hard disk for that) and everytime you boot the computer you press F12 or the equivalent select-boot bios key to select which disk you want to boot from, this should work pretty good IMHO :thinking:

On the other hand I don't suggest you to install Elive on a SD card, these devices are limited in RW and break soon when installing an OS on them (an OS requires loots of RW all the time), Instead I will suggest to use it as a Live system (just like when you record your USB's, but recording your SD) and enabling persistence on it :thinking:

The first hard disk is the laptop disk and I'm not in favor of disconnecting anything since the SD card doesn't seem to be seen by the bios at boot time. But I will eventually reinstall Elive on an external disk or USB key. But by the mean time I need to read a bit more on UEFI. I want to understand how it works.

Also on that laptop (Asus Vivobook), I haven't found any way to disable UEFI and activate legacy boot.


This looks to be an issue similar to the one that just came up here:

That HP stream 11 also has an internal flash disk as HD and a weird BIOS.
I wouldn't be surprised if i.e Raspbian would run just fine on those. :thinking:

Thanks, that was my post

If i boot to usb with stable 3x i can partition the drive correctly so that the version boots off the drive, however the screen is garbled. So the system is not usable.

It seems like a bug to me in the beta version.
I sm trying again to install the beta and not touch the partitions because they are working fine ...


note: a new version based on bullseye is going to be released soon...

It does indeed appear to be a bug, so might be a work around for now. :thinking:

Methinks it would be good if @PerfMonk (or anyone else with one of these netbooks) enabled reporting the logs when trying an install again. That way we can check if these glitches are 'elive-installer' induced or down to the partitioner itself not working correctly.

Even on the new 'Bullseye' based version, this kind of stuff needs checking.

All things considered, if @e-Solutions is prepared to spend some more time double checking, we could DM a link to the latest Bullseye version download for testing.
@e-Solutions just say the word. :smile:

Yes i am willing to help. While i must admit i am slightly more experienced than a noob with linux... I may not be the best candidate to help you with this.

Originally this netbook (hp stream 11) was to be a gift to my grandson. It ran windows 10 so poorly that i had to try other distros.

Q4os worked (usb) but would hang on install.
Elive 3.0x worked. But after installation the screen was not readable. The beta is now working fine, though i liked the old dock better...

Would be interested to learn more and also to craft a child mode for kid play.

I will try a reinstall. How do we activate or find where is the install log ? I will send it, no problem.:+1:t2:


You have different options for a dock it's merely a matter of installing:

  1. there's 'plank' which I prefer to 'cairo-dock'.
  2. And there's 'tint2' that is very usable.

All docks have their pros and cons, it's a matter of taste.
I wrote a Howto on customizing E16 and both docks as well, here:

You might want to explicate that and it could be interesting for us too.
BTW: I would advise to editing your previous message and remove the e-mail address .... it might be 'harvested' by spambots. :face_with_head_bandage:

By DM I meant via this forum.

The installer asks if you would like to send/participate and subsequently asks for an e-mail address.
You might've missed that. :smile:

Sorry! It been many days since I installed and it was late at night :grin: