BUG? Browser-on-RAM

I had some strange behaviour today:

I left my laptop open for a very long period, with Chromium (running-on-ram) without it being connected to a power source.
I noticed the machine was off and expected the battery to be empty or suspended/hibernating but .....
It turned out when restarting that my tmpfs on '/run/user/1001' (that's me) was 100% full and Chromium refused to start. :frowning_face:

This is one for @Thanatermesis to have a look at IMO ... or give me some pointers where to look. :magick:
Removing (and re-installing) Chromium brought my 'tmpfs' back to 1% but I lost all bookmarks, extensions and settings.

the good thing of most used browsers now is the "sync" feature, where your bookmarks and everything is saved on the cloud (on your account), so no matter if you go to a new computer, when you login, you have your bookmarks, your passwords, and even your extensions set up (you don't use this?)

Mmmh, that sounds like your conf was broken / corrupted, once per day I want to close my browser and want to forcedly refresh the confs, seems like it free some ram too, I use this command after having closed the browser:

systemctl --user stop psd ; sync ; systemctl --user start psd

since the conf is mounted on layer bla bla it could reach a broken / disconnected state (should not happen anyways), but the problem seems to be more like your computer forcedly shutdown when the battery was empty, this was the real problem here and in the same way it can broken other things (especially your filesystem), actually elive is made so that when it reaches 5% it alerts you and if reaches 2% it makes the computer hibernate (or suspend, I cannot recall), but I don't remember where / how this feature is implemented and maybe is only on E17

This feature would be needed to have on the actual versions of Elive too, I have noted to implement it FS#761 : Auto hibernate feature

Of course not ...... I'm very particular about privacy. :shocked:

anyway ..... no worry, I've got my own cloud. :magick:

No the whole 'profile' was gone.

Sorry if I wasn't clear enough on this:

The battery wasn't empty, the machine had gone into hibernation/suspend after unattended for that long a period.
There was nothing else wrong with the machine except that 'tmpfs' was at 100% ....... next (if it happens again) I'll know where to look and see what's running on '/run/user/1001'.

I haven't checked yet if 'suspend/hibernate' unmounts user-mounted file systems and/or if my encrypted setup is in the game too. :thinking:

I'm not worried about myself or my machines as, in general I can handle mishaps like these ..... but this would be quite fearsome to somebody who isn't as acquainted with our OS.
It needs checking IMO.

Well I wouldn't call that very (new)user friendly. :frowning_face:

I did a check on my laptop and:

  • 'Hibernate' and 'suspend' activated from the 'shutdown-menu' have no issues at all and don't affect 'tmpfs' in any way. :thinking:

So effectively, it does look like the laptop shutdown in an unexpected way.

  • Strange that there wasn't the usuall pop-up telling me that was what happened, though. :thinking:

After posting these findings I'll try and forcibly shut-down the machine and see what gives. :skull_and_crossbones:

Which I've done twice now with no noticeable results either ..... but then I do 'only' have the option to use the on/off switch, I don't want to open up the laptop to disconnect the built-in battery.

There is no 'forced shutdown' notification there, so that's slightly worrying for the experiment. :face_with_peeking_eye:

  • Which leaves the only other option ---- to let it run until it the battery runs out or it shuts down
    Only 2.5 Hrs of battery time left! :cry:

4 hours later:

the laptop has gracefully suspended at around 5% battery power,
Exactly as it should. :w00t:

Needless maybe to say:
Apparently my 'mishap' can be seen as some fluke of nature, not bug. :smiley14:

I think it happened to me too in the past (but not anymore!), for me is not a big issue since I use that "sync" feature and my profile is always restored / copied on any computer i configure it, for your case, your only solution is to manage your own backups of the profile directory :thinking: , but if this issue repeats when we are having a problem with the tool (never happened to me anymore, but i run manually a command to start/stop it so maybe I'm not aware of it)

hum, which tmpfs? the one mounted on /tmp ? (this is disable by default in elive because of this stability possible reason)

should not, they should be intact when restored IMHO

as a suggestion i assume you already know (i use these things a lot), doing these things in VirtualBox is much better, in the sense you don't need to reboot your machine, you can break it, and you can also restore "snapshot states" when doing very specific tests

i just tried it in a recent install and it works (make sure elive-health is run on desktop start, this one tells it)
btw if you press that button for 5-10 seconds you trigger the force-shutdown :thinking:
note: don't be confident on low-battery, unless you use e16 and laptop-mode daemon is disabled (otherwise it can trigger a correctly shutdown when it detects the battery is low)

well, if happens again we can check again...
in any case, I think it could have due to a "first time setup" :thinking: