Cannot install a printer driver from system-config-printer

Hi everyone,
Today I tried to introduce my printer (HP Photosmart c309a) to my elive system, but it did not work. The process stops as soon as I select the printer from the database and click 'Forward'. Nothing happens any more after that. the window with the printer/driver selection just stays open forever.
The printer is attached to my router with a USB cable, and my laptop is wirelessly connected to the router.
Any ideas what stops the system from going on? No error messages or the like unfortunately.

Seeing it's a network printer: You did try to discover it as a network printer, I hope?
It shouldn't actually require any configuration.
Your router should have the drivers.

Yes, and I just tried a direct USB cable connection laptop/printer. Does not work either, although the printer obviously is recognzed. It looks for drivers and stops without finishing the process.

i know that the printer configurator of the 3.0 version is not -so- stable, it had a few minor things that didn't worked

if im not wrong, there's 2 types of printer configurators included because of that

or you can also try to use the next beta versions which has a much newer printer configurator tools included

So what is the other printer configurator, then?

And might that mean no printing for me on elive 3.0.6?

I don't remember :), try cups-TAB to see the autocompletion commands, maybe with sudo too

cups (printer system) has also a web configurator, which should be more stable, try to configure it from web:

http://localhost:631 :wink:

And might that mean no printing for me on elive 3.0.6?

you can, unless you need a specific newer driver, what i meant is that the conifgurator (tool) included had a few issues, but thats a problem of the tool itself (only), not with the printing system

OK, thank you, I'll try this and tell you what happened.

I got the printer added throupgh the CUPS web frontend finally as you recommended as an alternative. Strange, though, because system-config-printer to me only seems to be another frontend which works without any problems in all other Linux distros I use. And I do not have an exotic printer - it's a HP Photosmart C309a - either. There must be a problem in the collusion of a part of Elive and system-config-printer, then.
But at least now I can print and there is a good viable workaround for all those who cannot add a printer on Elive so far.
Thank you for your help

1 Like

that's because of the version, which seems like to had a few issues in the version used for elive-3.0, which is sad but we cannot do much.

By other side, newer versions of elive should have this improved :slight_smile:

Good to know that you can print without problems now :applause: :boogie: