Cannot share files between two Elive PCs on same WiFi network

Anybody have an idea why? They see each other but I cannot get to either's Public folder from either PC.

It depends on how you connect.
Personally I prefer "ssh", "scp" and "sftp" for file sharing. (albeit I have seen some issues in bi-directionality there). Samba I haven't used in years so I don't dare explain that. :shocked:

It's easy enough from your filemanager (thunar) using "sftp" as protocol:

  1. In the menu "go -> open location" enter the wanted computer address (and user name optionally)

  1. You will be asked a password (unless the keys are in order for password-less login)

3.The machine will appear as a mountpoint in the side pane.

After which you can mount/unmount that like any other medium and access it locally.

No dice.

I shuold mention that one of the machines has an encrypted drive. Both HP.
HP Pavilion 11-n010dx x360
HP Pavilion DV6-3225

How do you feel about NFS?

If the system is decrypted and running, it shouldn't make a difference.

As a first go into a terminal and use "ssh" from there to connect to the target should ask if you want to trust the machine you're connecting to.
If it doesn't connect it'll tell you why. In that case check in the other (targeted) machine if that one can connect....sometimes it does. :innocent:

If both refuse a ssh connection then it's usually down to a misconfiguration on your machines.

Outdated and error prone.

Same issue with ssh; not connecting. I'm sure it's something I'm (not) doing. Thanks for the input about NFS also.

Yes but on the CML it will say why it wont connect.

if it's:
ssh permission denied (publickey)
then (on both machines) alter the file "/etc/ssh/sshd_config" to have a line: PasswordAuthentication yes
save the file and restart the sshd with:
sudo systemctl restart sshd
Now when using ssh it should connect and demand a password.

how do I open it? I tried SciTe Text Editor but it will not save.
Never mind figured it out.
but still no dice. However in the status bars of both it says the folder (Public) is mountable.

I know what's going on; I chose the option that lets you select elive pcs on the network by name during Elive's setup. Is there any way to opt out of this and will doing so weaken security?

Since I made the change you suggested I am able to login using ssh, which then becomes sftp. Just need to figure out how to configure shares and sharing.

Now if I can just deal with Windoze and sMac boxes on the networks I'm regularly on...

In the case of mac boxes that's no issue they run the same zsh shell (they only never tell the user ssh is available and don't offer it in their flemanager ) but for Win boxes you'll need to install something like "putty" (which generally is one-way).

You want Windows-like shares so your best option is to install and use "samba" (i.e the smb protocol) and keep shared ssh mountpoints for the Mac and Linux boxes.

On a side note: "filezilla" is my personal favorite GUI on Macs and Win machines for sftp file sharing. :wink:

That's not a biggy but might be hampering your connections depending on the nameserver.
Just try ssh or sftp with the IP. The easiest way to quickly ascertain an IP address is to do a "ping" to the name, which will show the IP address. If it doesn't then you've got a nameserver issue.

  • addendum:

ssh (and sftp) works best with shared keys, thus allowing a simple password-less connection between known/trusted machines.
It's actually the safest way to work.

Are we talking GPG or something else?

No, something else! ... gpg has nothing to do with ssh.
gpg is mainly for encryption/decryption of i.e e-mail messages.
ssh has it's own private and public keys (where you do not want to share your private key).

It's a bit much to start a tutorial on ssh and gpg usage here so:
I suggest you look up how that works .... there's plenty on the net about "ssh" as well as "gpg"

This about the Go-To page:

I'm good; just wanted to make sure you didn't mean something separate from ssh.