Compile megasync [SOLVED]

I'm trying to compile megasync following instructions on the github site :

The configuration ran OK, the make too. But the make install does abort with the following message :
Error in file "/usr/share/applications/run-file-helper.desktop": "edj/edje" is an invalid MIME type ("edj" is an unregistered media type)

Anybody can help on this ? I can't find anything on that since it seems that Enlightenment is not used by many.


It just means that the installer is unable to add Megasync to E's menu and/or might show up in Cairo-dock tho.

  • The installment should finish despite of that error. If not, mention it to the creator as that would be a stupid restriction.

Meaning that you might need to run MEGAsync from commandline or search with Alt + F2.
Alternatively you can create your own icon on the dock by creating a .desktop in /usr/share/applications/ as I've explained as part of the tutorial here:

Thanks a lot for the info and tutorial. In fact the installation really stopped because of this error the megasync binary was not installed because of this. I will contact megasync to ask correction of this error.

Also I found out that megasync has the package for debian (8 to 11 + testing) on their site for download. I might as well use it.

I will mark this post as solved.