Configure X from console


#1

Hi there. I tried a couple of times to install elive among these 11 or so years away. Got troubles with X in different machines (live version). Yesterday I got problems with multiple screens, and got the black screen :man_facepalming:t3:. Luckily i installed e16 (love the waves effect and miss it!!!). so i managed myself to kill X in tty2 and somehow got to login screen with WM selector. My suggestion is to add a script to reconfigure X from console while offline (dpkg-reconfigure Xorg was the command in ubuntu… pfff this gets me to the my good old times :japanese_ogre:). i can’t remember bash scripting but something like "| if grep “Xserver Fatal Error” = true show “Use the following command to configure blablabla”. Searched in the forums back in those years and couldn’t find an answer in the old forum (should I asked?). Thana if you read this, freenode misses you :wink::wink:


#2

grep (EE) /var/log/Xorg.0.log

grep -> program to find a pattern in a file
(EE) - > what should grep search for? Because () are special characters, they should be escaped by
/var/log/Xorg.0.log -> the File that should be looked in.

If the ERROR (EE) don’t get any result, try WARNING (WW), too.

And then we’ve got the ~/.xsession-errors … Try to read it from down to up. But I don’t know what to search for here.

Back in the old days (Debian 2.2 “Potato” for me), often ‘cat /var/log/Xorg.0.log | grep (EE)’ is used. But this is known as ‘useless use of cat’. Because grep is reading the content from STDIN as well as from the file direct.


#3

for willys (the OP)

Have you tried editing the xorg.conf file in /etc? There is an expression that Real men edit their xorg.conf by hand (instead of letting a utility fix it) . Open a terminal and view the .xsession errors there, while another terminal is where you make the necessary repairs using your preferred editor.

I did a LOT of this when I had an nvidia-equipped desktop that had two screens. This was way before enlightenment made it easier.


#4

Hahha :smiley:

Mmmh, the X11 startup has a “multiple different attempts” feature (trying with vesa, trying with no-ecore-vsync, etc…) options, which are not much tested but they are meant to work, in the end, it suggest to start a shell in failed cases

In other words, with this “auto” configurator should not be needed a configurator and it should manage it better, which they are very delicated (not always compatible). By other side it has not been tested much (not easy to simulate a “failed with intel, try with vesa” state but it should generate the configurations correctly by itself, see also this screenshot: