E16 changing the Fonts Sizes

This little howto explains how to change your font sizes on E16, to satisfy better your needs and screen types

Some points to consider:

  • It is strongly suggested to configure them at the smallest size that your eyes can comfortably read

Applications Font

First, run the Customize Look and Feel Application:

image

After, configure the Default Font and select the desired size:

Apply your changes

Note: If you don't see the changes to take effect, you must logout from the desktop to have it correctly reloaded


E16 Font settings

For that, you would need to hack your own E16 theme :madness: but don't worry, its very easy! :excited:

First: make a copy to your desired theme to modify to your local home themes, with a rebranded name! for example:

cp -a /usr/share/e16/themes/Elive_Dark ~/.e16/themes/mytheme1

On this example you will have a copy of the entire directory of the theme to your E16 home settings named mytheme1

  • note: spaces are not allowed for these directory names, you must use the _ character

Next, edit the Fonts configuration file:

scite ~/.e16/themes/mytheme1/fonts.pango.cfg

Basically you just need to change the number, which is the font-size value, for example for the entries like default, border, menu...

Save the file and reload your E16 desktop with the combo "Ctrl + Alt + End" (or just logout)

Enjoy your new fonts settings :excited:

  • note: there's multiple font configuration files, but pango is the used by default that gives smooth looking fonts

Other font settings:

You may not need to configure these, but just in case:

Terminal:

To configure your terminology terminal, just right click on it and search these settings

Note: Since Terminology is an elementary application, changing the setting on elementary it will also affect terminology!

Elementary:

Run elementary_config from a terminal and change the Scale value

Not that I am aware of.
The settings are only changeable in font.cfg or those delivered by the theme when in Settings -> theme : Use theme font configuration is activated
We could consider a small script handling that.....for those that have trouble reading the smaller fonts. :rofl:

I would better suggest to patch / improve E16 to include a slider wigdet to set the font size for the theme :thinking:

2 Likes

Ok, included a small howto of how to modify them on the E16 desktop too :slight_smile:

@martinwprior I think that this howto includes everything that you may need! :smiley: but add a comment here if you see anything missing :happy_dance:

I would add there the setting for using the theme font configuration ..... otherwise nothing changes. :stuck_out_tongue:

@triantares: If im not wrong, these checkboxes options must be disabled, if you enable the "use theme font settings" checkbox it will use the fonts.theme.cfg file, which is the old traditional way, by default it uses (when this checkbox is disabled) the fonts.pango.cfg file, which looks much smoother and better :slight_smile:

Yeah, but that would be the fonts.pango.cfg in /usr/share/e16 not the one in theme. :nod:

Using theme fonts:
Elive_Screenshot_2019-10-08_16%3A29%3A50__316x172

Not using theme fonts:
Elive_Screenshot_2019-10-08_16%3A30%3A43__343x233

hum, this looks confusing :thinking:

try to "bkp save" your dir (snapshot copy) and then copy the fonts.pango.cfg file of Elive_Dark into your theme, see if the fonts looks better when you have both checkboxes disabled, maybe the original fonts.pango.cfg you were using on the original theme is not good

With Elive_Dark fonts.pango.cfg file in use:
Elive_Screenshot_2019-10-08_16%3A49%3A03__354x220
Find the diffs. :rofl:

The fonts.pango.cfg in /usr/share/e16/config/ is identical to that in Elive_Dark and that in GTK-light.
Only diff is that I brought along FreeSans.tt (and a pixel or 2 larger) in the theme because the DejaVuSans wasn't allways as it should.

Mind you these screenshots are on a downsized resolution. In the original 2560x1440 resolution 13" screen even e16 transparency looks good. :smile_cat:

And I've got GTK-light in /usr/share/e16/themes not in ~/.e16/themes/