Elive 3.0 Stable Repsitory unreachable

Hello everybody,

im not sure if this is an error on my site, but i cant find the error.

Im running Elive 3.0 Stable on my old Laptop and i have tried to Download packages from the http://repo.wheezy.debian.elivecd.org Repository, but it times out after a while. I also cant view it in my browser.

Im in germany if thats important.

Should it be this way or did the URL change or its offline on purpose?

Thanks in advance!

Yes, Wheezy isn't maintained anymore so it has moved to archives .... and some elive mirrors went down and out with no back-ups available alas.
Some changes are called for.

What you need to do is have the debian repositories in /etc/apt/sources.d/debian.list point to:

deb http://archive.debian.org/debian wheezy main
deb http://archive.debian.org/debian-security wheezy/updates main 

As for the elivecd link ... it should point to (note that there isn't a 'debian' in there any more):

http://repo.wheezy.elive.elivecd.org/ is the correct place now in /etc/apt/sources.d/aaa-elive.list


Thanks for the help! I commented out all lines in debian.list and added the 2 you provided. The one in aaa-elive.list looks like this:

deb http://repo.wheezy.elive.elivecd.org/ wheezy main elive efl games ports fixes drivers multimedia non-free

Does the line still work? apt-get update still reports it cant connect to:


Could it be the repo in ggg-marillat.list?

I think so but I'm not 100% it's only that.
You can try by commenting out the repo there (it's not reacting ayway) and leaving it empty.

1 Like

Yeah commenting out marillat worked. Now apt-get update finishes. It ignores a lot of stuff tho.

Yes, on mine too.
Specifically the 'debian-security' is not correct anymore by the look of things.

Just got an old Acer Aspire-3610 that has 3.0.6 on it to boot up and it conks out on debian-security with a 404

1 Like

Just on a side note (you yourself probably know but there may be others who don't):
The 'archives' wont yield anything for updates unless the last previous update was from before Wheezy was archived.

If there are any updates available they'll be coming from 'elivecd' but that's also highly improbable.

The reason to have those repos available, is for the ability to install other software on Stable 3.0.6 in hindsight, that's all.

1 Like

Yeah i dont expect to get updates for a System that old. All i need is to still be able to install deps for compiling software. Yesterday tho after logging in, Elive asked me to install 3 Updates for Elive. Are these debian package Updates or a something else?