Elive 3.8.14 Beta install on Sony Viao laptop

Received the email promoting this release, donated and downloaded the iso, burned to usb.
Installed Elive 3.8.14 Beta to SSD using the gparted option with encryption (afaikr) rebooted after install and cannot decrypt the SSD, figuring I might have slipped up somewhere ran the installer again taking the automatic full disk option and set (carefully) the encryption password, same result no access to the SSD, does not recognise the decrypt password.
Feel like I've been conned with this donate before you try crap for a useless installer, luckily MX Linux has me back up running with encryption, apps, settings, logins in about 15mins.

Maybe you missed the part stating that this is Beta software and the donation is only meant to help out further development ........ It is most definitely NOT a purchase.
Thank you very much for donating and do keep/save the download link as it will be usable on future releases too.

Personally I'm on holiday and haven't tried out 3.8.14 yet but 3.8.13 encrypted just fine...... so you may have stumbled on a very serious bug.
Did you enable feedback reporting during install with a mail address? That way the bug may be found. :thinking:

On a side note:
I quite often stumbled into password traps due to:

  • Notebooks booting with numpad enabled, thus changing keyboard layout.
  • Setting password with a different language setting for the keyboard on subsequent boot up.
  • Going from qwerty layout to dvorak w.o noticing.

All have in common that there's a not so obvious keyboard layout problem (let's not forget capslock, either), so it might be an idea (just to test) to use a password that is layout and numpad agnostic.

14 characters min to say Yes

2 Likes

I'll try all of the above but the Sony is my daily driver so it's gonna have to wait till I free up a drive. Many thanks