Elive can’t tether to my iPhone’s internet over USB!

Hello,
It was supposed to have internet connection when I turn on “Personal Hotspot” on my iPhone and connect it via usb to itself.
I tried it on stable version, used different options but it couldn’t detect and I decided that it is due to the old kernel.
Then I tried with beta version with newest kernel, same problem.
Normally, Ubuntu and Ubuntu based systems can detect it automatically at the moment when I plug the iPhone in.
My PC has no WiFi card, so I want to connect through USB.
I hope that there is a simple solution.

I would love to be able to answer your question but frankly haven't used a USB dongle in decades... and before that it was PCMIA or a serial connection.
Maybe @Thanatermesis has some pointers.
I changed the title a bit to reflect the connection.

Isn't it just (always) easier to stick in a small USB-wifi card?

  • I don't use Networkmanager either but doesn't that come up with a tethering option?
    I know "connman" does allow tethering with "connmanctl", from the manpage:

Tethering a wireless connection (ssid "SSID", passphrase "password"):

         $ connmanctl tether wifi on SSID password

and in all cases make sure you have "ipheth-utils" installed, it isn't installed by default on Elive contrary to Ubuntu.

Hello!

I'm not sure if this is Elive relative, in the sens that I regularly use usb web connection with a phone (surely not apple one, but...), e.g. on the eeepc 1001px with Elive 3.8.13 & E24: as soon as I set "by usb" on the phone's web share settings, Elive connects thru it...

Salutations!

I do want to try this, thank you

Ok, I will try with another phone, Android system. Thank you!

That can be done simply by typing in a terminal:
api ipheth-utils

It will require an internet connection, so I hope that that isn't a catch22 for you. :face_with_thermometer:
If it is .... download the .deb file (it doesn't have extra dependencies) from here:
https://packages.debian.org/buster/amd64/ipheth-utils/download
Copy it to USB flashdisk and install the package by double clicking on it within the desired machine.

I had installed ipheth-utils, but system couldn’t recognize phone’s internet, then I came across askubuntu forum 12.04 - How do I set up the iPhone USB Ethernet Driver? - Ask Ubuntu

When I tried the last answer in the forum, ie had installed usbmuxd, the connection was established...

Surely it works without any problems with Android system!

1 Like

That would be this answer, just for future reference. :smile_cat: