Elive Retro

Do you want a critical review or not. :frowning_face:

If you are going to keep telling me it's fine ..... where, obviously it's not, then I'll just stop bug hunting and assessing UX and let you do what you like.

It's simply good UX to tell a user that such a thing is possible at a later stage (and thus there's need of a GUI that creates a swapfile)

So set it to Firefox ..... what's your problem there?

Yeah, that has to be set in 'cairo-dock' itself. It's now set to 'synaptic' icon.

what is not good? :thinking: we needed the variant configuration and now we don't want it? :thinking::thinking:, the user is free to select any variant or just no one

remember, first you configure the language and then you configure the keyboard, they are two totally different things just like "we don't speak altgr dialect", and so you can configure it to have chinese language with german keyboard, so again, there's three steps:

  • configure the language (and only the language)
  • configure the keyboard
    • if you configure the keyboard, it asks you if you want to set it to a special variant

didn't had the time to try it, i know you mentioned it doesn't require admin privileges but remember that the configurator tool in elive is not about changing (only) the keyboard for the user but for the system itself, the user can select any keyboard at any time even without admin privileges like using a desktop gadget but these tools are meant to configure the system and not the user desktop

done :slight_smile:

A post was merged into an existing topic: UX aspects of RetroWave tools

8 posts were split to a new topic: UX aspects of RetroWave tools

Resuming the test outcomes as the discussion about side aspects got too long and sort of eclipsed the thread origin :

  1. There are some UX issues with the installer as:
  • add text pointing to a swap-file option if needed
  • 'language and keyboard' configurator needs some changes (some already seen to)
  1. Elive-center and related .desktop files need some icon changes. (some already seen to)

  2. The 'default' browser choice isn't ideal.

No real biggies there, yet ...
So all in all not bad for a release candidate. :smiley_cat:


I upgraded 3 systems yesterday. The first was on an SSD over USB with encrypted partitions which I messed up myself because I didn't remember which was which there.
The second was on a USB flash disk but that didn't go well as Grub' didn't get installed on it ... and thus wouldn't boot after that.

The 3rd was an older (3.8.20 IIRC) Elive that ran from SSD but was originally installed with 'legacy BIOS' but I booted RetroWave with EFI.

That last one was caught excellently by the installer. Warning and offering solutions...Very Good!
So that Helix2 Thinkpad now runs RetroWave. :1up:

:applause: I think other distro's installer doesn't offer these features so they just don't know / let users do things themselves, the elive installer detects, request, suggests, guides, etc

IMPORTANT NOTE: yesterday I found by very accidentally that my last iso build was broken (I just verified this in the previously released torrent and seems like it was fine there), the issue was very important because it didn't run a very needed step of the Live mode where many hardware is detected and configured, making the system (and its installation) more tuned-to-your-hardware. I found it accidentally because booting an updated ISO I found that the "composite" checkbox was unchecked by default, why? I started to research... that was not normal, it should be preselected if detects that there's graphic-card composite capabilities, it sounded like it was an important thing but in the end it was a simple missing "fi" in that important step of the live mode, that was because the too-many changes the language-configurator received recently, and this would have ended by having a final release which received modifications not tested (because the tested one was this RC2) and so releasing a totally broken iso (not even the nvidia drivers, which received so many fixes and improvements recently, would have been installed due to this, the persistence system will have been broken too, and many other things), I wrote that because we need to make very caution with the things we change, this happens always in software development and this is why always in any software, where this is the procedure:

  • development: normal progress, receiving many new features, changes, and fixes
  • pre-release: no more features, no more changes, only fixes for the found bugs
  • release-candidate: final betatest to confirm everything is working, no more modifications at all and not even bugfixes (if so, another release-candidate should be made)

Fortunately I have seen it, but as I said, it was very lucky because I found it by just having see that the composite checkbox on desktop start was not checked by default in a vbox boot

I will probably need to do a RC3 before to publish it then, because RC2 received already too many changes

At this very moment doing an upgrade on the old Thinkpad X61 Tablet.

It is struggling sometimes though.

That is one lousy excuse. :face_with_head_bandage:
Something like "The dog ate my homework." ..... :wink:

Anyway, the issues with the language configurator have been mentioned going back to 2019 but it was never considered pressing as there were many other things to do, as well.

A lot can be changed after the installation with upgrades but not that first configurator.

That's good, most distros go to RC3 and there were hardly any Betas of RetroWave.
Maybe set it up as a zsync? That way the seeds wont need so much time to update. :thinking:

Yes this is a very limited / old machine, I hope you are using the 32bit version (which is a bit lighter in both arch and components selected)

Unfortunately I don't have a slow machine here to do tests to see what things can be optimized (on the other hand, many good optimizations has been made in the last months)

it is not an excuse of anything, im just explaining why making changes in the last moment is dangerous with an example that already happened

what im saying is that these "minor UX changes" almost messed the entire release by making it broken without notice

yes but we have no time, the release must be done in less than 7 days and there still needed:

  • an amazingly attracting webpage to attract all those retrowave people and see that there's an OS for their computers looking synthwave, just like many linux users to enjoy it
  • a big work on the website code to allow "retro" download-button types just like "stable" and "beta", and this is a big change that can lead to many bugs, im not convined that I have the time to implement this and if so, I will need to only provide a torrent link, which is not good because it will stop / difficult many people from downloading it
  • other things that I need to include not yet finished

Maybe set it up as a zsync? That way the seeds wont need so much time to update.

in the real world nobody uses zsync and is only useful to save some bandwidth, the requirements are exactly the same as not using zsync

I was thinking about us seeders actually.

Nope, the 64bit.

All went very well. :smile:

I think it's better to turn off the icons in the e16 menu. They look inconsistent.

Once installed it runs fine ..... even relatively snappy for such an old machine.

In the above pic, 'elive-center' resizes very much better than original size settings on that small screen. Thanks to @Thanatermesis :smiley14:

Hi guy's, how are you doing?

I installed RC2 this weekend in my two laptops.

64 bit works fine, no issues found, but 32 bit RC2 still crash e16 desktop with user logout when Thunar is opened at least at 80-90% times (sometimes it's OK and no bug) :frowning:

It's critical to solve it before final release to avoid users blaming.

@Thanatermesis I could give you a remote control of this laptop as I gave in 2018 for 3.0.3 issues, I think is the best and fast way to hunt this bug.

If not, please ask me what to do to make test and send you logs.

Any ideas?

If not I think is a nice job the retro version, I love them a lot!

What GPU brand are you using with this laptop?

Hi David,

It's a 2012 HP mini laptop with an Intel Atom, GPU is inside the CPU I think, It has 2 GB RAM and runs all elive releases without issues from 3.0 stable to 3.8.32, that thunar bug started in January 2023, even with a new and clean install (not upgrade mode)


yes, that Thunar bug has been around longer than Jan 2023. I have had that same fault with Thunar file manager, and it might be ok if you reinstall.

Ever since I had my new AMD graphics card, I have not had this issue. But it looks like the fault could happen again in the future.

Hello David,
I reinstalled sometimes 3.8.30 even doing a clean installation with no success. This weekend I did a clean installation of 3.8.32 RC2 and in the first start of the system the issue was there.
I mean always the laptop with 32 bit release, the another one, and old Acer Aspire 5310 from 2007 that runs 64 bit release never had this thunar issue.
I "solved" this installing pcmanfm because without a file manager the laptop is not very practical but I lost a lot of elive features included in thunar like resize big PDF files with a right click, and also we can't publicate a distro with this kind of bug...
It arrived with some update because 3.8.30 32 bit worked fine in this laptop between its launch in may 22 until Jan 23 that bug appears.....

I've noticed that only @Thanatermesis and me are seeding the torrent. It would be nice if others did the same.

Hi Harm, you're right... I'll started tonight my laptop to seed it also !

1 Like

Opened qbittorrent back up

1 Like

I've tried multiple times on a Virtual machine but I cannot reproduce what you say.

Can you be more descriptive about what is actually happening... i.e only 'crash' is fairly vague.

  1. This is an installed system I assume. if it's live-mode: Be aware that it doesn't run 'lightdm' to login again .... it goes straight back into the desktop except after a few consecutive tries Elive will assume something is wrong/buggy and offer opening a root console as option.

  2. This crash is this the X11 system that goes totally dark? or does it freeze the splash screen? or does it turn off the machine?

  • In the X11 case, is it lightdm (the login screen) that doesn't come up? Do you get a console/prompt?
  • In the latter (turn off) case, does the machine power off totally or does it shutdown running (and showing) the scripts it should.
1 Like

Can you give me more details about this bug? for example:

  • does "dmesg" shows you any error message
  • if you run the issue on a terminal, can you see any error message
  • what are the steps i need to do to reproduce it?

if i'm unable to reproduce the issue here (or to know what is happening) yes I would need that, but let's try the first options first since is faster :slight_smile:

1 Like