Elive Retrowave install issues and thoughts- real hardware

Hi to all.
Sry for my not influent English - isnt my native.
Tried test it on real hardware - Ryzen 1600x/8 GB Ram / Nvidia 750 ti / SSD:
I have dual monitor setup - VGA Real monitor and Camlink 4k USB as a video grabber - conected by HDMI of course. I have another grabber - just default china "Macrosilicon UVC" device as a backup

Few bugs what i found - it cannot install this system becouse of that:

  1. Chosed Nvidia GPU Propertiary drivers - works ok
  2. In desktop mode, in installer i see message that my system is very low on memory and it isnt good idea to run it on it..... ????
  3. After copying files and setup username a message always show - you have VGA - DSUB monitor and - thats all i can read becouse installer just turn off any video.... No VGA display and HDMI display was off too. 5 times the same. In single display mode - graber only - desktop just dont start... flashing and nothing happens. In that single mod i disabled - switch off dsub cale from monitor and no picture at starting desktop.

Same "Live envirovement" is working fine on both grabber and vga dsub - nvidia properties loking good, mirroring screen work. But cant install it.
4. Fonts DPI on 1920x1080 on 23" monitor is too small i bareley see anything in menus.. how change that ?
5. On main theme is nearly impossible to see something on left side of dock, too much transparency, the same in conky - thats the conky on right side of screen ?
6. Transparent on conky - unable to read data from that, too low fonts, transapency is too high
7. Conky - maybe change that % to MB / GB ?? Im not mathematics to think how is 30% from 16384 MB RAM :stuck_out_tongue:
8. Is the Retrowave version is the same as BETA build - what you promote too ?
Fully 64bit is paywalled , 32 is free like always but retrowave is fully free - it is limited somehow ?

I think thats all ive found for now. Hope some problems can be fixed somehow.

Now ill try install it for 6 time.. i disable VGA ouput totally and try only HDMI on real monitor..
My both grabbers working just fine on another distros, i test 4 -5 for week plus another jobs on my channel and i know - its not a camlink or macrosilicon fault.

Tested on Legacy BIOS and EFI mode - the same Hardware is ok.


I've got it installed with grabber and real monitor attached. Just choosed safe graphics not the Nvidia Closed Source.
Windows with information was show - something about beter to use DVI - i know that is better but i cant :stuck_out_tongue: - then another windows appears and says dont close me then it has been installed correctly...


ill go to test it few hours and then make movie on my channel like always i do :slight_smile:

perfect! :applause:

Mmmh, I don't remember this message, can you tell me more exactly it said? so I can search this message in the code and fix it if is wrong

this one?
Your monitor is connected using a VGA cable instead of DVI. Check the connectors of your monitor to see if you can use a DVI cable instead because it improves the graphics. The operating system also detects your monitor more reliably and eye strain is reduced. This is just a suggestion and only optional for your computer.

mmh, I don't see anything strange happening after that :thinking: except the installation of nvidia drivers step

mmh you say that the desktop is not starting but where exactly you mean? after this step the desktop was broken? or rebooting after to install?

but if im not wrong, you were able to finish the full installation process, right? its only that the installed system is not booting? :thinking: what exactly it does?

this sounds like the nvidia fonts issue, you can use elive-scale to change that , tell me if works

yes is conky, mmh maybe the new background has some "too clear" elements and conky should have a small 50% transparency background for that :thinking:

the left-side dock is a pager, its not transparent but a representation of the multiple desktops (you have a small intro video explanation of it when you start the live mode and check the "1-minute instructions" checkbox

for the fonts, i think they dynamically change when you use elive-scale, which is your actual issue with small fonts (probably you have the nvidia dpi bug), if you make a photo with your phone and upload it to imgur can help, to see the sizes "in real" :slight_smile: , also it will help to see how the fonts looks like for that dpi issue (include a finger or something to compare)

  1. Conky - maybe change that % to MB / GB ?? Im not mathematics to think how is 30% from 16384 MB RAM

a photo will help again :slight_smile: in my virtualbox test it does show correctly GB and not MB :thinking: (it only shows MB when the usage is less than 1 GB, then it switches to GB)

Is a stable version based on the long work made on the beta's :slight_smile: , but is a "special" release since the look-n-feel are different and specific

not limited at all :slight_smile: full-blown featured forever, the reason of give it totally cost-free is to try to grow the user-base of elive which actually doesn't has much users (this is of course because not many public news happened on elive in the last time)

but im not sure to fully understand, if you use the VGA cable it doesn't works after to install? :thinking: with open-source nvidia drivers too?

You mean a terminal showing this message? not a bug, the terminal is "doing things" for the installation

let's see it! :smiley:

  1. I cant reproduce error about too small or small memory, tried few times..

2.Thats always happen to me after that window - when im using propertiary drivers Nvidia

Just black screen and nothing. hdd is doing something - led is blibking but no picture on any monitor
when using safe mode issue never happend

  1. when using safe mode installer complete his job without any issue. After first reboot i installed drivers by apt in console - no any erros after that. working stable

  2. About DPI youre right, i changed to 96 and its ok

6.Conky DPI - im new - info about only 1 link in post :frowning:

  1. Thanks for info about releases :slight_smile:

8.About that VGA-DSUB - yeah its telling that beter use DVI-D - but i cant - only VGA and HDMI for grabber - but this isnt issue. After install all is working well - with propertiary nvidia - like i say i installed it manualy

  1. Movie, posted and i tell in that this is very good distribution, of course talking about my issues but not in full criticism - just that they exist on my installation and how resolve it :slight_smile: Nothing bad about Retrowave becouse this good release :slight_smile: Thats in very big short. I dont speak well eng so only recording in Polish :stuck_out_tongue:
    Link to video if you want

Sry for late replay but i recorded movie then get to test that, what you say :smiley:

hope that pictures uploaded correctly... i hope lol

Conky dpi issue - 23" - 1080 - FullHD - clear .iso

Sry but cant more pic inside 1 post

And there is effect when he tolds about dvi / dsub or cuda install - when i non click whatever just black screen

disk is working but nothing is displayed anywhere - after 30 minutes wait - nothing change

short movie - screen goes blank - nvidia propertiary - i dint touch nothing.

Somehow this clashes with the '8Gb RAM' mentioned earlier and also with the 'low on RAM message'.
Could you give us the output of 'free -h'
Or better yet the output of 'inxi -z'

That can also be found inside the 'elive-center' on the dock and is called 'Desktop Size'.

I have had similar quirks that enlarge the pager (or the previews) to almost the same size as the desktop, after mucking around with screens. Maybe this is something of the same.

You need to 'save the configuration' that after it's applied if you want to have it after a next boot.
Using 'elive-center' and 'Screen Settings' will ask when you finish.

I apologize for the misunderstanding, hardware has 8192 not 16384 installed and its show correctly. What i say i cant reproduce message about low mem situation - tried in uefi and legacy bios. But issue with jus blank screen - turned off monitor can reproduce everytime - just use nvidia and propertiary drivers at running first time installation iso 64bit - movie show that

That's good advice, I think. Thanks for that.

You could try to bring up a TTY with 'Ctrl. Alt and F1' keys. If you get a prompt you might catch some error messages....and even try to start X from there with 'startx -- :2'

So the issue is more like on the step where the Nvidia drivers are being installed on the installed system? :thinking: maybe the tool try's to remove the nvidia module first or something similar, I need to check that....

remember that you have a much better way to install the drivers (from apt packages too) which is using that tool, to call it you can run:

~ ❯❯❯ sudo nvidia-privative-drivers-install --help

hum that's curious... :thinking: because due to the amount of people suffering this dpi issue i recently changed the tool to force the screen to use 96 dpi by default, so tell me more:

  • where did you switched to 96 dpi? from the elive-scale-desktop tool?
  • can you show us the contents of your /etc/X11/xorg.conf.d/20-nvidia.conf file to verify that the 96 dpi is correctly added? (so assuming that, the 96 entry is added but your desktop is not using 96 dpi until you force-configure them with... elive-scale-desktop I assume)

I improved the message to mention HDMI too, (if you meant this message from the installer) now it will be:

Your monitor is connected using a VGA cable. Check the connectors of your monitor to see if you can use a DVI or HDMI cable instead because it improves the graphics. The operating system also detects your monitor more reliably and eye strain is reduced. This is just a suggestion and only optional for your computer.

Yes thank you, your comments about the issues here are very welcome so they can be fixed / improved :slight_smile: in fact the nvidia drivers was very well improved thanks to the recent betatestings on a laptop with these drivers but you were using a different setup (external monitor, and installation of nvidia which was not possible to test before) :applause:

hum... your screen looks correct for a 96dpi setting, so:

  1. which setting for dpi is the one that suits you better?
  2. if you remove/comment the 2 "dpi" related lines in your /etc/X11/xorg.conf.d/20-nvidia.conf that are included by default by Elive and reboot, does the screen sizes looks better?

yes it looks like your screen / drivers are simply disabled (so, everything is working except the displaying), unfortunately I don't have a similar machine setup to test this here :frowning: :frowning: but I can try to search in the code if I can find the reason of that, I will keep you updated in the next comment...

@SwiatLinuksa_YT as mentioned before, I suspected that the issue was that the nvidia modules being deactivated (rmmod) during the installation of nvidia in your target system, causing nvidia to stop working in your host (live) system :thinking:

Thanks a lot for pointing out this issue that could affect everybody having nvidia drivers, they were probably unable to install Elive

I did some changes and now is probably fixed, but it is untested so I don't have an nvidia machine where to install, it will be very helpful if you run a new installation on that machine to verify that is not blanking the screen anymore this time (installer automatically updates itself before to install), if you watch the terminals of the installation you probably see now a message saying "Updated Nvidia installer". (and don't worry for your previous install, the installer will take care of keeping your existing users and configurations, making the installation process much automated and faster)

1 Like