Error in apt update

I tried to do an apt update, and all repositories under sources.list.d have some errors. For example:

What did i break?

May it be due to the "upgrade" installation process that turned this Ubuntu installation into elive?

well all those keys should be in 'etc/apt/trusted.gpg.d/' ... so check if they haven't been deleted in some way.

Else you'll have to import the keys again.
Or maybe this is biting you (depending on how old the installation is):

This is what I have under such folder, i guess they are there?

How can i re-import them?

As explained in the link in my previous post. :innocent:
In short: wget -O- <> | gpg --dearmor | sudo tee /usr/share/keyrings/<myrepository>-archive-keyring.gpg

I sort of thought that you were still on Bullseye but clearly you already shifted to Bookworm... In which case probably the easiest method would be to upgrade using the Elive-iso again.
Spotify would need a manual reset though.

On a sidenote:
On my machines (whether Bullseye or Bookworm) 'apug' works just fine. So it isn't the repos.

1 Like

I don't think it should have been the problem, maybe looking at your installation logs there could have been any clue, but I think you didn't enabled them so I don't see the reports in the server

I would rather install the bookworm version (torrent on Patreon) instead :slight_smile: which is much newer and improved in many aspects, try to do an over-install of it with the bookworm one

1 Like

Tried this, didn't workout!

That's what i wanted to do, but i accidentally boot in legacy mode, ignored the mbr warning, broke grub, restarted the live usb, and at this point elive didn't detect elive itself anymore and neither detected the elive partition as an "upgradable" one lol

Luckily nothing really went lost since everything is in my nas anyway ahah

Fresh installation works great

The installer actually did not ask me if i wanted to share informations like it usually does. I always enabled it for elive know where the data goes.

Did use that one! In fact i have elive retrowave installed in a pc, but i wanted to replace ubuntu budgie on my secondary pc using the fresh iso. I just tried the upgrade mode to move from ubuntu to elive because "why not". And then that problem appeared. On the other hand, overwriting everything like i just did getting a fresh installation, returned a well working system

In case something could've been lost: Get a 'grub-boot-disk' and let it find the partitions for you.
Once booted you can repair grub from there.

1 Like

Booting in the correct mode (EFI) and reinstalling Elive should have solved the issue too, on the other hand since the previous install was unsucessful i think the installer considers then it to be a new clean install :thinking: unless it asks about which option to select

Didn't really take few minutes in the end... by here's my recap:

  • I had an ubuntu budgie 22.04.3 installation on this computer.
  • I downloaded the latest iso from the link on Patreon
  • When installing from the live usb, elive saw the partition containing the ubuntu installation and suggested to select it to proceed in upgrade mode.
  • I selected the partition, choosed upgrade mode, and let the installation finish with no error
  • The old question "do you want to help sharing the data" is not asked anymore so i do not really know how to let you know what's up with the logs now?
  • When i boot the fresh installation , everything went smooth like usually (also windows is safe and sound and correctly shown in grub as a boot option. It also boots fine).
  • I updated the theme using the guide that tells how to apply retrowave to the normal beta elive
  • I later tried to install spotify, but the apt update kept giving the no pubkey error.
  • I checked the things reported also in the guide of @triantares
  • therefore tried the corresponding retrieaval (and some others, even asked for help to chat gpt but it was totally useless)
  • annoyed, i decided to just reinstall elive in upgrade mode (it always solved my problems in the past)
  • accidentally booted in legacy mode
  • Elive detected the elive partition and asked if i wanted to proceed in upgrade mode
  • Elive installer suggested me it was a dumb idea ignoring the fact the current installation was efi but i was booting in legacy mode, and i should have created a separate mbr partition
  • i ignored the installer and proceeded anyway
  • Ofc the installation broke grub
  • I simply lazily rebooted the elive live usb and restarted the installer
  • Installer did not detect the elive installation. I rebooted. It did not detect it again. Proceeded installing choosing the partition where there was the broken elive installed. the installer did not care. I did not care anyway and installed elive freshly

Everything is fine now