Error VT-x is disabled in the BIOS (VERR_VMX_MSR_VMXON_DISABLED)

I am attempting to run a XUbuntu Virtual Machine through Virtual Box. When referring Virtual Box Startup to my XUbuntu .iso file i get the following message:

VT-x is disabled in the BIOS (VERR_VMX_MSR_VMXON_DISABLED)

Any ideas how to resolve this ? Otherwise how could I create a boot disk with this .iso in ELive ?

Did you check in your computer bios if the features for VM is activated ? VT-x is ADM and Intel also have one with a different name.

JF

[RobJungD] Just check these Dropbox - 20180815_215835.jpg settings in Virtual Box. Hope you will be able to run xubuntu.

@Fantasy_Apple

f you attached the picture from your dropbox, is it because the Forum didn’t allowed you to attached the ScreenCapture directly within the forum ?

JF

@jfbourdeau I don’t know but whenever i try to upload ScreenCapture it shows maximum upload size limit crossed. No matter if i compressed the image into few bytes this site showing same thing lol. :thinking: So i had to share images through cloud link. There must be something that doesn’t allow to upload images or some kind of restriction. :face_with_raised_eyebrow:

@Thanatermesis I think we should increase the attachment size limit, it also find it bothering… Discourse make it easy to attach an image and with a small limit, we’re going backward.

@Fantasy_Apple I just insalled a fresh version of Elive 2.99 on my pc,
using the default of VirtualBox for Ubuntu 32 bits, Xubuntu installed well

I think it is a BIOS bad settings on @RobJungD pc that is the problem.

@jfbourdeau Maybe you’re right.:star: But i think the error is showing because of default settings modification. As you said i’ve also installed many distro using VirtualBox default settings.:cowboy_hat_face: Just a day ago Thanatermesis explained the fact of VirtualBox Its nothing but a software that simulates as the hardware. BIOS problem occurs when we try to boot it on real machine (Like we need to turn off secure boot to install some special distro). So i think Hardware Virtualization must be checked in VM.

What I meant is when you choose an OS in VBox, and any distro, some settings are “checked by default” for this specific OS and distro… Vbox does it’s best guess of which default settings… And By default, if you choose Linux 32 bits, VT-x/AMD-V is checked.

If for any reason for @RobJungD it was not checked, it needed to be… You were right

But my default VM creation settings were ok for me during my test.

Tks !
JF

1 Like

That image is 6MB, it is too huge, a lot of wasted data, it should be resized, but unfortunately there’s not an easy way for the users to do it… maybe there’s a plugin for discourse that resizes the uploaded images? that could be nice…

@RobJungD appart of virtualbox, your computer needs to have vt-x enabled, this is a BIOS configuration, you should first enable it in your bios

1 Like

If I use Elive’s Shift Print screen and select one of my screen, 169k
Print Screen for a picture that contain my 2 screen, 200 something k

Users just have to make screen shot the right way in Ubuntu or within Elive, simply use Elive’s screen shot tools

1 Like