Error while building package with debuild

Trying to build a package with the higher level debuild instead of dpkg-deb.

error: binary build with no binary artifacts found; .buildinfo is meaningless

What do I do here?


Just pushed for you. Not sure why youtube-dl-gui is used by another repo that doesn't use any such dependency. :face_with_head_bandage: GitHub - TheTechRobo/youtube-dl-gui: A small GUI frontend for youtube-dl

Thank you,
Not sure how actively I'm going to be able to help.
My eldest daughter just invited me to so she might just have some advantage over you. :eyepopping:

And I haven't played chess in a very long time .... after a particularly devastating match where I got drunk coz I thought I had it all in the bag and lost interest. The opponent sat there for ages thinking about moves that weren't even an option so I started ordering drinks and answering his moves blindly. :disbelief:

So cut me some slack please. :smiley_cat:

1 Like

Never used that ... interesting.
Or would that be pbuilder? To install including deps:"api build-essential autoconf automake autotools-dev dh-make debhelper devscripts fakeroot xutils lintian pbuilder"

Have you tried cowbuilder ?

Trying it right now.

I've got a note to self for cowbuilder:

If you want a quick and dirty way of installing the build dependencies, use:

apt-get build-dep

This installs the dependencies. You need sources lines in your sources.list for this:

deb-src Studenten Net Twente - Index of /debian/ squeeze-updates main contrib non-free

If you are backporting packages from testing to stable, please be advised that the dependencies might have changed. The command apt-get build-deb installs dependencies for the source packages in your current repository.

But of course, dpkg-buildpackage -us -uc will show you any uninstalled dependencies.

If you want to compile more often, use cowbuilder.

apt-get install cowbuilder

Then create a build-area:

sudo DIST=squeeze ARCH=amd64 cowbuilder --createThen create a build-area:

sudo DIST=squeeze ARCH=amd64 cowbuilder --create

Then compile a source package:

apt-get source cowsay

do your magic editing

dpkg-source -b cowsay-3.03+dfsg1 # build the new source packages
cowbuilder --build cowsay_3.03+dfsg1-2.dsc # build the packages from source

Watch where cowbuilder puts the resulting package.

Good luck!

How do I start a new thingy?

❯ cowbuilder create
I: Invoking pbuilder
I: forking: pbuilder create --buildplace /var/cache/pbuilder/base.cow --mirror --distribution sid --no-targz --extrapackages cowdancer
W: /home/thetechrobo/.pbuilderrc does not exist
E: Directory /var/cache/pbuilder/base.cow does not exist
E: pbuilder create failed
I: forking: rm -rf /var/cache/pbuilder/base.cow

You need a .dsc file

Sorry, can't spend too much time on htis - my sister's iPhone isn't turning on right. How do I do this?

Put it on the windowsill and then threaten to push it outside into the cold deep uncertainty out there, if it doesn't play nice.
Either your sister or the phone will give in. You can't lose. :w00t:

1 Like

Good one. :rofl2:

As for how do I do this, I meant .dsc file generation.

Finally got around to (re)trying cowbuilder - this time on Elive.

Defaults to debian sid - which wont work due to there being no repos for sid and it looks for them - so I added --distribution buster. It almost worked.

Hmmm, you used an repo there ...... maybe you should try getting a source from a Debian repository to check where the fault might be.

here's the script I used to rebuild and optionally install .debs on my machine.
Maybe it can be of some use to you.

#! /bin/bash
#Fix libcurl3 dependancy issue with and force installation for amd64 computers
#Usage: "./ /path/to/file/xxxxx.deb"

NAME=basename $PACKAGE
TMP_DIR=echo $PACKAGE | cut -d"_" -f1 | cut -d"-" -f2

read -p "Rebuild this package? $NAME [y/n] " ANSWER
while [[ $ANSWER != "y" ]] && [[ $ANSWER != "n" ]] ; do
read -p "Rebuild this package? $NAME [y/n] " ANSWER
if [[ $ANSWER == "n" ]] ; then
exit 0
dpkg-deb -x $PACKAGE $TMP_DIR
dpkg-deb --control $PACKAGE
sed -i 's/libcurl3 /libcurl3 | libcurl4/' DEBIAN/control
sudo chown -R root:root $TMP_DIR

I don't remember where I got the script ..... I suspect I didn't write it but only altered it slightly for my own purpose.

What do you mean?

The command I ran was sudo cowbuilder --create --distribution buster - do you mean I should remove the elivecd source from my system?

The fault is with repo I think - this part of the paste:

E: Release signed by unknown key (key id A2C799BFDFF8D7C2)
   The specified keyring /usr/share/keyrings/debian-archive-keyring.gpg may be incorrect or out of date.
   You can find the latest Debian release key at
amd64: ok
2020-12-11 19:55:20 URL: [31170/31170] -> "/var/cache/pbuilder/base.cow/var/lib/apt/lists/partial/repo.buster.elive.elivecd.org_dists_buster_InRelease" [1]
gpgv: Signature made Wed Dec  9 15:57:16 2020 EST
gpgv:                using RSA key 7DE28EA6A09F7609843AF6D9A2C799BFDFF8D7C2
gpgv: Can't check signature: No public key

EDIT: Found a potential solution, will try when I'm back at my elive box, the solution is gnupg - Added key, but dget still shows "gpg: Can't check signature: public key not found" - Ask Ubuntu

That the repo isn't all encompassing i.e AFAIK contains only Elive specific packages.

But have no proof whatsoever.
Don't think or jump to conclusions, find facts. :shocked:

Choose a simple test package available on the Debian repo and see if that will build.
That way you'll know if it's your system or

Computer died, so I'll have to get the ssd out and chroot into it to finish this. :face_with_head_bandage:

Actually let me rephrase that: Charger died, so I'll have to get the ssd out and chroot into it to finish this.

If I remember where I put it, I'd post a photo - it was pretty bad. The pluggy part was completely bent out of shape, probably beyond safe repair.

Not surprised it happened lol, since the only way the charger would work was if it was bent a certain way. Was kept in storage and probably not well taken care of before I got it. :disbelief: :ohmygod:

Wasn't used for many years too, since it had archaic ff/chrome/itunes/wordperfect/bloat/morebloat/extremebloat when i got it.

Get the SSD out and boot from it -- is another option.
connect it over USB and you can simply use it.

Little pieces of tinfoil sometimes do wonders there.
What have you got to lose? :madness:

My house :madness:

Exactly what I'm using. :nod:

Then just boot from it .... no need to "chroot". Unless you're doing it for kicks, of course. :smiley14:

Chromebook can't do that...without some mods that I don't want to do.