Feedback for the Installed Elive 3.7.16

Hi all,

First of all I'd like to thank elive devs for their work.

I tried elive 3.0 a few months ago. I liked it but I needed more recent versions of some applications, and I switched to debian buster. Then I learned that a new elive was coming, based on debian buster. I obviously had to try it :smiley:

I installed elive 3.7.16 on my (10+ year-old) acer extensa 7630EZ laptop. The installation process went fine but I experienced some minor issues.

  • When running elive from USB key, it asked for language and keyboard layout preferences. I kept default french choice for both, but keyboard layout was qwerty (english). This issue persisted after installation. I didn't find how to change this using graphical tool, and finally ran the following commands, as found on the web:

dpkg-reconfigure keyboard-configuration

service keyboard-setup restart

This did the job

  • I didn't find elive version from graphical menus. I had to cat /etc/elive-version to get it and tell you what version I'm using

  • After playing around with cayro dock customization, the following graphical items didn't react anymore to mouse clicks:

    • Enlightenment pager showing virtual desktops, tough I can still switch between them using ctrl+alt+arrow
    • minimized windows
      If I try to move them with ctrl+alt+left_click I move a cayro dock instead
      Clicking on their icon in the dock brings back the previously minimized window
  • I didn't manage to change background image. I didn't find how to tell enlightenment to use a file in my home. I even copied the pic to /usr/share/e16/themes/Elive_Dark/backgrounds/ but it was not in the list of possible backgrounds. Clicking "Définir comme fond d'écran" (define as background image) in thunar has no effect

  • Elive menu has item "install silverlight and netflix" but the installation fails. This does not seem to be very important as netflix runs just fine in firefox without this extra installation

  • When booting elive from USB key there's an animated boot screen, but when booting from disk after installation, the loading screen is just black. I don't even see the usual linux startup sequence messages

  • I didn't find how to move/hide the system monitor app that displays on top right corner of the screen

I didn't spend much time trying elive yet. I'll try more things later. Anyway I like it very much. Thanks again :slight_smile:



Thank you @Kuipper for the detailed feedback and welcome to the forums :slight_smile:

I'm going to check all those details and fix what is possible

About the boot splash images in the installed system, please try this:

sudo scite /etc/default/grub

comment the two lines that includes something like GRUB_GFX....

then run:

sudo update-grub

and finally reboot and see if you have those images appearing now

you should play with these options (only keep the second one, or only have the "auto" value in the first one, etc) in order to make it working

When you have it, please tell me which option is the one that made it working for you, so maybe the resolution values are not needed anymore to include (autodetected from the installer)

In fact, maybe only the second one should be removed

Oh btw, can you show me the result of this command? I have made a recent change related to it:

dpl | grep linux-

About silverlight, can you confirm me that it just works without run it ? (this means, try it from the Live mode, where the installer of Silverlight has not been run yet)

I can confirm too that "silverlight" videos just simply work (at least the ones I've encountered until now) in firefox. Even "youtube-dl" downoads and converts them to mp4. :happybounce:
I think that menu entry isn't needed anymore.

Right click Desktop, Desktopm Background and choose

Nope, not enough !

First and foremost: You have to populate "~/.e16/Backgrounds/" with the personal wallpaper you want to use. Only then will you have the choice of images that are there.

Both are a CairoDock thingy: It reserves space over the whole width of the screen, thus overlaying anything else there.
Just move the dock away and then "grab" the pager and move it to where you want it .... after which you can put the dock back where it was. :smiley_cat:

That's "conky" and it's fairly hard to customize or even move ....... I personally never enable it, also because I think it's useless humbug on an installed system.

1 Like

agree tks ! Skipped a part.... Good catch

1 Like

Thanks for all the tips you gave me.

I don't have time to try them today. I hope I can do that during the week-end.

More generally please don't be upset if I don't react as fast as you :slight_smile:


fixed for next build :slight_smile:

About Keyboard and Language options, I just added an extra tool in Elive so that the users can reconfigure their language and keyboard

Now the "set as wallpaper" feature in thunar will work on e16 too :slight_smile: (since the next build)

check your hotkeys-list document, you should be able to do it from the hotkeys

silverlight instaler has been removed from the list since is not useful anymore

For the remaining things (bootloader image by changing that resolutions conf, i will wait the feedback from @Kuipper to see if worked :slight_smile:


I tried various combinations of GRUB_GFX*, but unfortunately none of them fixed the boot screen

I tried disabling any of those two lines, and even both of them. I tried GRUB_GFXMODE set to auto only, set to 1024x768x32 as vbeinfo command suggested. I tried explicitely adding GRUB_BACKGROUND. None of these improved the boot screen, I only managed to change screen resolution (seen on the only one displayed message, see below).

I've been a bit imprecise in my first post. The screen is not immediately black, the message "Elive_OS: clean, files XX/XX, blocks XX/XX" (from my memory, it may be a little different) is displayed for some time before I get a black screen. I don't know if it's important.

As you asked Thanatermesis, here's the result of dpl command:

dpl | grep linux-
ii binutils-x86-64-linux-gnu 2.31.1-16 amd64 GNU binary utilities, for x86-64-linux-gnu target
ii firmware-linux-free 3.4 all Binary firmware for various drivers in the Linux kernel
ii linux-base 4.6 all Linux image base package
ii linux-compiler-gcc-8-x86 5.2.9-2~bpo10+1 amd64 Compiler for Linux on x86 (meta-package)
ii linux-cpupower 5.2.9-2~bpo10+1 amd64 CPU power management tools for Linux
ii linux-headers-5.2.0-0.bpo.2-amd64 5.2.9-2~bpo10+1 amd64 Header files for Linux 5.2.0-0.bpo.2-amd64
ii linux-headers-5.2.0-0.bpo.2-common 5.2.9-2~bpo10+1 all Common header files for Linux 5.2.0-0.bpo.2
ii linux-headers-generic 3.7.10+0.0.1+git930c5fd84-6buster1 amd64 workaround for compatibility integration
ii linux-image-5.2.0-0.bpo.2-amd64 5.2.9-2~bpo10+1 amd64 Linux 5.2 for 64-bit PCs (signed)
ii linux-kbuild-5.2 5.2.9-2~bpo10+1 amd64 Kbuild infrastructure for Linux 5.2
ii linux-libc-dev:amd64 5.2.9-2~bpo10+1 amd64 Linux support headers for userspace development

Triantares, you were right, moving cayro dock solves issue with pager not reacting to mouse events.

I got a notification about an automatic update. I saw there's a new tool for keyboard config, as announced.
I didn't see other announced modifications yet (silverlight installer removal and background image setting from thunar). I guess it will be for next update.

I'd like to add another suggestion too: it would be nice if installation process allowed to set timezone. I had to configure the clock after installation.

Thank you all and see you later :slight_smile:

@Kuipper to add a timezone configurator is possible but requires a lot of work (so, not planned yet), if you try the new build 3.8.1 it should have some small improvements in the timezone detection, hopefully it works by default for you now :slight_smile:

And on a running system it can always be (re)configured using "sudo dpkg-reconfigure tzdata".


  • Which might actually not be a bad idea to add as a menu-entry.
1 Like

On a side note:

Booting for the first time with USB, aka persistence not
(yet) enabled:

  • Will not have a network connection yet and thus will use the time settings available from your BIOS. These do not have to necessarily be correct and certainly won't be corrected for summer/winter time settings.

Once a connection is up, it will set the time correctly according to the time-zone you are in.

sounds good :thinking: are you sure the changes are permanent ? (when you connect to internet it should set it back to the old timezones detected, unless this tool really changes the modified files too, also, in a new connection network (ssid) it will change it to a new detected timezone

as a side note, the last version 2.8.1 (or apug) has much improvements in the detection of the timezone (so should be better detected)

exactly, a connection is required ot detected the timezone (ip geolocation based)