Finally installed 3.8.34 after downloading it the day before 3.8.35 dropped

Yeah, timing is everything in this life, so I can't be mad. I was rewarded with the background I wanted when I first googled Elive reviews! The article was on ZDNet by Jack Whalen and he waxed nostalgic about his previous use of the OS. Indeed, his article was what spurred me to download and install Elive that day!

Elive is smoother and I daresay faster with this iteration; that's admirable. I still have the bluetooth issue and another with encoding video with a BayTrail CPU/GPU but I'm sure the latter can be resolved qquickly (I hope).

I want to live and work with this version for awhile before I scrape up some shekels for the 3.8.35 download. Be here on the forums for awhile...

The link you received will be valid for quite a while and allows you to download the latest version (in this case 3.8.35) .....where that being said: All donations are always welcome. :wink:

That's the reason I don't take advantage of the loophole; I want to contribute for each edition that I download. The (Elive) show must go on!


Thank you for your support @ZRVoyyd :applause:

I have received an email with a failed installation from you, looking at the reports you sent seems like you did 2 failed installations and finally in the third one it worked, I don't see in them what went wrong, it only says that your nvme disk was busy while trying to partition it but I don't know the reason, do you have any clue? (did you had it mounted somewhere or doing anything with the disk?)

The last install worked in the same way (automated partition). From what I think: the installer suggested you to reboot so that the kernel will know the new partition values, but you tried again without reboot (second attempt) and then you decided to reboot which made it working, is this right? :thinking:

I didn't find yet a way to make the kernel update about the new partitions on these (rare) cases, the installer uses a few commands like blockdev --rereadpt "$disk" but in some rare cases is not enough and a reboot is needed

Really? None of your installations have ever failed. It's what I was doing with Elive that might've caused the issue. My daily linux driver with Elive is an HP Pavilion 11-n010dx x360 (2014). Unfortunately, I'm still running an HDD (1TB), but it's responsive as hell under Elive.

The only issues that I have with the laptop are related to Bluetooth and I suspect h/w failure. Will get a new WiFi/Bluetooth card and will let you know how that turns out, although I want to troubleshoot the problem first.

It has been an interesting experience installing and configuring Elive on a variety of machines other than my own; Elive is currently installed on six Dell Latitude 2110 (32-bit), two MacBooks vintage 2010 (64-bit) and a Samsung Netbook (32-bit). The six Dells were a donation to the local youth group in my community and I have manage them as well as two Lenovo Thinkpads (L460, 64-bit), two older Thinkpads, a custom built desktop vintage 2011 and another HP Pavilion (64-bit). They're all getting the Elive treatment. The two L460 Thinkpads, the desktop and the HP Pavilion will be used to teach the youth filmaking, editing and livestreaming production while the others will be used for word processing and such.

I've found that the different h/w of these systems requires that I curate apps carefully; apps that work smoothly for one particular h/w platform might not be as snappy on another platform. For instance on my HP Pavilion 11, I can run Xine (a video player that I think should have it's own icon), Videos (formerly Totem) and Kaffeine without issue, but the MacBooks don't run Xine or Videos smoothly, but will run Kaffeine without issue (so far).

Thank you for Elive!!!

P.S. Forgot to ask what version of CURL are Elive 3.8.32 and 3.8.34 running? This article came up in my feed this afternoon: Nasty bug discovered in widely used Linux utility curl, and patches already rolled out

Nasty bug discovered in widely used Linux utility curl, and patches already rolled out.

The article goes on to state the CURL 8.4.0 is unaffected by the security hole.

1 Like

That's a simple "curl -V" to find out it's 7.88.1 .... which BTW is also the version Bookworm has.

If I read the article correctly it's not an immediate hellhole of vulnerability i.e it requires quite a few very specific circumstances but ..... Murphy's law applied means it could happen so it will happen thus it should be seen to.
To quote the article:
To be precise, the preconditions needed to spark the problem into a curl security fire are:

  1. The curl request is made via socks5h.
  2. The curl state machine's negotiation buffer is smaller than ~65k.
  3. The SOCKS server's "hello" reply is delayed.
  4. The attacker sets a final destination hostname larger than the negotiation buffer.

That's a lot of preconditions.

--etouq-- :wink:

Yeah but I'm one of those better safe than sorry proponents so of course I went and found CURL 8.4.0 and when I attempted to install it I received dependency not satisfied message.


O well, I'll just have to be careful...

Well you'll need ALL those preconditions. It's not and/or so there's hope. :wink:

Ctrl + space --> "debsearch curl"

yes and no, is the same in bookworm but a newer one is on bookworm-backports, so this is the version that will be the default on the upgraded Elive

howto in construction... but i left it there, no much time to continue it now: How to install any software in Elive Linux - UNFINISHED HOWTO