Grub boot error "mdadm: no arrays found in config file or automatically"

Ok so...
I get 2 errors repeatd more or less 4 times:
1.274762] ACPI BIOS Error (bug): Could not resolve symbol [\_SBPCI0.SAT0.SPT4._GTF.DSSP], AE_NOT_FOUND (20190509/psargs-33)
1.286261] Error: Aborting method \_SBPCI0.SAT0.SPT4._GTF due to previous error (AE_NOT_FOUND) (20190509/psparse-531)
I get the following error after it: mdadm: no arrays found in config file or automatically
I just moved to my good desktop pc. it was time to do so. But now i get this. It does not harm but i delays the boot so much! Especially because the error is repeated quite a few times (like 50?), and in the middle there is this: dadm: error opening /dev/md?*: No such file or directory
after this 30-to-60 seconds pain, i get the following:
Gave up waiting for suspend/resume device

Next error:
[ 34.389380] radeon 0000:01:00.0: failed VCE resume (-110).
[ several different nubers, 34.xxxxx onwards for quite a few times] kvm: disabled by bios

And then it boots completely fine

I get the same error after moving my SSD from one laptop to another.
I didn't wait for the 50 messages but rebooted into rescue mode and let it start-up.

I haven't rebooted yet but first thing I'll try is re-installing grub. :thinking:

Oh yes, simply enable "kvm" (hardware virtualisation) in the BIOS/firmware.


Nope no joy ...... it won't install. :face_with_head_bandage:

"grub-install: error: /usr/lib/grub/i386-pc/ doesn't exist. Please specify --target or --directory"

And I noticed that the grub being used is not the Elive one but from the AltLinux that's also on the machine. Might be the firmware/BIOS biting me. :thinking:


Set "legacy mode" to "uefi mode" first in the bios

On top:

You might want to reconfigure your X:
"sudo dpkg-reconfigure xserver-xorg"

1 Like

@stoppy98 if the answer solved your problems:
Please set it to "solved" for search emgines. :idea:
Only the first poster can do that.

this is needed? so i can try to implement it for the installed mode in case of... this dmesg message found? :thinking:

1 Like

This is needed because the gpu differs from the one that was in the original machine and requires a different module to be loaded.
It happens a lot to me when I use Clonezilla to clone whole systems on different nachines.

ok we are talking about different things here :slight_smile: , where I assume that:

  • the default install does not need to reconfigure xserver-xorg (if is required, i will add it)
  • you said "to use a system in a different machine", this of course (may) requires new / different configurations, and everything is "up to the user on its own risk", elive cannot do anything from here

in fact, even if you move a system to a different machine, it is suggested to reinstall over (upgrade mode), so the installer has a lot of autodetections that takes care to include or remove packages or daemons that are needed / not-needed in that machine, so a lot of things can affect and reinstalling will improve the overall compatibility and correct drivers & settings

1 Like