Grub installation on Beta elive 3.8.2

Installing the 64bit elive will not configure the grub setup correctly. I even tryed to install grub on the master bot record by hand and the system won't boot. The reports I get on startup is "operating sytem is missing or installed".

I'm wondering if the grub-i386 is involved with the issue, or you need to update grub?

This might also be a BIOS setting (UEFI-Legacy) biting you.

1 Like

Agreed, had similar issues earlier, too.
I switched back to "classic bios boot"

you can switch your bios to use one or other, but the installer should guide you with the things that you need to install it correctly during the manual partitioning :thinking:

1 Like

The Dell xps x502l works fine with Grub with Elive 3.8.7 64bit Beta.

This option fixed my issues on this subject

If so, would you mind marking the answere to the issue as solved?
That makes it easier for others when they have a similar issue and do a search. :smiley_cat:



Issue is solved by installing Beta 64bit 3.8.7 elive


What I actually meant is that there is a checkbox option to mark the issue solved at the bottom of the messages.
I did it for you but I.m not 100% sure which answer solved it for you. :smiley_cat:

Hello, why do you say it could be a BIOS setting (UEFI-Legacy)?

If for instance the BIOS/Firmware is set to boot both (legacy and UEFI) and UEFI is set as first it might not even find the USB flashdrive to boot from correctly etc, etc.

So switching around (i.e setting legacy first) usually helps, it depends how the installer set the system up to boot.
Either way the machine firmware looks in different locations for a bootloader. GRUB is not a "one stop solution" anymore.

1st of all:
Welcome in the forum ! :hug:
That said, it is not a solution for all and everything,
but it may be one. Reason:
Bios is not Bios, it differ also in the behavior...
On one model it's the easy way out of issues,
on the next model not.
I personally had bad experiences with certain Lenovo NoteBook models (p52 & p53) finally after hours, I got it run. Seems to be a general issue with Debian (systemd ?, dunno) - same crab happend with MX Linux, just btw...
Other models had no issues,
none the less be careful/thoughtful with UEFI partitions - it is actually a good idea to read about it, before you work with it.

Sorry, hello everyone :wink:
Oh thanks for these answers

Hello, by the way thank you for these explanations in passing
and yes i also think it's actually a good idea to read it