How to disable switch desktop with two-fingers scroll

By default desktop change when I scroll by two-figers on touchpad. I want to disable this func. How i can do it?

Stable or Beta version? :slight_smile:

they uses a different desktop configuration system

64-bit beta 3.8.17 :slight_smile:

scrolling so two finger scroll, switches between the virtual desktops, indeed.

Go into "enlightenment" - "settings" and chose Desks where you can set the number of virtual desktops down to 1 ... and "apply".
Now you can switch desktops by clicking an area in the pager or using the Ctrl, Alt and arrow combo.

Thx, @triantares, but this way is not what I want.
I like 2 desktops with 8 areas in every desktop.
I tuned keybinding and I can switch desktops by alt-` combo, end swtich areas by alt-1,2,3 ... etc
It is very usefull
I often use two-fingers scroll while work. Sometimes, when the mouse pointer place on the free area of desktop, two-fingers scroll switched desktops. It is unfortunately and dislike me.
I want disable or block this function for comfortable using Elive

wouldn't know how to turn off that behaviour other than not having the 2 desktops. Found it ! See below.
Of course you can set a higher number of areas on a single desktop if it's the amount that counts. :grinning_face_with_smiling_eyes:
Me personally, I prefer a single desktop on the top right like in E17 on Stable so I never run into this scroll thing.

It's something that's prolly hidden deep in some config file somewhere. I'll have a look if I some time.
Which after a quick search turns out to be in "~/.e16/bindings.cfg".
You can edit the file and find the part that says:

MouseDown   *  4 desk prev
Tooltip Go Back a Desktop
MouseDown   *  5 desk next
Tooltip Go Forward a Desktop

and change the * to i.e S to have to use the scroll with Shift to switch desktops, thus:

MouseDown   S  4 desk prev
Tooltip Go Back a Desktop
MouseDown   S  5 desk next
Tooltip Go Forward a Desktop

Save the the changes and restart E16.

There is an identical "/usr/share/e16/config/bindings.cfg" that maybe will regenerate the original bindings on a reboot so I'd alter that one in a similar fashion.

Great idea! It's work! Thx!