Howto add (snap) apps to cairo-dock and the launch-menu in 3.7.4

If, like me you have installed apps using "snapd" you will find that they cannot be added to cairo-dock whilst running .... nor can they be added from the launch-menu because they are not there either.

The solution is to make a .desktop entry in /usr/share/applications.
The following example is for "gimp" but can be copied and changed to any other snap application.
create the enntry with your favorite editor (mine is nano for simple jobs like this):
"sudo nano /usr/share/applications/gimp.desktop"

and add the following text:

[Desktop Entry]
Name=gimp
Comment=gimp Desktop
GenericName= Gimp for Linux
Exec=/usr/bin/gimp %U
Icon=/usr/share/icons/Faenza/apps/scalable/gimp.svg
Type=Application
StartupNotify=true
Categories=Graphics;GTK;2DGraphics;RasterGraphics;
MimeType=x-scheme-handler/gimp;

After which (when saved) cairo-dock will prompt you if you want to open the application. :popcorn:

3 Likes

in fact, the provider of the app should provide a .desktop file with the app... how otherwise is the app meant to be run since .desktop files are the standard launchers? spank to them...

is there' not a .desktop installed in other places? where the files of the snap thing are installed in fact?

Every time I used snapd on ubuntu distros, I always ending up have the installed application icon showing up... It's may be an bad integration of snapd for E Desktop Environnement

Yes there is.
It's in /snap/gimp/current/usr/share/applications/gimp.desktop
It also works to copy that to /usr/share/applications or maybe a symlink will do.
This will require editng the Icon=path in that file,though.

The adding and editing thingy is a nice simple stanza to add other personal stuff to the dock ....... like a lockscreen or a screen-rotater icon for on my tablet.

Lock screen to the Dock or somewhere is a must + a already made shortcut for the command to lock... for newbies or less patient people

Yep, but bringing up onboard just to lock the screen is a drag. It's a tablet ..... not always keyboard attached.

The one above rotate-screen is my lock.

1 Like

I vote for the default background to be this one :slight_smile:
I also have the same

1 Like

Looks a bit weird when I rotate it though.:surprise:

1 Like

snapcrap in the go !

this is absolutely non-standard, but even worse: unable to implement

1 Like

@Thanatermesis
Just did the 32bit to 64bit (3.0.6 to 3.7.5) again.
Started 21.45 and ended 21.56 (ETC) and all went smooth as cold beer on a summerday. :rainbowyay:
That was on the reinstated machine that caused so many problems last time.

The "only" difference to last time us that I had activated the BIOS partition when upgrading 3.7.4 on the same machine , so no questions asked.
All looks "in the pocket" to me now.

Ultimately, the ony real problem that now can occur is the danged partitioning, in that it always carries a risk.
So backup, backup and backup if there's something important there.

2 Likes

For now, for me it's a workable solution until gimp and mypaint get their naming schemes sorted out. :nod:
Then: Out the window goes snap! :rofl2:

not out of the window

this is extremelly crappy:

and doesn't works, it wont show on the desktop and there's no way to make it working, see the "gimp/current" part, there's not like /opt/share/applications or /usr/local/applications which should be better, and there's not a single dir to scan

in other words: why snap doesn't just do it better ? :woman_facepalming:

why when I was installing Snap apps in Manjaro or some Ubuntu distros, it was showing up in menus ?

Probably because every developer only has eyes for their own app and doesn't give a hoot of what snap should be doing.
Suppose next they'll be wanting to containerize everything, every app its own virtual space.

On the Ubuntus I tried, that was a 50% chance of success.

1 Like

the .desktop files are scanned from this standard directory list:

~ ❯❯❯ echo $XDG_DATA_DIRS
/usr/local/share:/usr/share/xdgeldsk:/usr/share

so that "snap address dir" makes no sense the way is installed, it doesn't follow any standard, so it is not well made

how other distros does it? i dont know... but probably using an ugly hack

when you install an application, in the correct way, desktop applications are in the correct places and everything works as expected, but thats not the case of the snap things (at least this one)

thats their fault (snaps things), they should be better made, following standards and strictly allowing only things in the correct way instead of "ugly hacks" (putthing things in any place, in any way, any permissions, etc)

1 Like

declined. Not thisone, noooo

The library "problem" has been resolved so no need for jumping throuht these hoops anymore. Both "gimp" and "mypaint" install fine alongside each other, using api (apt-get install).

NOT TRUE, sorry!
Gimp still removes mypaint.:sniff:

1 Like