Installation issues

After getting through the locale/keyboard SNAFU :sunglasses: Thanks for that help :heart_eyes:

I partitioned my M2 SSD giving 238 GB to install Elive on.
My setup is
MB = MSI MAG X570 Tomahawk WiFi (MS-7C84)
CPU = Ryzen 7 5800 X
RAM = 16 GB DDR4
Flashed the BIOS about 1 week ago with image from MSI dated 2023-07-24
Graphics = NVIDIA GP107 [GeForce GTX 1050 Ti]
Screen = 2 * Samsung 4K 32"

  1. On boot with Nvidia drivers option I noticed an error message something like "Blacklist hash error -16" flashing by before listing all 16 cores (in reality 8+8) and their speed 3850 - 4120 MHz
  2. When I select start of installation I get a message that my BIOS is broken and needs to be updated...
    I start the install that is not very fast but okay. It seems that i builds up a kernel with Nvidia drivers hooked in.
  3. The install stalls on configuring after about 1/3 of the progress bar with no indication that anything is going on. After an additional 10-20 minutes it is suddenly stalled at about 75%. I wait 15 minutes. Then take a looooong walk with my dog and coming back it is still stuck at 75%. (Some signs of life would be nice. Is it working or has the installation wandered in to LaLa land?)
  4. At no point of the installation preparation do I get an option whether to dual boot my Linux Mint 21.1 or not (Something that pretty much every OS today does (I can not speak for M$ as I do not have any such malware)) They share the same boot partition but have separate EXT4 partitions

So far no success on installing. I also tried using a regular 320GB SATA SSD but since that is not a UEFI recognised device it can not be booted from :frowning:

I'm not really in the know about Nvidia hardware (I don't have any) so I was hoping @Thanatermesis or any of the others who do might weigh, sorry for the delay. :bowing_man:

I do see some strange (unrelated to Nvidia) stuff that might need more explication.

Flashing the BIOS isn't needed really for booting as on UEFI systems everything is updated through the EFI partition content. If you want to use the "legacy boot" option, you would require it though.

  1. These errors indicate an issue with incompatible keys in the firmware that are blacklisted in the kernel. They can be ignored i.e shouldn't hamper the functioning of your machine.
    To troubleshoot, having an output of 'sudo journalctl -b 1' would help. ... considering that would be a lot of output: Please do copy it to i.e "" first and show the link.

  2. I don't know of any BIOS error messages in elive-installer other than those about "gpt/UEFI" firmware. This is starting to hint at your previous BIOS/Firmware upgrade, by the looks of things. :thinking:
    If you want to check out the Firmware content, look at the output of: 'sudo dmidecode' and see if it is what you're expecting it to be.

  3. If the installer isn't showing anything (not even a terminal opened) then it is still configuring itself i.e nothing is happening to your machine yet.

  4. Considering the previous: You shouldn't be installing anything yet so that's normal.

So I'm taking the machine is still in it's original state when you reboot? If not ... then there is a serious issue at hand. :warning:

I'd think it doesn't/wouldn't have a GPT layout, causing it (or anything else) to not be recognized. If it's got an MBR it should boot with "legacy-boot" but actually the installer should take care of an EFI partition for you.

These are confusing and multiple errors which I cannot know what is happening because there's no more details :thinking:, what I recommend is to start again with:

  • reset your BIOS to the defaults / optimal settings
    • make sure UEFI is enabled and legacy is disabled
  • download a new Elive iso and record it again to a different USB media (these issues could be due to a broken media or iso), using the suggested tools to record the usb
  • boot then elive and try a new installation, if you encounter an issue try to describe it as much possible, with error messages (run "dmesg" too) or with the details to reproduce it, if there's not enough details we will need a recorded video from your phone to the whole process showing the issues encountered, uploaded to youtube for example in a temporal video

What seems to happen is....
When I installed on a regular SATA SSD the install went fine all the way until reinstalling GRUB when no update was made.
When I then tried with a reorg of my M2 SSD The install fails on the last stage of install of GRUB.
After I update the kernel on my day-to-day Mint 21.2 the GRUB is properly installed and the two Elive suddenly shows up.
When trying to boot from the M2 the installer is started with message "Updating GRUB. ..Rebooting." No update is done so after the reboot is done the same state is entered.
When booting from the regular SATA SSD E-live starts nicely
Advice if there is any log I can send to help with investigation

I am actually surprised how many people seemingly install or upgrade Elive and take no heed of this pop-up:

Next time do give an email-address and take note of the day and hour.
That way there will be a means to find and look into into what happened without having a silly "back-and-forth" of questions here on the forum .... :face_with_head_bandage:

And I actually entered my email address :slight_smile:

1 Like

That would have been worthwhile to mention (with the date) in the initial post.

@Thanatermesis should look at the logs.
My uneducated guess would be that, there's something going on between the various distros in the manner of handling /boot/efi. :thinking:

The somewhat successful install on /dev/sda1 has vmlinuz created 06082023 at about 15 Bangkok time

and the totally failed on /dev/nvme0n1p3 has vmlinuz createdat 08082023 at about 13.50 Bangkok time

I will remember to add a date and time in future posts.

1 Like

That "sda1" is a consideration as that partition (i.e the first) should be a vfat EFI partition, for it to work on a UEFI system.
I'd advise (if there's nothing to lose on sda and you want UEFI) to let the installer erase the whole disk and create a new layout. That way it should be created automagically......!

Isn't this a bit at odds with:

Apparently, Elive is installed but tries to boot from a wrong /boot/grub entry i.e Grub sets the previously booted system as default for a next time.
Like I mentioned this looks very similar to ..... that had IIRC 9 different distros as multiboot and reverted to using "Refind" because "grub2" got so slow, meaning it could be a very real bug. :thinking:

It would be good to get to the bottom of this.

hum this is strange, we have seen this bug before and I think the issue was resolved, probably caused by a timeout too short (around 3-4 minutes) of generating grub which timeouted and then it failed... the updated installer (2 weeks ago) solved this issue, you are the second person to have it and im not sure what exactly caused the issue, since I don't have the machine is very hard to see where is the issue exactly

if you manually run on Elive "sudo update-grub" it does takes too long or fail? (which im not sure that you can actually try that if you cannot boot Elive in a first place)

Eventually there can be a way to make your Elive boot in order to check in detail what is happening, will be more easy if you allow me to remotely check what is happening (using anydesk or the elive-remote tool), tell if you agree with doing that