Installation report 2.9.99 --- crypttab malformed

I finally succeeded in getting the install working on my eeepc 1000. This machine has 2 ssd’s. sda is 30gb and sdb is 8gb. Wanting both to be drives to used and encrypted, I wanted (did) to partition with raid > luks > lvm with a separate /boot.

The Elive installer had an option to go to Palimpsest to do partitioning, this always brought up Gparted. I finally turned to the Debian-unofficial netinstall image to do the partitioning. The Stretch installer failed somehow, but it wasn’t obvious till grub install time. This weeks build for Buster did the trick nicely.

So now I reboot to the Elive usb and unlock luks, activate LV’s, and mount them. The Elive installer would not offer the logical volumes as targets till they were mounted. I had wrongly hoped that vgchange -ay would be enough.

This last time, the install went through without error, so I rebooted to a never ending splash screen. Escaping out of it, I see that initramfs cannot find the logical volumes.

Ok, so now I reboot into a copy of Parted Magic and create a chroot environment and poke around. From memory, /etc/crypttab looked something like:

md127127_crypt UUID= none luks

I first tried md127_crypt and inserting the UUID in place of the whitespace, this failed with the same results. On the second try, md0_crypt worked.

I don’t know if this was a result of my unconventional approach or if there is a bug in the installer, but I wanted to report it.

It was worth the effort though. What a beautiful, responsive piece of art Elive is. Congratulations!

2 Likes

One of the main tools used for the installer is the command:

sudo partitions-list --show-all --show-disks --show-raw

It should show all the devices found, also the lvm / encrypted ones (you may should unlock luks first if needed)

If these partitions are not shown with this command, the installer would not see them, could be easy to make them show up (its a script if you want to try to hack it), but a tests machine would be needed to try it

This can be a part of the installer which failed to get the correct uuid (or probably just detecting the partition correctly), but since partitions-list may not show it the problem can come from this part too

A bug in elive, or more exactly a feature not yet supported/tested, thanks for report it :), let’s see how we can make it working by default

Thanks :applause: :boogie:

BTW, the installer of Elive also includes encryption when automatic partitioning mode is selected

1 Like