Installing 3.8.43 to a Thinkpad Helix2 tablet -- Not really going well --

I installed 3.8.43-amd64 to a Helix2 thinkpad tablet and the experience was actually quite bad. :frowning_face:
As a first:

  • Using Ventoy to boot didn't work w.o disabling 'secure boot' (A normal 'dd' USB disk did) .... but then:
  • Booting the Ventoy disk only gave a blank blaclk screen ... it just didn't boot but using 'grub2 mode' did.
  • To be clear: This is a Ventoy issue, not Elive

The installation was a simple 'use the whole disk' declining the upgrade of the existing Ubuntu on it but then .....
The machine refused to boot, requiring a 'grub-boot-disk' to continue.
Eventually it did boot after I did "sudo dpkg-reconfigure grub-efi-amd64" from the running install.
Next caveat:

  • sound card doesn't show up (it worked on Ubuntu) not even after letting the 'audio-configurator' have a go at it and the configurator claiming that it was setup correctly. :frowning_face:
    This is a Broadwell-rt286 card and IIRC I actually installed Ubuntu on it because of that sound issue (and some more, but that's for later).

Bodhi 7.0 also configures this card correctly as it uses a Ubuntu (Jammy) base. Recognizing it as an 'Intel Broadwell-U audio device' and using the 'snd_hda_intel' driver as does Elive but I cannot get even a "beep" from the frigging machine, using Elive.
I think this is a bookworm kernel (read firmware) issue, even Ubuntu 2404 does not have sound. :shocked:

I recently did an "automated partitioning" install and found a few bugs in the disk/partition functions, I fixed them yesterday and I was able to install it correctly, maybe you faced the same issue

extra note: wifi didn't worked too with the default kernel on that machine, but it worked with the second / stable kernel

that's very good! I have been waiting to find a machine where the sound card didn't worked in order to test and fix what is happening on it, I was unable to reproduce that in my machines, so could be very good if I can run a few commands on that machine to see what is happening in order to solve it

may be, just as the mentioned kernel wifi issue before with 6.7 (backport) which worked with 6.1

It's not as much that the soundcard doesn't work but that it doesn't load anything at boot.

If I run Bodhi (which is built on 2022 Ubuntu) it works and ... it will work on Buster based Elive too, providing I don't use anything higher than the 5.3 kernel.
Anything newer will not work or recognize it .... meaning: 2024 Ubuntu, all Bookworm based distros, Fedora and Suse Tumbleweed.

Elive wants to set up the card and offers the choice between the HDMI and BroadwelRt286 device but cannot configures it. The same goes for alsamixer .... if I opt for the rt286 it errors out.

So if you run the audio configurator manually, none of the choices work ? :thinking:

Booting with the second kernel (6.1) makes it working?

No, 6.1 wont work either.
It's the combination of available modules, firmware and how they're called.

A Buster version works fine but a Bookworm does NOT, not even with a 5.4 kernel.



The firmwares are updated in elive from testing, which are meant to be more updated but maybe they are less compatible (your case?)

Can you try to force downgrade them and reboot to see if works? :thinking:

~ ❯❯❯ appo firmware-intel-sound
  Installed: 20230625-2
  Candidate: 20230625-2
  Version table:
 *** 20230625-2 1500
       1500 file:/home/thana/packages/mirror-elive/elive-bookworm bookworm/drivers amd64 Packages
       1500 file:/home/thana/packages/mirror-elive/elive-bookworm bookworm/drivers i386 Packages
        100 /var/lib/dpkg/status
     20230210-5 500
        500 bookworm/non-free-firmware amd64 Packages
        500 bookworm/non-free-firmware i386 Packages
~ ❯❯❯

there's a few multiple firmware packages, but basically try to remove the "drivers" word from the elive repos and run "apug", they probably downgrade to the ones from debian repos, otherwise you must "apir" them one to one

I tried that but it's not just the firmware but also in how (and which) kernel modules are called.
Changing all those will have a serious effect on how other Intel firmware is loaded .... probably messing up a lot.

Considering the apparently low demand (there's surprisingly little to find when searching) of those drivers, I got the impresion the kernel devs are just waiting out for Intel to clean up their mess.

For those few cases: I propose keeping a Retrowave Buster version available to download. :thinking:
IIRC @yoda also had a Broadwell soundcard on his Lenovo Yoga.

mmh well, that's the actual structure in elive:

  • new kernel from backports (which are meant to be compatible with debian-stable)
  • default kernel from debian-stable
  • firmwares are ported by elive from testing in order to have newer ones (maybe this was a bad idea and maybe the cause of some drivers not working good)

so i think maybe the firmwares should be kept as the default ones from the debian-stable + backports combination repos :thinking:, the question is: how you can make them working? or more exactly what is the problematic one exactly?

I don't have access to the machine ATM but it's down to the (multiple) "snd_***_intel" modules.
There's really a lot of them and many have changed or been replaced lately, just not for the Broadwell apparently.
In itself for the Helix it's only a minor discomfort. The built-in speakers are really total shit hardware, so I always use Bluetooth external devices anyway. :innocent:

It's not only Elive as I've already remarked. All distro's are in the same position unless they're built on an older base like Bodhi.

That said, Enlightenment (in any version) isn't any good on a tablet IMO.

well, elive should try to make it working as best as possible, so... maybe i should remove the firmwares from testing porting :thinking:

Whatever you do .... it's not going to get those Broadwell cards working.
For those having issues, to avoid them doing hasty stuff like installing 'pipewire' and such, to no avail ... it would be simply better to offer a Buster based version, if at all.

On top, I think that (even w.o this soundcard case) we need to have such a Retrowave Buster version there in the archives at the least.

yeah these versions are good to have especially for tests and comparison, but I still worried about making them working by default in the newer versions of elive :thinking:

I still wonder if the firmwares should come from debian-testing or left them to debian-stable+backports

What I can do this weekend is:
First install Bodhi 7 .... after which I'll let Elive do an up/crossgrade over it and I'll have a log sent over by the installer.

It should show where the actual changes went. :thinking:

Doesn't make much of a difference, the way I see it it comes down to Intel and they're not in a hurry considering how outdated the hardware is.

Did that on Saturday morning (local time) .... check the logs.

Oh yes, before I forge: This time the machine booted perfectly w.o any fiddling with grub. :smiley:

Mmh no not really :thinking: it will simply replace all the files at exception of /opt, users files, /usr/local, snaps, and a few more

Good to know :slight_smile:

So well, the only remaining thing to do now (sound card not working I assume), is to comment the Elive repos temporally, run "apu", and then apir the firmware packages, this will install the firmwares from stable+backports, instead of the ported ones by elive from debian-testing, which I pressume is the most likely issue. Optionally you can also install the kernel 6.1 which is the default provided from debian-stable, the 6.7 is from backports

Update: after to play with a recent hardware and found that Wifi 6 AX200 was not working, I tried to downgrade firmware-iwlwifi to the version from debian-stable and it worked, so the ports used from testing of the firmwares are going to be removed from elive since it shows that decreases compatibility

The version from SID also works, but not the ones from debian-testing

Not quite: Some of the previous firmware packages have been renamed or replaced .... so it will require a tad more than that, at the least an older kernel (6.1) that knows what to look for.

Just replacing the firmware did "nada" for the Helix.

kernel 6.9 just released, can you try it? im already running from it here :slight_smile:

about the firmwares, to me the ones from stable or from unstable worked, but not the ones from testing, the question is, elive should use the ones from stable or the ones from unstable which ideally should be the same ones with extra ones ? (which ideally should mean: more hardware supported without sacrificing compatibility)

@triantares I have also made this directory with compatible-debs you can install to try the different versions of the firmwares more easily: